aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2021-09-03 07:27:19 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2021-09-03 07:28:35 +0000
commitb3408688b0e693740017005e1221ca1d9ed376bc (patch)
tree821fd90e091f1ff2923dfab22cc57b93aabf126e
parenta418eaab5cae4da54593de29ef491b628a6051a6 (diff)
downloadports-b3408688b0e693740017005e1221ca1d9ed376bc.tar.gz
ports-b3408688b0e693740017005e1221ca1d9ed376bc.zip
editors/vim: Fix build under (non-poudriere) `make install'
-rw-r--r--editors/vim/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index c025cb68cb5c..7e12f30a8bb2 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -39,6 +39,7 @@ VIM_VER= ${PORTNAME}${PORTVERSION:R:S|.||g}
# FLAVORS are used to build various Vim GUIs. The default flavor (`vim') is
# console-only.
FLAVORS= console athena gtk2 gtk3 motif x11 tiny
+FLAVOR?= ${FLAVORS:[1]}
# Register conflicts with all other flavors
CONFLICTS_INSTALL= ${FLAVORS:N${FLAVOR}:S/^/vim-/}