aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-26 07:45:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-26 08:18:56 +0000
commitb3604071e107c58267902e03ba45d25e1a19d17f (patch)
tree3cb1e1bcc8d24260d820c42c68696f5ddc160e84
parent4eec09ad2592e4956342403d5b22562fd254e4a1 (diff)
downloadports-b3604071e107c58267902e03ba45d25e1a19d17f.tar.gz
ports-b3604071e107c58267902e03ba45d25e1a19d17f.zip
graphics/py-albumentations: New port: Fast image augmentation library and wrapper around other libraries
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-albumentations/Makefile25
-rw-r--r--graphics/py-albumentations/distinfo3
-rw-r--r--graphics/py-albumentations/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index ecaf6cb80fd6..2eda6b37dba7 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -843,6 +843,7 @@
SUBDIR += py-PyOpenGL
SUBDIR += py-PyOpenGL-accelerate
SUBDIR += py-actdiag
+ SUBDIR += py-albumentations
SUBDIR += py-altair
SUBDIR += py-asciitree
SUBDIR += py-beziers
diff --git a/graphics/py-albumentations/Makefile b/graphics/py-albumentations/Makefile
new file mode 100644
index 000000000000..60835c1107aa
--- /dev/null
+++ b/graphics/py-albumentations/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= albumentations
+DISTVERSION= 1.3.1
+CATEGORIES= graphics python # machine-learning
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast image augmentation library and wrapper around other libraries
+WWW= https://albumentations.ai/
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.11.1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}qudida>=0.0.4:graphics/py-qudida@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-image>=0.16.1:graphics/py-scikit-image@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.1.0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist pytest # 95 tests fail, see https://github.com/albumentations-team/albumentations/issues/1505
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-albumentations/distinfo b/graphics/py-albumentations/distinfo
new file mode 100644
index 000000000000..51738e8d5176
--- /dev/null
+++ b/graphics/py-albumentations/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1703558078
+SHA256 (albumentations-1.3.1.tar.gz) = a6a38388fe546c568071e8c82f414498e86c9ed03c08b58e7a88b31cf7a244c6
+SIZE (albumentations-1.3.1.tar.gz) = 176371
diff --git a/graphics/py-albumentations/pkg-descr b/graphics/py-albumentations/pkg-descr
new file mode 100644
index 000000000000..61867fe0a79d
--- /dev/null
+++ b/graphics/py-albumentations/pkg-descr
@@ -0,0 +1,5 @@
+Albumentations is a computer vision tool that boosts the performance of deep
+convolutional neural networks.
+
+The library is widely used in industry, deep learning research, machine learning
+competitions, and open source projects.