aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 10:38:01 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 12:01:44 +0000
commitb4630a2ae5e5f7ca9a20e77394b007f6ea79d662 (patch)
tree48daa3e383adc1427997bc59c0475498a71669bc
parent947cc0959eb798fb353dbc6096f53233631fd57d (diff)
downloadports-b4630a2ae5e5f7ca9a20e77394b007f6ea79d662.tar.gz
ports-b4630a2ae5e5f7ca9a20e77394b007f6ea79d662.zip
multimedia/ffmpegthumbnailer: Update to latest commit (2022-10-21)
Fixes build with FFmpeg 6.0 PR: 270224
-rw-r--r--multimedia/ffmpegthumbnailer/Makefile23
-rw-r--r--multimedia/ffmpegthumbnailer/distinfo6
-rw-r--r--multimedia/ffmpegthumbnailer/files/patch-CMakeLists.txt52
3 files changed, 15 insertions, 66 deletions
diff --git a/multimedia/ffmpegthumbnailer/Makefile b/multimedia/ffmpegthumbnailer/Makefile
index 5233f6156363..b686ad34347b 100644
--- a/multimedia/ffmpegthumbnailer/Makefile
+++ b/multimedia/ffmpegthumbnailer/Makefile
@@ -1,8 +1,7 @@
PORTNAME= ffmpegthumbnailer
-PORTVERSION= 2.2.2
-PORTREVISION= 1
+DISTVERSION= 2.2.2.a.20221021
CATEGORIES= multimedia graphics
-MASTER_SITES= https://github.com/dirkvdb/${PORTNAME}/releases/download/${PORTVERSION}/
+#MASTER_SITES= https://github.com/dirkvdb/${PORTNAME}/releases/download/${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Lightweight video thumbnailer that can be used by file managers
@@ -14,24 +13,26 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libavformat.so:multimedia/ffmpeg
-USES= cmake compiler:c++11-lib gnome jpeg localbase pkgconfig tar:bz2
+USES= cmake:testing compiler:c++11-lib gnome jpeg localbase pkgconfig tar:bz2
+USE_GITHUB= yes
+GH_ACCOUNT= dirkvdb
+GH_TAGNAME= e0bf01d
+
USE_GNOME= glib20
USE_LDCONFIG= yes
EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
+CMAKE_TESTING_ON= ENABLE_TESTS
+CMAKE_OFF= ENABLE_TESTS
CMAKE_ON= ENABLE_GIO
-OPTIONS_DEFINE= TEST THUMBNAILER
-THUMBNAILER_DESC=Register as a system thumbnailer
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= THUMBNAILER
OPTIONS_DEFAULT=THUMBNAILER
+OPTIONS_SUB= yes
-TEST_CMAKE_BOOL= ENABLE_TESTS
+THUMBNAILER_DESC= Register as a system thumbnailer
THUMBNAILER_CMAKE_ON= -DENABLE_THUMBNAILER:BOOL=ON
-do-test:
- (cd ${TEST_WRKSRC} && CTEST_OUTPUT_ON_FAILURE=1 ctest)
-
.include <bsd.port.mk>
diff --git a/multimedia/ffmpegthumbnailer/distinfo b/multimedia/ffmpegthumbnailer/distinfo
index e3f4747e9420..fe6986688b27 100644
--- a/multimedia/ffmpegthumbnailer/distinfo
+++ b/multimedia/ffmpegthumbnailer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1595238599
-SHA256 (ffmpegthumbnailer-2.2.2.tar.bz2) = 1cb24059c38223f657b300c84dd80491b7040d4b69471c4fea69be862bc99b5b
-SIZE (ffmpegthumbnailer-2.2.2.tar.bz2) = 1201838
+TIMESTAMP = 1678817076
+SHA256 (dirkvdb-ffmpegthumbnailer-2.2.2.a.20221021-e0bf01d_GH0.tar.gz) = 56e100ef6e6a8ce18e6015b79efad6601a636b03b6bcf9abf6b6f73c501e13e7
+SIZE (dirkvdb-ffmpegthumbnailer-2.2.2.a.20221021-e0bf01d_GH0.tar.gz) = 1291600
diff --git a/multimedia/ffmpegthumbnailer/files/patch-CMakeLists.txt b/multimedia/ffmpegthumbnailer/files/patch-CMakeLists.txt
deleted file mode 100644
index 2d065734fdf0..000000000000
--- a/multimedia/ffmpegthumbnailer/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,52 +0,0 @@
---- CMakeLists.txt.orig 2019-10-03 19:51:17 UTC
-+++ CMakeLists.txt
-@@ -1,4 +1,4 @@
--cmake_minimum_required(VERSION 3.5)
-+cmake_minimum_required(VERSION 3.12)
-
- list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
-
-@@ -92,6 +92,15 @@ add_library(libffmpegthumbnailerobj OBJECT
- libffmpegthumbnailer/filmstripfilter.cpp
- )
-
-+target_link_libraries(libffmpegthumbnailerobj
-+ FFmpeg::avformat
-+ FFmpeg::avcodec
-+ FFmpeg::avutil
-+ FFmpeg::avfilter
-+ $<$<BOOL:${HAVE_JPEG}>:${JPEG_LIBRARIES}>
-+ $<$<BOOL:${HAVE_PNG}>:PNG::PNG>
-+)
-+
- # we use our own deprecated struct menbers, so disable the warning about it
- set_source_files_properties(libffmpegthumbnailer/videothumbnailerc.cpp PROPERTIES COMPILE_FLAGS -Wno-deprecated-declarations)
-
-@@ -118,12 +127,7 @@ set (FFMPEGTHUMBNAILER_SOVERSION_AGE 1)
- if (ENABLE_STATIC)
- add_library(libffmpegthumbnailerstatic STATIC $<TARGET_OBJECTS:libffmpegthumbnailerobj>)
- target_link_libraries(libffmpegthumbnailerstatic
-- FFmpeg::avformat
-- FFmpeg::avcodec
-- FFmpeg::avutil
-- FFmpeg::avfilter
-- $<$<BOOL:${HAVE_JPEG}>:${JPEG_LIBRARIES}>
-- $<$<BOOL:${HAVE_PNG}>:PNG::PNG>
-+ libffmpegthumbnailerobj
- $<$<BOOL:${ENABLE_GIO}>:${CMAKE_DL_LIBS}>
- )
-
-@@ -140,12 +144,7 @@ endif ()
- if (ENABLE_SHARED)
- add_library(libffmpegthumbnailer SHARED $<TARGET_OBJECTS:libffmpegthumbnailerobj>)
- target_link_libraries(libffmpegthumbnailer
-- FFmpeg::avformat
-- FFmpeg::avcodec
-- FFmpeg::avutil
-- FFmpeg::avfilter
-- $<$<BOOL:${HAVE_JPEG}>:${JPEG_LIBRARIES}>
-- $<$<BOOL:${HAVE_PNG}>:PNG::PNG>
-+ libffmpegthumbnailerobj
- )
-
- set_target_properties(libffmpegthumbnailer PROPERTIES