aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-01-31 18:34:10 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-02-11 00:49:40 +0000
commitb49fedd5dc6d00d8f130972c17d5cd75fbd718fb (patch)
treeaca02a9e00c50e9bd79d1740c29b5848e96ef165
parent84cf50e4d307f135e55e111c6305352a82e8d3e2 (diff)
downloadports-b49fedd5dc6d00d8f130972c17d5cd75fbd718fb.tar.gz
ports-b49fedd5dc6d00d8f130972c17d5cd75fbd718fb.zip
games/openbor: update to 7610
-rw-r--r--games/openbor/Makefile4
-rw-r--r--games/openbor/distinfo6
-rw-r--r--games/openbor/files/patch-revert32
-rw-r--r--games/openbor/files/patch-source_utils.c16
4 files changed, 51 insertions, 7 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index c536eb113f65..1121f0c5f6e3 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -1,6 +1,6 @@
PORTNAME= openbor
# Hint: svn revision is git rev-list --count ${GH_TAGNAME}
-PORTVERSION?= 7586
+PORTVERSION?= 7610
PORTREVISION?= 0
CATEGORIES= games
@@ -35,7 +35,7 @@ PORTSCOUT= ignore:1
USE_GITHUB= yes
GH_ACCOUNT= DCurrent
-GH_TAGNAME?= 87ea891e
+GH_TAGNAME?= f4510854
USES+= cpe gmake pkgconfig sdl
.if ${PORTVERSION} < 4433
diff --git a/games/openbor/distinfo b/games/openbor/distinfo
index 6accd1c6e8e5..a803a4d63f53 100644
--- a/games/openbor/distinfo
+++ b/games/openbor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1706209104
-SHA256 (DCurrent-openbor-7586-87ea891e_GH0.tar.gz) = 14693862178fd4eb1e36fb9f9ac3122b77740a0755942fcc5823fe3165a047bd
-SIZE (DCurrent-openbor-7586-87ea891e_GH0.tar.gz) = 89138596
+TIMESTAMP = 1707519600
+SHA256 (DCurrent-openbor-7610-f4510854_GH0.tar.gz) = 0fe777b69a23e2913a37260dbf9c9c680a0376acfe0f2402a7b7fe6281bcfe0b
+SIZE (DCurrent-openbor-7610-f4510854_GH0.tar.gz) = 212696672
diff --git a/games/openbor/files/patch-revert b/games/openbor/files/patch-revert
new file mode 100644
index 000000000000..67ed7692f6cb
--- /dev/null
+++ b/games/openbor/files/patch-revert
@@ -0,0 +1,32 @@
+Partially revert https://github.com/DCurrent/openbor/commit/16939d70c3af
+due to breaking fonts with old games (e.g., Rocket Viper v2.41)
+
+--- openbor.c.orig 2024-02-09 23:00:00 UTC
++++ openbor.c
+@@ -46507,10 +46507,6 @@ void startup()
+ // init. input recorder
+ init_input_recorder();
+
+- printf("Loading fonts................\t");
+- load_all_fonts();
+- printf("Done!\n");
+-
+ printf("Loading sprites..............\t");
+ load_special_sprites();
+ printf("Done!\n");
+@@ -46545,9 +46541,13 @@ void startup()
+ load_menu_txt();
+ printf("Done!\n");
+
++ printf("Loading fonts................\t");
++ load_all_fonts();
++ printf("Done!\n");
++
+ /*
+- Kratus (01-2024) Moved the translation and menu functions to the end of the engine "startup" function,
+- but before the "control init" function (reverted the font function to load before scripts)
++ Kratus (10-2021) Moved the translation, menu and font functions to the end of the engine "startup" function,
++ but before the "control init" function
+ */
+ printf("Loading translation..........\t");
+ ob_inittrans();
diff --git a/games/openbor/files/patch-source_utils.c b/games/openbor/files/patch-source_utils.c
index 1693b73e8915..8558a0074446 100644
--- a/games/openbor/files/patch-source_utils.c
+++ b/games/openbor/files/patch-source_utils.c
@@ -1,3 +1,6 @@
+source/utils.c:18:10: fatal error: 'features.h' file not found
+ 18 | #include <features.h>
+ | ^~~~~~~~~~~~
source/utils.c:303:54: error: implicit declaration of function 'mallinfo' is invalid in C99
[-Werror,-Wimplicit-function-declaration]
writeToLogFile("Memory usage at exit: %u\n", mallinfo().arena);
@@ -6,9 +9,18 @@ source/utils.c:303:64: error: member reference base type 'int' is not a structur
writeToLogFile("Memory usage at exit: %u\n", mallinfo().arena);
~~~~~~~~~~^~~~~~
---- source/utils.c.orig 2024-01-02 00:04:19 UTC
+--- source/utils.c.orig 2024-02-01 15:55:11 UTC
+++ source/utils.c
-@@ -303,9 +303,7 @@ void *checkAlloc(void *ptr, size_t size, const char *f
+@@ -14,7 +14,7 @@
+ #include <locale.h>
+ #include <math.h>
+
+-#ifdef LINUX
++#if defined(__linux__)
+ #include <features.h>
+ #endif
+
+@@ -307,9 +307,7 @@ void *checkAlloc(void *ptr, size_t size, const char *f
"\n* Shutting Down *\n\n");
writeToLogFile("Out of memory!\n");
writeToLogFile("Allocation of size %i failed in function '%s' at %s:%i.\n", size, func, file, line);