aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2022-06-08 20:25:41 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2022-06-08 22:10:02 +0000
commitb4ca4c9cc1bd9eb29069fd92134bf7f9d9455190 (patch)
treefcac7a589ec1128465c7177c1879bda3eaf476d9
parent8f9452cdbb42dc86adfea23a7e2e3059caf937ee (diff)
downloadports-b4ca4c9cc1bd9eb29069fd92134bf7f9d9455190.tar.gz
ports-b4ca4c9cc1bd9eb29069fd92134bf7f9d9455190.zip
sysutils/arc_summary: New port
arc_summary is included in the OpenZFS repository. It provides basic information on the ZFS ARC, its efficiency, the L2ARC (if present), the Data Management Unit (DMU), Virtual Devices (VDEVs), and tunables. See the in-source documentation and code at https://github.com/openzfs/zfs/blob/master/module/zfs/arc.c for details. The original introduction to arc_summary can be found at http://cuddletech.com/?p=454. Reviewed by: diizzy Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D35441
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/arc_summary/Makefile31
-rw-r--r--sysutils/arc_summary/distinfo3
-rw-r--r--sysutils/arc_summary/pkg-descr7
4 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 9e952a4fe686..59564baf26cd 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -53,6 +53,7 @@
SUBDIR += apcpwr
SUBDIR += apcupsd
SUBDIR += aptly
+ SUBDIR += arc_summary
SUBDIR += arcconf
SUBDIR += archey4
SUBDIR += archivemount
diff --git a/sysutils/arc_summary/Makefile b/sysutils/arc_summary/Makefile
new file mode 100644
index 000000000000..57ef8d5078fa
--- /dev/null
+++ b/sysutils/arc_summary/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= arc_summary
+PORTVERSION= 20220410
+CATEGORIES= sysutils
+MASTER_SITES= https://raw.githubusercontent.com/openzfs/zfs/${_REV}/cmd/
+DISTFILES= ${PORTNAME}?${PORTVERSION}
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Print ZFS ARC cache statistics and other information
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sysctl>0:devel/py-sysctl@${PY_FLAVOR}
+
+USES= python shebangfix
+SHEBANG_FILES= ${PORTNAME}
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/arc_summary
+
+_REV= 0a9aaa7f0cc16f1771f492cce665bc5c5eb8e735
+
+do-extract:
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/sysutils/arc_summary/distinfo b/sysutils/arc_summary/distinfo
new file mode 100644
index 000000000000..aeb7eee05210
--- /dev/null
+++ b/sysutils/arc_summary/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1654724895
+SHA256 (arc_summary?20220410) = 6b46d2e3e3d935bf414bfbe49c82ddaa759ee5f1b75dd6dff676c17f10ffa9a2
+SIZE (arc_summary?20220410) = 33957
diff --git a/sysutils/arc_summary/pkg-descr b/sysutils/arc_summary/pkg-descr
new file mode 100644
index 000000000000..f6ce6a03d31c
--- /dev/null
+++ b/sysutils/arc_summary/pkg-descr
@@ -0,0 +1,7 @@
+arc_summary is included in the OpenZFS repository. It provides basic
+information on the ZFS ARC, its efficiency, the L2ARC (if present), the
+Data Management Unit (DMU), Virtual Devices (VDEVs), and tunables. See
+the in-source documentation and code at
+https://github.com/openzfs/zfs/blob/master/module/zfs/arc.c for details.
+The original introduction to arc_summary can be found at
+http://cuddletech.com/?p=454