aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-06-18 03:54:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-06-18 03:54:03 +0000
commitb59b9b6cbadb5338bd0a6b281e0096402afec80f (patch)
treef848f7cfe908a35c58dcfc9ec0cabd8e8ee04be0
parent64dcd813bef8aa4b7acdc26029e5ac5904ddfe4e (diff)
downloadports-b59b9b6cbadb5338bd0a6b281e0096402afec80f.tar.gz
ports-b59b9b6cbadb5338bd0a6b281e0096402afec80f.zip
textproc/rubygem-rexml32: Add rubygem-rexml32 3.2.8 (copied from rubygem-rexml)
- Add PORTSCOUT
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-rexml32/Makefile24
-rw-r--r--textproc/rubygem-rexml32/distinfo3
-rw-r--r--textproc/rubygem-rexml32/pkg-descr9
4 files changed, 37 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8463d78ab6ab..3a2c6292178d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1885,6 +1885,7 @@
SUBDIR += rubygem-representable
SUBDIR += rubygem-reverse_markdown
SUBDIR += rubygem-rexml
+ SUBDIR += rubygem-rexml32
SUBDIR += rubygem-ri_cal
SUBDIR += rubygem-rly
SUBDIR += rubygem-rmmseg-cpp
diff --git a/textproc/rubygem-rexml32/Makefile b/textproc/rubygem-rexml32/Makefile
new file mode 100644
index 000000000000..eea0bc027534
--- /dev/null
+++ b/textproc/rubygem-rexml32/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= rexml
+PORTVERSION= 3.2.8
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 32
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= XML toolkit for Ruby
+WWW= https://github.com/ruby/rexml
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-strscan>=3.0.9:devel/rubygem-strscan
+
+USES= cpe gem
+
+NO_ARCH= yes
+
+CPE_VENDOR= ruby-lang
+
+PORTSCOUT= limit:^3\.2\.
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-rexml32/distinfo b/textproc/rubygem-rexml32/distinfo
new file mode 100644
index 000000000000..7eb2f8b468ed
--- /dev/null
+++ b/textproc/rubygem-rexml32/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1716142206
+SHA256 (rubygem/rexml-3.2.8.gem) = 0908a86381d9f973824680df4e0a75422766272f03b1c0e49db7e79c23db1135
+SIZE (rubygem/rexml-3.2.8.gem) = 101888
diff --git a/textproc/rubygem-rexml32/pkg-descr b/textproc/rubygem-rexml32/pkg-descr
new file mode 100644
index 000000000000..bf3143c3967e
--- /dev/null
+++ b/textproc/rubygem-rexml32/pkg-descr
@@ -0,0 +1,9 @@
+REXML was inspired by the Electric XML library for Java, which features an
+easy-to-use API, small size, and speed. Hopefully, REXML, designed with the same
+philosophy, has these same features. I've tried to keep the API as intuitive as
+possible, and have followed the Ruby methodology for method naming and code
+flow, rather than mirroring the Java API.
+
+REXML supports both tree and stream document parsing. Stream parsing is faster
+(about 1.5 times as fast). However, with stream parsing, you don't get access to
+features such as XPath.