aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 08:55:17 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 09:06:32 +0000
commitb59d2f879d2123a09d4563a006443659128213ae (patch)
tree012a975d86b3683e9b1e77a4cc1961eb8715553f
parent27f9bd4c225ec784b992974fd49cfb0987dbf88b (diff)
downloadports-b59d2f879d2123a09d4563a006443659128213ae.tar.gz
ports-b59d2f879d2123a09d4563a006443659128213ae.zip
lang/ruby31: Fix orphaned .timestamp in 6021649ff0cee1ea88e34b5444c2fe31031ca29a
When both CAPIDOCS and DOCS options are enabled, the following commands are executed: 1. post-install-CAPIDOCS-on: removed the installed .timestamp (in STAGEDIR). 2. post-install-DOCS-on: copied the generated .timestamp (in capi directory) to the STAGEDIR again. Therefore, the installed .timestamp is orphaned. To fix this, we remove both the generated and installed .timestamp in post-install-CAPIDOCS-on:. PR: 267775 Reported by: yasu
-rw-r--r--lang/ruby31/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/ruby31/Makefile b/lang/ruby31/Makefile
index fa350ff2e52a..0bf41f00efa0 100644
--- a/lang/ruby31/Makefile
+++ b/lang/ruby31/Makefile
@@ -180,7 +180,7 @@ post-install:
.endif
post-install-CAPIDOCS-on:
- ${RM} ${STAGEDIR}${PREFIX}/share/doc/ruby${RUBY_SUFFIX}/capi/.timestamp
+ ${RM} ${WRKSRC}/doc/capi/.timestamp ${STAGEDIR}${PREFIX}/share/doc/ruby${RUBY_SUFFIX}/capi/.timestamp
cd ${STAGEDIR}${PREFIX} && ${FIND} share/doc/ruby${RUBY_SUFFIX}/capi/ -type f >> ${TMPPLIST}
post-install-DEBUG-off:
@@ -201,7 +201,7 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/ext/${FILE} \
${STAGEDIR}${RUBY_DOCDIR}/${FILE:C|^([^/]+)/.*|\1|}/
.endfor
- @(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${RUBY_DOCDIR}/ "! -name .timestamp")
+ @(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${RUBY_DOCDIR}/)
${INSTALL_DATA} ${WRKSRC}/COPYING* \
${WRKSRC}/ChangeLog \
${WRKSRC}/LEGAL \