aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2021-08-18 08:57:32 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-08-19 06:16:25 +0000
commitb5a7b4433120ded99f75c64b69b3c94224608728 (patch)
treef0589e38bf6a3ed7ad8608d922ca171d993b3920
parentf9550e0e8396f9f69ccdb81e890bd3fa5d8f298a (diff)
downloadports-b5a7b4433120ded99f75c64b69b3c94224608728.tar.gz
ports-b5a7b4433120ded99f75c64b69b3c94224608728.zip
graphics/tumble: Unbreak with -fno-common
Submitter becomes MAINTAINER. Already maintainer of several ports. Ref: https://github.com/brouhaha/tumble/issues/10 PR: 257913 MFH: 2021Q3 (cherry picked from commit 9ff864cb14876ee8dba7900e3afb7169e449b5f4)
-rw-r--r--graphics/tumble/Makefile11
-rw-r--r--graphics/tumble/files/patch-semantics.c11
-rw-r--r--graphics/tumble/files/patch-tumble__input.h8
3 files changed, 24 insertions, 6 deletions
diff --git a/graphics/tumble/Makefile b/graphics/tumble/Makefile
index df4ba6c30ddc..545a8fa9d2b8 100644
--- a/graphics/tumble/Makefile
+++ b/graphics/tumble/Makefile
@@ -1,19 +1,18 @@
# Created by: Rob Farmer <rfarmer@predatorlabs.net>
PORTNAME= tumble
-PORTVERSION= 0.36
DISTVERSIONPREFIX= v
+DISTVERSION= 0.36
+PORTREVISION= 1
CATEGORIES= graphics print
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fuz@fuz.su
COMMENT= Creates a PDF file from image files
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: blank_handler
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: blank_handler
-NOT_FOR_ARCHS= powerpc sparc64
+NOT_FOR_ARCHS= mips mips64 powerpc powerpc64 powerpcspe sparc64
NOT_FOR_ARCHS_REASON= Only works on little endian systems
LIB_DEPENDS= libtiff.so:graphics/tiff \
@@ -26,8 +25,8 @@ GH_ACCOUNT= brouhaha
CFLAGS+= -I${LOCALBASE}/include/netpbm
-PORTDOCS= README
PLIST_FILES= bin/tumble
+PORTDOCS= README
OPTIONS_DEFINE= DOCS
diff --git a/graphics/tumble/files/patch-semantics.c b/graphics/tumble/files/patch-semantics.c
new file mode 100644
index 000000000000..4e6e5d7d71bb
--- /dev/null
+++ b/graphics/tumble/files/patch-semantics.c
@@ -0,0 +1,11 @@
+--- semantics.c.orig 2021-08-17 12:37:41 UTC
++++ semantics.c
+@@ -119,7 +119,7 @@ typedef struct output_page_t
+ #endif
+
+
+-FILE *yyin;
++extern FILE *yyin;
+ int line; /* line number in spec file */
+
+ int bookmark_level;
diff --git a/graphics/tumble/files/patch-tumble__input.h b/graphics/tumble/files/patch-tumble__input.h
new file mode 100644
index 000000000000..cbac30796308
--- /dev/null
+++ b/graphics/tumble/files/patch-tumble__input.h
@@ -0,0 +1,8 @@
+--- tumble_input.h.orig 2021-08-17 12:36:31 UTC
++++ tumble_input.h
+@@ -71,4 +71,4 @@ void init_jpeg_handler (void);
+ void init_pbm_handler (void);
+ void init_png_handler (void);
+
+-input_handler_t blank_handler;
++extern input_handler_t blank_handler;