aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-11-15 04:49:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-11-15 04:49:15 +0000
commitb5f6999039f41dd29c9b7c4f7ab4294926c3ef30 (patch)
tree8a401ef1a8336133ebc87e5c2dc352dd51cbcd02
parentc198e10673e58ebd1a13259348591593f872b72b (diff)
downloadports-b5f6999039f41dd29c9b7c4f7ab4294926c3ef30.tar.gz
ports-b5f6999039f41dd29c9b7c4f7ab4294926c3ef30.zip
science/mopac: Update 7.1.15 -> 22.0.5
-rw-r--r--science/mopac/Makefile47
-rw-r--r--science/mopac/distinfo6
-rw-r--r--science/mopac/pkg-plist8
-rw-r--r--science/py-qcengine/Makefile2
4 files changed, 22 insertions, 41 deletions
diff --git a/science/mopac/Makefile b/science/mopac/Makefile
index cd15f9982ca8..a0835c53f71f 100644
--- a/science/mopac/Makefile
+++ b/science/mopac/Makefile
@@ -1,43 +1,32 @@
PORTNAME= mopac
-PORTVERSION= 7.${MOPAC_SUBVERSION}
-PORTREVISION= 8
+DISTVERSIONPREFIX= v
+DISTVERSION= 22.0.5
PORTEPOCH= 1
CATEGORIES= science # chemistry
-MASTER_SITES= http://bioinformatics.org/ghemical/download/%SUBDIR%/
-MASTER_SITE_SUBDIR= release20111012 current
-DISTNAME= mopac7-${MOPAC_SUBVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Semi-empirical (MNDO, etc.) molecular orbital calculation
-WWW= https://bioinformatics.org/ghemical/
+WWW= http://openmopac.net/
-LICENSE= GPLv2+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= fortran gmake libtool pathfix
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_LDCONFIG= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+TEST_DEPENDS= ${PYNUMPY}
-PORTEXAMPLES= *
-
-OPTIONS_DEFINE= EXAMPLES
+USES= blaslapack:openblas cmake:testing fortran python:test
+USE_LDCONFIG= yes
-MOPAC_SUBVERSION= 1.15
+USE_GITHUB= yes
+GH_ACCOUNT= openmopac
-post-patch:
- @${REINPLACE_CMD} -e '/usage/s|run_||g' \
- -e 's|./src/mopac7|${PREFIX}/libexec/mopac7|g' \
- ${WRKSRC}/run_${PORTNAME}7
+CMAKE_OFF= TESTS
+CMAKE_TESTING_ON= TESTS
+CMAKE_ARGS= -DPython3_EXECUTABLE=${PYTHON_CMD} #-DPython3_NumPy_INCLUDE_DIRS=${PYTHONPREFIX_SITELIBDIR}/numpy/core/include
-post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/run_${PORTNAME}7 \
- ${STAGEDIR}${PREFIX}/bin/${PORTNAME}7
- ${INSTALL_PROGRAM} ${WRKSRC}/fortran/.libs/${PORTNAME}7 \
- ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}7
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/test
- ${INSTALL_DATA} ${WRKSRC}/tests/*.dat ${STAGEDIR}${EXAMPLESDIR}/test
+PLIST_FILES= bin/mopac \
+ bin/mopac-makpol \
+ bin/mopac-param \
+ lib/libmopac.so \
+ lib/libmopac.so.1
.include <bsd.port.mk>
diff --git a/science/mopac/distinfo b/science/mopac/distinfo
index 2a8943e72967..d7a3f812a0fe 100644
--- a/science/mopac/distinfo
+++ b/science/mopac/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1655625116
-SHA256 (mopac7-1.15.tar.gz) = 6d7ac5d78522db70f7794fd816cea32829cfa9e93774202fe80ba5a54375fbaa
-SIZE (mopac7-1.15.tar.gz) = 764547
+TIMESTAMP = 1668486249
+SHA256 (openmopac-mopac-v22.0.5_GH0.tar.gz) = 48214514a7879fc5253db932a397fbfea0f35627c66694e170db1323454a1acc
+SIZE (openmopac-mopac-v22.0.5_GH0.tar.gz) = 15781547
diff --git a/science/mopac/pkg-plist b/science/mopac/pkg-plist
deleted file mode 100644
index 662c639fbc56..000000000000
--- a/science/mopac/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/mopac7
-include/mopac7/libmopac7.h
-lib/libmopac7.a
-lib/libmopac7.so
-lib/libmopac7.so.1
-lib/libmopac7.so.1.0.13
-libdata/pkgconfig/libmopac7.pc
-libexec/mopac7
diff --git a/science/py-qcengine/Makefile b/science/py-qcengine/Makefile
index fa03f6ece4ac..9cc06637eceb 100644
--- a/science/py-qcengine/Makefile
+++ b/science/py-qcengine/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py-cpuinfo>0:sysutils/py-py-cpuinfo@${PY_FLA
${PYTHON_PKGNAMEPREFIX}qcelemental>=0.24.0:science/py-qcelemental@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
- mopac>0:science/mopac \
+ mopac:science/mopac \
mrchem:science/${PYTHON_PKGNAMEPREFIX}mrchem \
nwchem:science/nwchem \
rdkit>0:science/rdkit \