aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:25:21 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:31:48 +0000
commitb640076400aae9bf0aefab793aead60de755ac54 (patch)
tree95cde5a7ec6e0b1a59be7637e8fdcac0dfafef43
parent6ab64b0e47928f8dea9baf9a7a17ed8abb75781c (diff)
downloadports-b640076400aae9bf0aefab793aead60de755ac54.tar.gz
ports-b640076400aae9bf0aefab793aead60de755ac54.zip
devel/py-nbformat: Update to 5.8.0
- Update LICENSE_FILE - Convert to USE_PYTHON=pep517 Changes: https://github.com/jupyter/nbformat/releases
-rw-r--r--devel/py-nbformat/Makefile11
-rw-r--r--devel/py-nbformat/distinfo6
-rw-r--r--devel/py-nbformat/files/setup.py64
3 files changed, 8 insertions, 73 deletions
diff --git a/devel/py-nbformat/Makefile b/devel/py-nbformat/Makefile
index 75055cedd301..5cc950b14ee4 100644
--- a/devel/py-nbformat/Makefile
+++ b/devel/py-nbformat/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nbformat
-PORTVERSION= 5.7.3
+PORTVERSION= 5.8.0
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -9,8 +9,10 @@ COMMENT= Jupyter Notebook format
WWW= https://jupyter.org/
LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/COPYING.md
+LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatch-nodejs-version>=0:devel/py-hatch-nodejs-version@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hatchling>=1.5:devel/py-hatchling@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fastjsonschema>=0:devel/py-fastjsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jsonschema>=2.6:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jupyter-core>=0:devel/py-jupyter-core@${PY_FLAVOR} \
@@ -23,7 +25,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}check-manifest>=0:devel/py-check-manifest@$
${PYTHON_PKGNAMEPREFIX}testpath>=0:devel/py-testpath@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
@@ -33,7 +35,4 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=3.6:devel/py-importlib-metadata@${PY_FLAVOR}
.endif
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.post.mk>
diff --git a/devel/py-nbformat/distinfo b/devel/py-nbformat/distinfo
index 3460cabf646c..fe426f49b550 100644
--- a/devel/py-nbformat/distinfo
+++ b/devel/py-nbformat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1674590812
-SHA256 (nbformat-5.7.3.tar.gz) = 4b021fca24d3a747bf4e626694033d792d594705829e5e35b14ee3369f9f6477
-SIZE (nbformat-5.7.3.tar.gz) = 140407
+TIMESTAMP = 1679499202
+SHA256 (nbformat-5.8.0.tar.gz) = 46dac64c781f1c34dfd8acba16547024110348f9fc7eab0f31981c2a3dc48d1f
+SIZE (nbformat-5.8.0.tar.gz) = 140655
diff --git a/devel/py-nbformat/files/setup.py b/devel/py-nbformat/files/setup.py
deleted file mode 100644
index 742972d0114a..000000000000
--- a/devel/py-nbformat/files/setup.py
+++ /dev/null
@@ -1,64 +0,0 @@
-# -*- coding: utf-8 -*-
-from setuptools import setup
-
-setup(
- name='nbformat',
- version='%%PORTVERSION%%',
- description='The Jupyter Notebook format',
- long_description='This package contains the base implementation of the Jupyter Notebook format,\nand Python APIs for working with notebooks.',
- author_email='Jupyter Development Team <jupyter@googlegroups.com>',
- classifiers=[
- 'Intended Audience :: Developers',
- 'Intended Audience :: Science/Research',
- 'Intended Audience :: System Administrators',
- 'License :: OSI Approved :: BSD License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: Python :: 3.9',
- 'Programming Language :: Python :: 3.10',
- 'Programming Language :: Python :: 3.11',
- ],
- install_requires=[
- 'fastjsonschema',
- 'importlib-metadata>=3.6; python_version < "3.8"',
- 'jsonschema>=2.6',
- 'jupyter-core',
- 'traitlets>=5.1',
- ],
- extras_require={
- 'docs': [
- 'myst-parser',
- 'pydata-sphinx-theme',
- 'sphinx',
- 'sphinxcontrib-github-alt',
- 'sphinxcontrib-spelling',
- ],
- 'test': [
- 'pep440',
- 'pre-commit',
- 'pytest',
- 'testpath',
- ],
- },
- entry_points={
- 'console_scripts': [
- 'jupyter-trust = nbformat.sign:TrustNotebookApp.launch_instance',
- ],
- },
- packages=[
- 'nbformat',
- 'nbformat.corpus',
- 'nbformat.corpus.tests',
- 'nbformat.v1',
- 'nbformat.v2',
- 'nbformat.v3',
- 'nbformat.v4',
- ],
- package_data = {
- 'nbformat': [
- '*/nbformat.*.schema.json',
- ]
- },
-)