aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-05-26 11:42:45 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-05-26 11:42:49 +0000
commitb6b85085a0882490dc3cfb68692eeffe4b4ae42c (patch)
tree3dd5183643c20d8b41368a29bf53c1bed6d15c16
parent0e9dbbb6d5654dc9afd778d592eabc4a3a4cce4e (diff)
downloadports-b6b85085a0882490dc3cfb68692eeffe4b4ae42c.tar.gz
ports-b6b85085a0882490dc3cfb68692eeffe4b4ae42c.zip
*/*: Remove incorrect libtool dependency
All these ports builds without libtool Tested using Poudriere Approved by: portmgr (blanket, build fix)
-rw-r--r--audio/audacity/Makefile2
-rw-r--r--devel/thrift-cpp/Makefile2
-rw-r--r--finance/gnucash/Makefile2
-rw-r--r--math/saga/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 2066cd6f58b3..848085220584 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -32,7 +32,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libwavpack.so:audio/wavpack
USES= cmake compiler:c++20-lang cpe desktop-file-utils gettext \
- gnome libtool python:build pkgconfig shared-mime-info
+ gnome python:build pkgconfig shared-mime-info
CPE_VENDOR= audacityteam
USE_GITHUB= yes
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 4a9891c3900d..7d62993f7226 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
DISTINFO_FILE= ${.CURDIR}/../thrift/distinfo
USES= bison cmake pkgconfig compiler:c++11-lang cpe \
- libtool pathfix ssl
+ pathfix ssl
CPE_VENDOR= apache
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index e474e319a168..975f3e4c8208 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= p5-Finance-Quote>=0:finance/p5-Finance-Quote \
p5-LWP-Protocol-https>=0:www/p5-LWP-Protocol-https
USES= cmake:insource compiler:c++11-lib cpe desktop-file-utils \
- gettext-tools gnome guile:2.2,3.0,conflicts libtool localbase \
+ gettext-tools gnome guile:2.2,3.0,conflicts localbase \
perl5 pkgconfig shebangfix tar:bzip2 xorg
USE_XORG= x11
USE_CXXSTD= c++11
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 1923264d9686..ae77b07f35f7 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -31,7 +31,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
RUN_DEPENDS:= swig:devel/swig
USES= cmake compiler:c++17-lang desktop-file-utils dos2unix gnome \
- iconv:wchar_t libtool localbase pkgconfig python
+ iconv:wchar_t localbase pkgconfig python
DOS2UNIX_GLOB= *.cpp *.h
USE_LDCONFIG= yes
USE_WX= 3.2+