aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-29 14:09:59 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-29 14:23:28 +0000
commitb70bac0f6ddf2c1cdd024f8a545d89ac6dcf351c (patch)
tree06719225f0304d9c8e4b628afc4885e4f4765964
parentcb124de0aa43b98b435c77306ba3c8e4adc78fb6 (diff)
downloadports-b70bac0f6ddf2c1cdd024f8a545d89ac6dcf351c.tar.gz
ports-b70bac0f6ddf2c1cdd024f8a545d89ac6dcf351c.zip
devel/p5-Adapter-Async: Add p5-Adapter-Async 0.019
Adapter::Async provides a way to link a data source with a view. WWW: https://metacpan.org/release/Adapter-Async
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Adapter-Async/Makefile32
-rw-r--r--devel/p5-Adapter-Async/distinfo3
-rw-r--r--devel/p5-Adapter-Async/pkg-descr3
-rw-r--r--devel/p5-Adapter-Async/pkg-plist19
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9ab9187c03b1..c3960581cb9d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1656,6 +1656,7 @@
SUBDIR += p5-Acme-Comment
SUBDIR += p5-Acme-Damn
SUBDIR += p5-Acme-MetaSyntactic
+ SUBDIR += p5-Adapter-Async
SUBDIR += p5-Agent
SUBDIR += p5-Algorithm-Accounting
SUBDIR += p5-Algorithm-Annotate
diff --git a/devel/p5-Adapter-Async/Makefile b/devel/p5-Adapter-Async/Makefile
new file mode 100644
index 000000000000..373463cd54d8
--- /dev/null
+++ b/devel/p5-Adapter-Async/Makefile
@@ -0,0 +1,32 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= Adapter-Async
+PORTVERSION= 0.019
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TEAM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Provide a way to link a data source with a view
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Future>=0.30:devel/p5-Future \
+ p5-List-BinarySearch>=0.25:devel/p5-List-BinarySearch \
+ p5-Log-Any>=0:devel/p5-Log-Any \
+ p5-Mixin-Event-Dispatch>=1.006:devel/p5-Mixin-Event-Dispatch \
+ p5-Variable-Disposition>=0.004:devel/p5-Variable-Disposition \
+ p5-curry>=0:devel/p5-curry
+TEST_DEPENDS= p5-Test-CheckDeps>=0.010:devel/p5-Test-CheckDeps \
+ p5-Test-Fatal>=0.010:devel/p5-Test-Fatal
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Adapter-Async/distinfo b/devel/p5-Adapter-Async/distinfo
new file mode 100644
index 000000000000..bdb23d05eded
--- /dev/null
+++ b/devel/p5-Adapter-Async/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619569387
+SHA256 (Adapter-Async-0.019.tar.gz) = bcecb4992eeb3868c79992277d549199534514d4dcb8510225bfee1fdfed5e41
+SIZE (Adapter-Async-0.019.tar.gz) = 25017
diff --git a/devel/p5-Adapter-Async/pkg-descr b/devel/p5-Adapter-Async/pkg-descr
new file mode 100644
index 000000000000..70137ec10003
--- /dev/null
+++ b/devel/p5-Adapter-Async/pkg-descr
@@ -0,0 +1,3 @@
+Adapter::Async provides a way to link a data source with a view.
+
+WWW: https://metacpan.org/release/Adapter-Async
diff --git a/devel/p5-Adapter-Async/pkg-plist b/devel/p5-Adapter-Async/pkg-plist
new file mode 100644
index 000000000000..510a89d2a583
--- /dev/null
+++ b/devel/p5-Adapter-Async/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/Adapter/Async.pm
+%%SITE_PERL%%/Adapter/Async/Bus.pm
+%%SITE_PERL%%/Adapter/Async/Bus.pod
+%%SITE_PERL%%/Adapter/Async/Model.pm
+%%SITE_PERL%%/Adapter/Async/OrderedList.pm
+%%SITE_PERL%%/Adapter/Async/OrderedList.pod
+%%SITE_PERL%%/Adapter/Async/OrderedList/Array.pm
+%%SITE_PERL%%/Adapter/Async/OrderedList/Array.pod
+%%SITE_PERL%%/Adapter/Async/UnorderedMap.pm
+%%SITE_PERL%%/Adapter/Async/UnorderedMap.pod
+%%SITE_PERL%%/Adapter/Async/UnorderedMap/Hash.pm
+%%SITE_PERL%%/Adapter/Async/UnorderedMap/Hash.pod
+%%PERL5_MAN3%%/Adapter::Async.3.gz
+%%PERL5_MAN3%%/Adapter::Async::Bus.3.gz
+%%PERL5_MAN3%%/Adapter::Async::Model.3.gz
+%%PERL5_MAN3%%/Adapter::Async::OrderedList.3.gz
+%%PERL5_MAN3%%/Adapter::Async::OrderedList::Array.3.gz
+%%PERL5_MAN3%%/Adapter::Async::UnorderedMap.3.gz
+%%PERL5_MAN3%%/Adapter::Async::UnorderedMap::Hash.3.gz