aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-10-07 04:50:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-10-07 04:54:02 +0000
commitb7c594ee694505271855f97416b22b0cc8c2d2b6 (patch)
tree4a22a4d4e17a876f7ceca8f95c1e8deb70eb9f03
parentd58343b5c942375f7cce160c6cd0dee433b2b948 (diff)
downloadports-b7c594ee694505271855f97416b22b0cc8c2d2b6.tar.gz
ports-b7c594ee694505271855f97416b22b0cc8c2d2b6.zip
cad/ghdl: Add SYNTH option; Remove --disable-libghdl; Remove unused deps
PR: 274240 Suggested by: Nico Sonack <nsonack@outlook.com>
-rw-r--r--cad/ghdl/Makefile18
-rw-r--r--cad/ghdl/pkg-plist5
2 files changed, 15 insertions, 8 deletions
diff --git a/cad/ghdl/Makefile b/cad/ghdl/Makefile
index 0cc0282cb15c..c57d1c86469d 100644
--- a/cad/ghdl/Makefile
+++ b/cad/ghdl/Makefile
@@ -1,7 +1,7 @@
PORTNAME= ghdl
DISTVERSIONPREFIX= v
DISTVERSION= 3.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
MAINTAINER= yuri@FreeBSD.org
@@ -11,9 +11,6 @@ WWW= https://github.com/ghdl/ghdl
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING.md
-LIB_DEPENDS= libgmp.so:math/gmp \
- libmpfr.so:math/mpfr \
- libmpc.so:math/mpc
TEST_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}pyTooling>=2.11.0:devel/py-pyTooling@${PY_FLAVOR}
@@ -27,22 +24,27 @@ GNU_CONFIGURE= yes
LLVMVER= 15 # last supported version, see https://github.com/ghdl/ghdl/blob/master/configure#L317
-CONFIGURE_ARGS= --disable-libghdl
-
+OPTIONS_DEFINE= SYNTH
OPTIONS_SINGLE= BACKEND
OPTIONS_SINGLE_BACKEND= MCODE LLVM
-OPTIONS_DEFAULT= LLVM
+OPTIONS_DEFAULT= LLVM SYNTH
OPTIONS_SUB= yes
MCODE_DESC= Use the MCODE backend
# MCODE is enabled by default and doesn't require any configuration options
LLVM_DESC= Code generator is LLVM
-LLVM_USES= libedit ncurses
+LLVM_USES= ncurses
LLVM_CONFIGURE_ON= --with-llvm-config=${LOCALBASE}/bin/llvm-config${LLVMVER}
LLVM_BUILD_DEPENDS= llvm-config${LLVMVER}:devel/llvm${LLVMVER}
LLVM_RUN_DEPENDS= llc${LLVMVER}:devel/llvm${LLVMVER}
+SYNTH_DESC= Enable Synthesis Features in ghdl
+SYNTH_CONFIGURE_ON= --enable-synth
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libghdl-3_0_0.so
+
post-install-MCODE-on:
@${STRIP_CMD} \
${STAGEDIR}${PREFIX}/bin/ghdl \
diff --git a/cad/ghdl/pkg-plist b/cad/ghdl/pkg-plist
index 7907e23413a4..067665654672 100644
--- a/cad/ghdl/pkg-plist
+++ b/cad/ghdl/pkg-plist
@@ -4,7 +4,12 @@ bin/ghwdump
include/ghdl/libghw.h
include/ghdl/vhpi_user.h
include/ghdl/vpi_user.h
+%%SYNTH%%include/ghdl/synth.h
+%%SYNTH%%include/ghdl/synth_gates.h
lib/ghdl/ansi_color.sh
+lib/libghdl-3_0_0.so
+lib/libghdl.a
+lib/libghdl.link
%%LLVM%%lib/ghdl/grt-exec.lst
%%LLVM%%lib/ghdl/grt-shared.lst
%%LLVM%%lib/ghdl/grt.lst