aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:32:02 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:07:13 +0000
commitb7ec1cb90ebe0d04cf3498b5e0ba08fdb3184eeb (patch)
tree2c6f3d87316bf58fad48511b2a439a81ca1c31dd
parent8cdc03c6a40f45e6c025a3182b02d5c3d2b5ffed (diff)
downloadports-b7ec1cb90ebe0d04cf3498b5e0ba08fdb3184eeb.tar.gz
ports-b7ec1cb90ebe0d04cf3498b5e0ba08fdb3184eeb.zip
devel/py-build: Update to 1.0.3
-rw-r--r--devel/py-build/Makefile9
-rw-r--r--devel/py-build/distinfo6
-rw-r--r--devel/py-build/files/patch-pyproject.toml10
3 files changed, 19 insertions, 6 deletions
diff --git a/devel/py-build/Makefile b/devel/py-build/Makefile
index 7a92c864d4da..963199efe16b 100644
--- a/devel/py-build/Makefile
+++ b/devel/py-build/Makefile
@@ -1,6 +1,5 @@
PORTNAME= build
-PORTVERSION= 0.10.0
-PORTREVISION= 2
+PORTVERSION= 1.0.3
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -22,10 +21,14 @@ USE_PYTHON= allflavors autoplist concurrent pep517
NO_ARCH= yes
PEP517_BUILD_CMD= ${PYTHON_CMD} -m flit_core.wheel
-PEP517_BUILD_DEPEND= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.4:devel/py-flit-core@${PY_FLAVOR}
+PEP517_BUILD_DEPEND= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.8:devel/py-flit-core@${PY_FLAVOR}
.include <bsd.port.pre.mk>
+#.if ${PYTHON_REL} < 31000
+#RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=4.6:devel/py-importlib-metadata@${PY_FLAVOR}
+#.endif
+
.if ${PYTHON_REL} < 31100
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tomli>=1.1.0:textproc/py-tomli@${PY_FLAVOR}
.endif
diff --git a/devel/py-build/distinfo b/devel/py-build/distinfo
index cf663b7225d6..4194a4ca5b19 100644
--- a/devel/py-build/distinfo
+++ b/devel/py-build/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1674589742
-SHA256 (build-0.10.0.tar.gz) = d5b71264afdb5951d6704482aac78de887c80691c52b88a9ad195983ca2c9269
-SIZE (build-0.10.0.tar.gz) = 16465
+TIMESTAMP = 1708449136
+SHA256 (build-1.0.3.tar.gz) = 538aab1b64f9828977f84bc63ae570b060a8ed1be419e7870b8b4fc5e6ea553b
+SIZE (build-1.0.3.tar.gz) = 40797
diff --git a/devel/py-build/files/patch-pyproject.toml b/devel/py-build/files/patch-pyproject.toml
new file mode 100644
index 000000000000..490ec54be0c2
--- /dev/null
+++ b/devel/py-build/files/patch-pyproject.toml
@@ -0,0 +1,10 @@
+--- pyproject.toml.orig 2023-09-06 22:31:16 UTC
++++ pyproject.toml
+@@ -36,7 +36,6 @@ dependencies = [
+ "pyproject_hooks",
+ # not actually a runtime dependency, only supplied as there is not "recommended dependency" support
+ 'colorama; os_name == "nt"',
+- 'importlib-metadata >= 4.6; python_version < "3.10"', # Not required for 3.8+, but fixes a stdlib bug
+ 'tomli >= 1.1.0; python_version < "3.11"',
+ ]
+