aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:39:54 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:05 +0000
commitb91537add951ab5890ec129b21cf65b5e165c324 (patch)
tree91474524c0ff3ec770d68456af87bb47a0e88731
parent4d15212d0b835056e029c14b935aede3ffa00941 (diff)
downloadports-b91537add951ab5890ec129b21cf65b5e165c324.tar.gz
ports-b91537add951ab5890ec129b21cf65b5e165c324.zip
ftp/curl: Use complete arguments/options
-rw-r--r--ftp/curl/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index a67deb9a7533..e50be3d2e2f9 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -16,7 +16,15 @@ USES= cpe libtool localbase pathfix perl5 shebangfix tar:xz
USE_PERL5= build
CONFIGURE_ARGS= --disable-werror \
+ --enable-dateparse \
+ --enable-dnsshuffle \
--enable-headers-api \
+ --enable-hsts \
+ --enable-http-auth \
+ --enable-mime \
+ --enable-netrc \
+ --enable-openssl-auto-load-config \
+ --enable-progress-meter \
--with-fish-functions-dir=${LOCALBASE}/share/fish/completions \
--with-zsh-functions-dir=${LOCALBASE}/share/zsh/site-functions
CONFIGURE_ENV= LOCALBASE=${LOCALBASE} \