aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2023-07-19 22:15:25 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2023-07-19 22:15:25 +0000
commitb958272778bff1767fea4fdc3de5695cf822ffdb (patch)
tree44a69fe85dd63c9d239fb8344f7a221a38bfaf6b
parent9211b19b39b87d157544a1a1b60008c6220b8881 (diff)
downloadports-b958272778bff1767fea4fdc3de5695cf822ffdb.tar.gz
ports-b958272778bff1767fea4fdc3de5695cf822ffdb.zip
devel/got: update to 0.91
User-visible changes: - add merge -M option which tells 'got merge' not to fast-forward a reference - add initial implementation of 'gotadmin dump' which creates Git bundle files - add initial implementation of 'gotadmin load' which loads Git bundle files - abort histedit if the user quits the editor without saving the script - add support for keywords as <commit> arguments to got and tog
-rw-r--r--devel/got/Makefile7
-rw-r--r--devel/got/distinfo6
-rw-r--r--devel/got/files/openbsd-compat/imsg-buffer.c242
-rw-r--r--devel/got/files/openbsd-compat/imsg.c51
-rw-r--r--devel/got/files/openbsd-compat/imsg.h24
-rw-r--r--devel/got/files/openbsd-compat/recallocarray.c4
-rw-r--r--devel/got/files/openbsd-compat/siphash.h4
-rw-r--r--devel/got/files/patch-lib_repository__admin.c11
-rw-r--r--devel/got/files/patch-regress_cmdline_Makefile8
9 files changed, 283 insertions, 74 deletions
diff --git a/devel/got/Makefile b/devel/got/Makefile
index 8eb25dc6825f..976746e4ab99 100644
--- a/devel/got/Makefile
+++ b/devel/got/Makefile
@@ -1,5 +1,5 @@
PORTNAME= got
-DISTVERSION= 0.90
+DISTVERSION= 0.91
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/
@@ -28,7 +28,8 @@ post-extract:
# installed got
# installed git
# ssh to 127.0.0.1
-regress:
- @(cd ${WRKSRC}/regress && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} regress)
+### Disabled due to unportable shell constructs in 0.91
+#regress:
+# @(cd ${WRKSRC}/regress && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} regress)
.include <bsd.port.mk>
diff --git a/devel/got/distinfo b/devel/got/distinfo
index 29e9377887d1..67a6a8216b99 100644
--- a/devel/got/distinfo
+++ b/devel/got/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1687559108
-SHA256 (got-0.90.tar.gz) = 35ae134f37848ecfb1ced0e18d0bcfbaada056e3e603dcaa8333b08ffbc7eb1f
-SIZE (got-0.90.tar.gz) = 830029
+TIMESTAMP = 1689803487
+SHA256 (got-0.91.tar.gz) = 12c93975847e0f85f4ca192fb95770f13e73677eebdb8c692a98a6b294c48b9b
+SIZE (got-0.91.tar.gz) = 923998
diff --git a/devel/got/files/openbsd-compat/imsg-buffer.c b/devel/got/files/openbsd-compat/imsg-buffer.c
index a9f0c4053d9f..8bac2a0531ae 100644
--- a/devel/got/files/openbsd-compat/imsg-buffer.c
+++ b/devel/got/files/openbsd-compat/imsg-buffer.c
@@ -1,4 +1,4 @@
-/* $OpenBSD: imsg-buffer.c,v 1.14 2022/04/23 08:57:52 tobias Exp $ */
+/* $OpenBSD: imsg-buffer.c,v 1.16 2023/06/19 17:19:50 claudio Exp $ */
/*
* Copyright (c) 2003, 2004 Henning Brauer <henning@openbsd.org>
@@ -23,6 +23,7 @@
#include <limits.h>
#include <errno.h>
+#include <endian.h>
#include <stdlib.h>
#include <string.h>
#include <unistd.h>
@@ -34,15 +35,20 @@
static int ibuf_realloc(struct ibuf *, size_t);
static void ibuf_enqueue(struct msgbuf *, struct ibuf *);
static void ibuf_dequeue(struct msgbuf *, struct ibuf *);
+static void msgbuf_drain(struct msgbuf *, size_t);
struct ibuf *
ibuf_open(size_t len)
{
struct ibuf *buf;
+ if (len == 0) {
+ errno = EINVAL;
+ return (NULL);
+ }
if ((buf = calloc(1, sizeof(struct ibuf))) == NULL)
return (NULL);
- if ((buf->buf = malloc(len)) == NULL) {
+ if ((buf->buf = calloc(len, 1)) == NULL) {
free(buf);
return (NULL);
}
@@ -57,14 +63,22 @@ ibuf_dynamic(size_t len, size_t max)
{
struct ibuf *buf;
- if (max < len)
+ if (max < len) {
+ errno = EINVAL;
return (NULL);
+ }
- if ((buf = ibuf_open(len)) == NULL)
+ if ((buf = calloc(1, sizeof(struct ibuf))) == NULL)
return (NULL);
-
- if (max > 0)
- buf->max = max;
+ if (len > 0) {
+ if ((buf->buf = calloc(len, 1)) == NULL) {
+ free(buf);
+ return (NULL);
+ }
+ }
+ buf->size = len;
+ buf->max = max;
+ buf->fd = -1;
return (buf);
}
@@ -89,23 +103,6 @@ ibuf_realloc(struct ibuf *buf, size_t len)
return (0);
}
-int
-ibuf_add(struct ibuf *buf, const void *data, size_t len)
-{
- if (len > SIZE_MAX - buf->wpos) {
- errno = ERANGE;
- return (-1);
- }
-
- if (buf->wpos + len > buf->size)
- if (ibuf_realloc(buf, len) == -1)
- return (-1);
-
- memcpy(buf->buf + buf->wpos, data, len);
- buf->wpos += len;
- return (0);
-}
-
void *
ibuf_reserve(struct ibuf *buf, size_t len)
{
@@ -122,19 +119,160 @@ ibuf_reserve(struct ibuf *buf, size_t len)
b = buf->buf + buf->wpos;
buf->wpos += len;
+ memset(b, 0, len);
return (b);
}
+int
+ibuf_add(struct ibuf *buf, const void *data, size_t len)
+{
+ void *b;
+
+ if ((b = ibuf_reserve(buf, len)) == NULL)
+ return (-1);
+
+ memcpy(b, data, len);
+ return (0);
+}
+
+int
+ibuf_add_buf(struct ibuf *buf, const struct ibuf *from)
+{
+ return ibuf_add(buf, from->buf, from->wpos);
+}
+
+int
+ibuf_add_n8(struct ibuf *buf, uint64_t value)
+{
+ uint8_t v;
+
+ if (value > UINT8_MAX) {
+ errno = EINVAL;
+ return (-1);
+ }
+ v = value;
+ return ibuf_add(buf, &v, sizeof(v));
+}
+
+int
+ibuf_add_n16(struct ibuf *buf, uint64_t value)
+{
+ uint16_t v;
+
+ if (value > UINT16_MAX) {
+ errno = EINVAL;
+ return (-1);
+ }
+ v = htobe16(value);
+ return ibuf_add(buf, &v, sizeof(v));
+}
+
+int
+ibuf_add_n32(struct ibuf *buf, uint64_t value)
+{
+ uint32_t v;
+
+ if (value > UINT32_MAX) {
+ errno = EINVAL;
+ return (-1);
+ }
+ v = htobe32(value);
+ return ibuf_add(buf, &v, sizeof(v));
+}
+
+int
+ibuf_add_n64(struct ibuf *buf, uint64_t value)
+{
+ value = htobe64(value);
+ return ibuf_add(buf, &value, sizeof(value));
+}
+
+int
+ibuf_add_zero(struct ibuf *buf, size_t len)
+{
+ void *b;
+
+ if ((b = ibuf_reserve(buf, len)) == NULL)
+ return (-1);
+ return (0);
+}
+
void *
ibuf_seek(struct ibuf *buf, size_t pos, size_t len)
{
/* only allowed to seek in already written parts */
- if (len > SIZE_MAX - pos || pos + len > buf->wpos)
+ if (len > SIZE_MAX - pos || pos + len > buf->wpos) {
+ errno = ERANGE;
return (NULL);
+ }
return (buf->buf + pos);
}
+int
+ibuf_set(struct ibuf *buf, size_t pos, const void *data, size_t len)
+{
+ void *b;
+
+ if ((b = ibuf_seek(buf, pos, len)) == NULL)
+ return (-1);
+
+ memcpy(b, data, len);
+ return (0);
+}
+
+int
+ibuf_set_n8(struct ibuf *buf, size_t pos, uint64_t value)
+{
+ uint8_t v;
+
+ if (value > UINT8_MAX) {
+ errno = EINVAL;
+ return (-1);
+ }
+ v = value;
+ return (ibuf_set(buf, pos, &v, sizeof(v)));
+}
+
+int
+ibuf_set_n16(struct ibuf *buf, size_t pos, uint64_t value)
+{
+ uint16_t v;
+
+ if (value > UINT16_MAX) {
+ errno = EINVAL;
+ return (-1);
+ }
+ v = htobe16(value);
+ return (ibuf_set(buf, pos, &v, sizeof(v)));
+}
+
+int
+ibuf_set_n32(struct ibuf *buf, size_t pos, uint64_t value)
+{
+ uint32_t v;
+
+ if (value > UINT32_MAX) {
+ errno = EINVAL;
+ return (-1);
+ }
+ v = htobe32(value);
+ return (ibuf_set(buf, pos, &v, sizeof(v)));
+}
+
+int
+ibuf_set_n64(struct ibuf *buf, size_t pos, uint64_t value)
+{
+ value = htobe64(value);
+ return (ibuf_set(buf, pos, &value, sizeof(value)));
+}
+
+void *
+ibuf_data(struct ibuf *buf)
+{
+ return (buf->buf);
+}
+
size_t
ibuf_size(struct ibuf *buf)
{
@@ -153,6 +291,45 @@ ibuf_close(struct msgbuf *msgbuf, struct ibuf *buf)
ibuf_enqueue(msgbuf, buf);
}
+void
+ibuf_free(struct ibuf *buf)
+{
+ if (buf == NULL)
+ return;
+#ifdef NOTYET
+ if (buf->fd != -1)
+ close(buf->fd);
+#endif
+ freezero(buf->buf, buf->size);
+ free(buf);
+}
+
+int
+ibuf_fd_avail(struct ibuf *buf)
+{
+ return (buf->fd != -1);
+}
+
+int
+ibuf_fd_get(struct ibuf *buf)
+{
+ int fd;
+
+ fd = buf->fd;
+#ifdef NOTYET
+ buf->fd = -1;
+#endif
+ return (fd);
+}
+
+void
+ibuf_fd_set(struct ibuf *buf, int fd)
+{
+ if (buf->fd != -1)
+ close(buf->fd);
+ buf->fd = fd;
+}
+
int
ibuf_write(struct msgbuf *msgbuf)
{
@@ -190,15 +367,6 @@ again:
}
void
-ibuf_free(struct ibuf *buf)
-{
- if (buf == NULL)
- return;
- freezero(buf->buf, buf->size);
- free(buf);
-}
-
-void
msgbuf_init(struct msgbuf *msgbuf)
{
msgbuf->queued = 0;
@@ -206,7 +374,7 @@ msgbuf_init(struct msgbuf *msgbuf)
TAILQ_INIT(&msgbuf->bufs);
}
-void
+static void
msgbuf_drain(struct msgbuf *msgbuf, size_t n)
{
struct ibuf *buf, *next;
@@ -315,8 +483,10 @@ ibuf_dequeue(struct msgbuf *msgbuf, struct ibuf *buf)
{
TAILQ_REMOVE(&msgbuf->bufs, buf, entry);
- if (buf->fd != -1)
+ if (buf->fd != -1) {
close(buf->fd);
+ buf->fd = -1;
+ }
msgbuf->queued--;
ibuf_free(buf);
diff --git a/devel/got/files/openbsd-compat/imsg.c b/devel/got/files/openbsd-compat/imsg.c
index e70e6d4b3e85..9a981adf06be 100644
--- a/devel/got/files/openbsd-compat/imsg.c
+++ b/devel/got/files/openbsd-compat/imsg.c
@@ -1,4 +1,4 @@
-/* $OpenBSD: imsg.c,v 1.17 2022/01/28 10:41:44 claudio Exp $ */
+/* $OpenBSD: imsg.c,v 1.19 2023/06/19 17:19:50 claudio Exp $ */
/*
* Copyright (c) 2003, 2004 Henning Brauer <henning@openbsd.org>
@@ -177,8 +177,7 @@ imsg_compose(struct imsgbuf *ibuf, uint32_t type, uint32_t peerid, pid_t pid,
if (imsg_add(wbuf, data, datalen) == -1)
return (-1);
- wbuf->fd = fd;
-
+ ibuf_fd_set(wbuf, fd);
imsg_close(ibuf, wbuf);
return (1);
@@ -201,14 +200,49 @@ imsg_composev(struct imsgbuf *ibuf, uint32_t type, uint32_t peerid, pid_t pid,
if (imsg_add(wbuf, iov[i].iov_base, iov[i].iov_len) == -1)
return (-1);
- wbuf->fd = fd;
-
+ ibuf_fd_set(wbuf, fd);
imsg_close(ibuf, wbuf);
return (1);
}
-/* ARGSUSED */
+int
+imsg_compose_ibuf(struct imsgbuf *ibuf, uint32_t type, uint32_t peerid,
+ pid_t pid, struct ibuf *buf)
+{
+ struct ibuf *wbuf = NULL;
+ struct imsg_hdr hdr;
+ int save_errno;
+
+ if (ibuf_size(buf) + IMSG_HEADER_SIZE > MAX_IMSGSIZE) {
+ errno = ERANGE;
+ goto fail;
+ }
+
+ hdr.type = type;
+ hdr.len = ibuf_size(buf) + IMSG_HEADER_SIZE;
+ hdr.flags = 0;
+ hdr.peerid = peerid;
+ if ((hdr.pid = pid) == 0)
+ hdr.pid = ibuf->pid;
+
+ if ((wbuf = ibuf_open(IMSG_HEADER_SIZE)) == NULL)
+ goto fail;
+ if (imsg_add(wbuf, &hdr, sizeof(hdr)) == -1)
+ goto fail;
+
+ ibuf_close(&ibuf->w, wbuf);
+ ibuf_close(&ibuf->w, buf);
+ return (1);
+
+ fail:
+ save_errno = errno;
+ ibuf_free(buf);
+ ibuf_free(wbuf);
+ errno = save_errno;
+ return (-1);
+}
+
struct ibuf *
imsg_create(struct imsgbuf *ibuf, uint32_t type, uint32_t peerid, pid_t pid,
uint16_t datalen)
@@ -255,10 +289,9 @@ imsg_close(struct imsgbuf *ibuf, struct ibuf *msg)
hdr = (struct imsg_hdr *)msg->buf;
hdr->flags &= ~IMSGF_HASFD;
- if (msg->fd != -1)
+ if (ibuf_fd_avail(msg))
hdr->flags |= IMSGF_HASFD;
-
- hdr->len = (uint16_t)msg->wpos;
+ hdr->len = ibuf_size(msg);
ibuf_close(&ibuf->w, msg);
}
diff --git a/devel/got/files/openbsd-compat/imsg.h b/devel/got/files/openbsd-compat/imsg.h
index 9e19bedb893d..fb516e302873 100644
--- a/devel/got/files/openbsd-compat/imsg.h
+++ b/devel/got/files/openbsd-compat/imsg.h
@@ -1,4 +1,4 @@
-/* $OpenBSD: imsg.h,v 1.6 2021/01/13 09:56:28 claudio Exp $ */
+/* $OpenBSD: imsg.h,v 1.7 2023/06/19 17:19:50 claudio Exp $ */
/*
* Copyright (c) 2006, 2007 Pierre-Yves Ritschard <pyr@openbsd.org>
@@ -80,21 +80,35 @@ struct imsg {
struct iovec;
-/* buffer.c */
+/* imsg-buffer.c */
struct ibuf *ibuf_open(size_t);
struct ibuf *ibuf_dynamic(size_t, size_t);
int ibuf_add(struct ibuf *, const void *, size_t);
+int ibuf_add_buf(struct ibuf *, const struct ibuf *);
+int ibuf_add_zero(struct ibuf *, size_t);
+int ibuf_add_n8(struct ibuf *, uint64_t);
+int ibuf_add_n16(struct ibuf *, uint64_t);
+int ibuf_add_n32(struct ibuf *, uint64_t);
+int ibuf_add_n64(struct ibuf *, uint64_t);
void *ibuf_reserve(struct ibuf *, size_t);
void *ibuf_seek(struct ibuf *, size_t, size_t);
+int ibuf_set(struct ibuf *, size_t, const void *, size_t);
+int ibuf_set_n8(struct ibuf *, size_t, uint64_t);
+int ibuf_set_n16(struct ibuf *, size_t, uint64_t);
+int ibuf_set_n32(struct ibuf *, size_t, uint64_t);
+int ibuf_set_n64(struct ibuf *, size_t, uint64_t);
+void *ibuf_data(struct ibuf *);
size_t ibuf_size(struct ibuf *);
size_t ibuf_left(struct ibuf *);
void ibuf_close(struct msgbuf *, struct ibuf *);
-int ibuf_write(struct msgbuf *);
void ibuf_free(struct ibuf *);
+int ibuf_fd_avail(struct ibuf *);
+int ibuf_fd_get(struct ibuf *);
+void ibuf_fd_set(struct ibuf *, int);
+int ibuf_write(struct msgbuf *);
void msgbuf_init(struct msgbuf *);
void msgbuf_clear(struct msgbuf *);
int msgbuf_write(struct msgbuf *);
-void msgbuf_drain(struct msgbuf *, size_t);
/* imsg.c */
void imsg_init(struct imsgbuf *, int);
@@ -104,6 +118,8 @@ int imsg_compose(struct imsgbuf *, uint32_t, uint32_t, pid_t, int,
const void *, uint16_t);
int imsg_composev(struct imsgbuf *, uint32_t, uint32_t, pid_t, int,
const struct iovec *, int);
+int imsg_compose_ibuf(struct imsgbuf *, uint32_t, uint32_t, pid_t,
+ struct ibuf *);
struct ibuf *imsg_create(struct imsgbuf *, uint32_t, uint32_t, pid_t, uint16_t);
int imsg_add(struct ibuf *, const void *, uint16_t);
void imsg_close(struct imsgbuf *, struct ibuf *);
diff --git a/devel/got/files/openbsd-compat/recallocarray.c b/devel/got/files/openbsd-compat/recallocarray.c
index c81a4e7130fd..6fcb1d361b4b 100644
--- a/devel/got/files/openbsd-compat/recallocarray.c
+++ b/devel/got/files/openbsd-compat/recallocarray.c
@@ -1,4 +1,4 @@
-/* $OpenBSD: recallocarray.c,v 1.1 2017/03/06 18:44:21 otto Exp $ */
+/* $OpenBSD: recallocarray.c,v 1.2 2021/03/18 11:16:58 claudio Exp $ */
/*
* Copyright (c) 2008, 2017 Otto Moerbeek <otto@drijf.net>
*
@@ -59,7 +59,7 @@ recallocarray(void *ptr, size_t oldnmemb, size_t newnmemb, size_t size)
if (newsize <= oldsize) {
size_t d = oldsize - newsize;
- if (d < oldsize / 2 && d < getpagesize()) {
+ if (d < oldsize / 2 && d < (size_t)getpagesize()) {
memset((char *)ptr + newsize, 0, d);
return ptr;
}
diff --git a/devel/got/files/openbsd-compat/siphash.h b/devel/got/files/openbsd-compat/siphash.h
index 7a5990c93954..471c965690c2 100644
--- a/devel/got/files/openbsd-compat/siphash.h
+++ b/devel/got/files/openbsd-compat/siphash.h
@@ -26,7 +26,7 @@
* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
* SUCH DAMAGE.
*
- * $OpenBSD: siphash.h,v 1.3 2015/02/20 11:51:03 tedu Exp $
+ * $OpenBSD: siphash.h,v 1.4 2022/12/27 07:44:56 jmc Exp $
*/
/*
@@ -34,7 +34,7 @@
* optimized for speed on short messages returning a 64bit hash/digest value.
*
* The number of rounds is defined during the initialization:
- * SipHash24_Init() for the fast and resonable strong version
+ * SipHash24_Init() for the fast and reasonable strong version
* SipHash48_Init() for the strong version (half as fast)
*
* struct SIPHASH_CTX ctx;
diff --git a/devel/got/files/patch-lib_repository__admin.c b/devel/got/files/patch-lib_repository__admin.c
deleted file mode 100644
index a7be54c5f512..000000000000
--- a/devel/got/files/patch-lib_repository__admin.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/repository_admin.c.orig 2023-06-24 15:03:03 UTC
-+++ lib/repository_admin.c
-@@ -620,7 +620,7 @@ got_repo_cleanup_prepare(struct got_repository *repo,
- struct got_lockfile **lk)
- {
- const struct got_error *err;
-- char myname[HOST_NAME_MAX + 1];
-+ char myname[_POSIX_HOST_NAME_MAX + 1];
-
- if (gethostname(myname, sizeof(myname)) == -1)
- return got_error_from_errno("gethostname");
diff --git a/devel/got/files/patch-regress_cmdline_Makefile b/devel/got/files/patch-regress_cmdline_Makefile
index c11c9f731001..2f2640e43ccf 100644
--- a/devel/got/files/patch-regress_cmdline_Makefile
+++ b/devel/got/files/patch-regress_cmdline_Makefile
@@ -1,8 +1,8 @@
---- regress/cmdline/Makefile.orig 2022-05-10 11:21:59 UTC
+--- regress/cmdline/Makefile.orig 2023-07-10 07:49:48 UTC
+++ regress/cmdline/Makefile
-@@ -97,4 +97,6 @@ cleanup:
- ./cleanup.sh -q -r "$(GOT_TEST_ROOT)"
-
+@@ -105,4 +105,6 @@ dump:
+ load:
+ ./load.sh -q -r "$(GOT_TEST_ROOT)"
-.include <bsd.regress.mk>
+regress: ${REGRESS_TARGETS} .PHONY .SILENT