aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2022-03-29 09:00:44 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2022-03-29 09:00:44 +0000
commitb96a774d388f6c06577b2dafffbbf6441c281ba7 (patch)
tree2d1baac9b747d38604a32009ad0aba917a014984
parentafb00a01ee69d3e5f2e4ba8b0f609662760ab620 (diff)
downloadports-b96a774d388f6c06577b2dafffbbf6441c281ba7.tar.gz
ports-b96a774d388f6c06577b2dafffbbf6441c281ba7.zip
Add net/wireproxy: Wireguard client that exposes itself as a socks5 proxy
-rw-r--r--net/Makefile1
-rw-r--r--net/wireproxy/Makefile20
-rw-r--r--net/wireproxy/distinfo5
-rw-r--r--net/wireproxy/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2d0ca8a3edc5..fd7d58ee9510 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1566,6 +1566,7 @@
SUBDIR += wireguard-go
SUBDIR += wireguard-kmod
SUBDIR += wireguard-tools
+ SUBDIR += wireproxy
SUBDIR += wireshark
SUBDIR += wireshark-lite
SUBDIR += wlan2eth
diff --git a/net/wireproxy/Makefile b/net/wireproxy/Makefile
new file mode 100644
index 000000000000..3545b2d17bfc
--- /dev/null
+++ b/net/wireproxy/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= wireproxy
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.0.0-20220329034706
+DISTVERSIONSUFFIX= -4a4e7a79ab7f
+CATEGORIES= net
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Wireguard client that exposes itself as a socks5 proxy
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/octeep/wireproxy
+GO_TARGET= ./cmd/wireproxy
+
+PLIST_FILES= bin/wireproxy
+
+.include <bsd.port.mk>
diff --git a/net/wireproxy/distinfo b/net/wireproxy/distinfo
new file mode 100644
index 000000000000..e8089845f821
--- /dev/null
+++ b/net/wireproxy/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1648543118
+SHA256 (go/net_wireproxy/wireproxy-v0.0.0-20220329034706-4a4e7a79ab7f/v0.0.0-20220329034706-4a4e7a79ab7f.mod) = ba168f770947b7b24cc560a6efb90ac644ca0d1ce6fc9ab2e91c53d67e8b9403
+SIZE (go/net_wireproxy/wireproxy-v0.0.0-20220329034706-4a4e7a79ab7f/v0.0.0-20220329034706-4a4e7a79ab7f.mod) = 790
+SHA256 (go/net_wireproxy/wireproxy-v0.0.0-20220329034706-4a4e7a79ab7f/v0.0.0-20220329034706-4a4e7a79ab7f.zip) = bab5520168a5477a6f365a46850776eb2fbdf48cad5ea43205dca84fae382ba5
+SIZE (go/net_wireproxy/wireproxy-v0.0.0-20220329034706-4a4e7a79ab7f/v0.0.0-20220329034706-4a4e7a79ab7f.zip) = 45637
diff --git a/net/wireproxy/pkg-descr b/net/wireproxy/pkg-descr
new file mode 100644
index 000000000000..aa7c00d23673
--- /dev/null
+++ b/net/wireproxy/pkg-descr
@@ -0,0 +1,6 @@
+wireproxy is a completely userspace application that connects to a wireguard
+peer, and exposes a socks5 proxy or tunnels on the machine. This can be useful
+if you need to connect to certain sites via a wireguard peer, but can't be
+bothered to setup a new network interface for whatever reasons.
+
+WWW: https://github.com/octeep/wireproxy