aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2022-10-01 20:55:22 +0000
committerCraig Leres <leres@FreeBSD.org>2022-10-01 20:55:22 +0000
commitb9aacaac4e96beac486b388652595a9ed5140bd1 (patch)
treef513271a30b1d6c6760d4ff2b53d09c6ebce19ad
parent42bef93dbcdf98a7a70bb507ca947fd6a616d281 (diff)
downloadports-b9aacaac4e96beac486b388652595a9ed5140bd1.tar.gz
ports-b9aacaac4e96beac486b388652595a9ed5140bd1.zip
net/savvycan: Add patch to allow 33.333 kbps
-rw-r--r--net/savvycan/Makefile1
-rw-r--r--net/savvycan/files/patch-connections_connectionwindow.cpp10
2 files changed, 11 insertions, 0 deletions
diff --git a/net/savvycan/Makefile b/net/savvycan/Makefile
index fb201fb9c0cb..ce311016ae93 100644
--- a/net/savvycan/Makefile
+++ b/net/savvycan/Makefile
@@ -1,5 +1,6 @@
PORTNAME= savvycan
PORTVERSION= 1.0.245
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
diff --git a/net/savvycan/files/patch-connections_connectionwindow.cpp b/net/savvycan/files/patch-connections_connectionwindow.cpp
new file mode 100644
index 000000000000..dbbdc7187e0f
--- /dev/null
+++ b/net/savvycan/files/patch-connections_connectionwindow.cpp
@@ -0,0 +1,10 @@
+--- connections/connectionwindow.cpp.orig 2022-10-01 20:28:59 UTC
++++ connections/connectionwindow.cpp
+@@ -62,6 +62,7 @@ ConnectionWindow::ConnectionWindow(QWidget *parent) :
+ connect(ui->btnMoveUp, &QPushButton::clicked, this, &ConnectionWindow::moveConnUp);
+ connect(ui->btnMoveDown, &QPushButton::clicked, this, &ConnectionWindow::moveConnDown);
+
++ ui->cbBusSpeed->addItem("33333");
+ ui->cbBusSpeed->addItem("50000");
+ ui->cbBusSpeed->addItem("100000");
+ ui->cbBusSpeed->addItem("125000");