aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 10:57:46 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 10:57:46 +0000
commitb9aedfe5b6720b50a00ff039899534df29549ae3 (patch)
treee5744f41c7c84b6faa514b278d9dec6e5110cb25
parent34ee8a3e01b7d284600fab526dc3442c34aafb14 (diff)
downloadports-b9aedfe5b6720b50a00ff039899534df29549ae3.tar.gz
ports-b9aedfe5b6720b50a00ff039899534df29549ae3.zip
devel/py-pyright: Add py-pyright 1.1.253
Pyright for Python is a Python command-line wrapper over pyright [1], a static type checker for Python. [1] https://github.com/microsoft/pyright WWW: https://github.com/RobertCraigie/pyright-python
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pyright/Makefile28
-rw-r--r--devel/py-pyright/distinfo3
-rw-r--r--devel/py-pyright/files/patch-requirements.txt6
-rw-r--r--devel/py-pyright/pkg-descr6
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b4cbc073efcc..7ee4ec629366 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5094,6 +5094,7 @@
SUBDIR += py-pyral
SUBDIR += py-pyrepl
SUBDIR += py-pyrfc3339
+ SUBDIR += py-pyright
SUBDIR += py-pyro
SUBDIR += py-pyrsistent
SUBDIR += py-pyscaffold
diff --git a/devel/py-pyright/Makefile b/devel/py-pyright/Makefile
new file mode 100644
index 000000000000..72070fc99045
--- /dev/null
+++ b/devel/py-pyright/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pyright
+PORTVERSION= 1.1.253
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Command line wrapper for pyright
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nodeenv>=1.5.0:devel/py-nodeenv@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30800
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7:devel/py-typing-extensions@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-pyright/distinfo b/devel/py-pyright/distinfo
new file mode 100644
index 000000000000..c7e3f901ebe9
--- /dev/null
+++ b/devel/py-pyright/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1654708314
+SHA256 (pyright-1.1.253.tar.gz) = 0f63f07d66fe1a66f9dcc7cb7c403413bf926a6a586e0ad7b66e3c5fb83e5611
+SIZE (pyright-1.1.253.tar.gz) = 15403
diff --git a/devel/py-pyright/files/patch-requirements.txt b/devel/py-pyright/files/patch-requirements.txt
new file mode 100644
index 000000000000..b833699289cb
--- /dev/null
+++ b/devel/py-pyright/files/patch-requirements.txt
@@ -0,0 +1,6 @@
+--- requirements.txt.orig 2022-06-08 08:49:31 UTC
++++ requirements.txt
+@@ -1,2 +1,2 @@
+-nodeenv>=1.6.0
++nodeenv>=1.5.0
+ typing-extensions>=3.7; python_version < '3.8'
diff --git a/devel/py-pyright/pkg-descr b/devel/py-pyright/pkg-descr
new file mode 100644
index 000000000000..7c1048d0c17e
--- /dev/null
+++ b/devel/py-pyright/pkg-descr
@@ -0,0 +1,6 @@
+Pyright for Python is a Python command-line wrapper over pyright [1], a static
+type checker for Python.
+
+[1] https://github.com/microsoft/pyright
+
+WWW: https://github.com/RobertCraigie/pyright-python