aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Bodenmann <jbo@FreeBSD.org>2023-11-13 21:33:35 +0000
committerJoel Bodenmann <jbo@FreeBSD.org>2023-11-13 21:33:35 +0000
commitb9be86ddf6fec059e7e05ae0d7f791b788861d7b (patch)
tree9cf77a41ea3722ed4e8959e294fe2ff5d3c994aa
parent9202e5f6369a83138260956aa71c3b52b1030857 (diff)
downloadports-b9be86ddf6fec059e7e05ae0d7f791b788861d7b.tar.gz
ports-b9be86ddf6fec059e7e05ae0d7f791b788861d7b.zip
devel/qschematic: Update to 1.5.0
Changelog: https://github.com/simulton/QSchematic/releases/tag/1.5.0 While here, update Qt dependency to Qt6. Approved by: tcberner (mentor) Sponsored by: Simulton GmbH Differential Revision: https://reviews.freebsd.org/D42529
-rw-r--r--devel/qschematic/Makefile13
-rw-r--r--devel/qschematic/distinfo6
-rw-r--r--devel/qschematic/pkg-descr5
-rw-r--r--devel/qschematic/pkg-plist79
4 files changed, 55 insertions, 48 deletions
diff --git a/devel/qschematic/Makefile b/devel/qschematic/Makefile
index 14687062e3d2..e1a632090967 100644
--- a/devel/qschematic/Makefile
+++ b/devel/qschematic/Makefile
@@ -1,5 +1,5 @@
PORTNAME= qschematic
-DISTVERSION= 1.4.0
+DISTVERSION= 1.5.0
CATEGORIES= devel
MAINTAINER= jbo@FreeBSD.org
@@ -11,15 +11,20 @@ LICENSE_FILE= ${WRKSRC}/license.txt
LIB_DEPENDS= libgpds.so:devel/gpds
-USES= cmake compiler:c++17-lang qt:5
-USE_QT= buildtools:build core gui qmake:build widgets
+USES= cmake compiler:c++17-lang qt:6
+USE_QT= base
USE_GITHUB= yes
GH_ACCOUNT= simulton
GH_PROJECT= QSchematic
-CMAKE_OFF= QSCHEMATIC_BUILD_DEMO QSCHEMATIC_DEPENDENCY_GPDS_DOWNLOAD
CMAKE_ARGS= -DQSCHEMATIC_DEPENDENCY_GPDS_TARGET:STRING="gpds::gpds-shared"
+CMAKE_OFF= QSCHEMATIC_BUILD_DEMO QSCHEMATIC_DEPENDENCY_GPDS_DOWNLOAD
+
+# Since the update from USES qt:5 to qt:6 there appears to be some overlinking
+# resulting in pulling in OpenGL which is not needed by upstream.
+# Put a "workaround" in place until we get to investigate this.
+LDFLAGS+= -Wl,--as-needed
PLIST_SUB= DISTVERSION=${DISTVERSION}
diff --git a/devel/qschematic/distinfo b/devel/qschematic/distinfo
index 0918900d5ee2..5a8f6502fbaa 100644
--- a/devel/qschematic/distinfo
+++ b/devel/qschematic/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1681392194
-SHA256 (simulton-QSchematic-1.4.0_GH0.tar.gz) = 3cf9831c5d3f912cf7e21a314df76eece39a0c4b74f34f714161b0b65dc1b50a
-SIZE (simulton-QSchematic-1.4.0_GH0.tar.gz) = 1457474
+TIMESTAMP = 1699535126
+SHA256 (simulton-QSchematic-1.5.0_GH0.tar.gz) = f6b47cea654bd24d6f7cfa83773b8871d7fb66e4692844139cf2f9bdeedeb023
+SIZE (simulton-QSchematic-1.5.0_GH0.tar.gz) = 1509508
diff --git a/devel/qschematic/pkg-descr b/devel/qschematic/pkg-descr
index f8b175f8c70e..81b856a76abd 100644
--- a/devel/qschematic/pkg-descr
+++ b/devel/qschematic/pkg-descr
@@ -4,5 +4,6 @@ schematics in a Qt application. It uses Qt's graphics view framework.
The library interface allows for easy customization of existing items and adding
new custom items such as wires, nodes, connectors and similar.
-Drawn diagrams/schematics can be easily serialized to and from XML. A built-in
-netlist generator is provided to build a netlist form a drawn diagram/schematic.
+Drawn diagrams/schematics can be easily serialized to and from XML or YAML.
+A built-in netlist generator is provided to build a netlist from a drawn
+diagram/schematic.
diff --git a/devel/qschematic/pkg-plist b/devel/qschematic/pkg-plist
index bafe6941ee09..0d7239739e2f 100644
--- a/devel/qschematic/pkg-plist
+++ b/devel/qschematic/pkg-plist
@@ -1,42 +1,43 @@
-include/qschematic/commands/commandbase.h
-include/qschematic/commands/commanditemadd.h
-include/qschematic/commands/commanditemmove.h
-include/qschematic/commands/commanditemremove.h
-include/qschematic/commands/commanditemvisibility.h
-include/qschematic/commands/commandlabelrename.h
-include/qschematic/commands/commandrectitemresize.h
-include/qschematic/commands/commandrectitemrotate.h
-include/qschematic/commands/commands.h
-include/qschematic/commands/commandwirenetrename.h
-include/qschematic/commands/commandwirepointmove.h
-include/qschematic/items/connector.h
-include/qschematic/items/item.h
-include/qschematic/items/itemfactory.h
-include/qschematic/items/itemfunctions.h
-include/qschematic/items/itemmimedata.h
-include/qschematic/items/label.h
-include/qschematic/items/node.h
-include/qschematic/items/rectitem.h
-include/qschematic/items/splinewire.h
-include/qschematic/items/widget.h
-include/qschematic/items/wire.h
-include/qschematic/items/wirenet.h
-include/qschematic/items/wireroundedcorners.h
-include/qschematic/netlist.h
-include/qschematic/netlistgenerator.h
-include/qschematic/scene.h
-include/qschematic/settings.h
-include/qschematic/types.h
-include/qschematic/utils.h
-include/qschematic/utils/itemscontainerutils.h
-include/qschematic/utils/itemscustodian.h
-include/qschematic/view.h
-include/qschematic/wire_system/connectable.h
-include/qschematic/wire_system/line.h
-include/qschematic/wire_system/manager.h
-include/qschematic/wire_system/net.h
-include/qschematic/wire_system/point.h
-include/qschematic/wire_system/wire.h
+include/qschematic/commands/base.hpp
+include/qschematic/commands/commands.hpp
+include/qschematic/commands/item_add.hpp
+include/qschematic/commands/item_move.hpp
+include/qschematic/commands/item_remove.hpp
+include/qschematic/commands/item_visibility.hpp
+include/qschematic/commands/label_rename.hpp
+include/qschematic/commands/rectitem_resize.hpp
+include/qschematic/commands/rectitem_rotate.hpp
+include/qschematic/commands/wirenet_rename.hpp
+include/qschematic/commands/wirepoint_move.hpp
+include/qschematic/items/connector.hpp
+include/qschematic/items/item.hpp
+include/qschematic/items/itemfactory.hpp
+include/qschematic/items/itemfunctions.hpp
+include/qschematic/items/itemmimedata.hpp
+include/qschematic/items/label.hpp
+include/qschematic/items/node.hpp
+include/qschematic/items/rectitem.hpp
+include/qschematic/items/splinewire.hpp
+include/qschematic/items/widget.hpp
+include/qschematic/items/wire.hpp
+include/qschematic/items/wirenet.hpp
+include/qschematic/items/wireroundedcorners.hpp
+include/qschematic/netlist.hpp
+include/qschematic/netlist_writer_json.hpp
+include/qschematic/netlistgenerator.hpp
+include/qschematic/scene.hpp
+include/qschematic/settings.hpp
+include/qschematic/types.hpp
+include/qschematic/utils.hpp
+include/qschematic/utils/itemscontainerutils.hpp
+include/qschematic/utils/itemscustodian.hpp
+include/qschematic/view.hpp
+include/qschematic/wire_system/connectable.hpp
+include/qschematic/wire_system/line.hpp
+include/qschematic/wire_system/manager.hpp
+include/qschematic/wire_system/net.hpp
+include/qschematic/wire_system/point.hpp
+include/qschematic/wire_system/wire.hpp
lib/cmake/qschematic/qschematic-config-version.cmake
lib/cmake/qschematic/qschematic-config.cmake
lib/cmake/qschematic/qschematic-targets-%%CMAKE_BUILD_TYPE%%.cmake