aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mangin <cmangin@arobas.net>2023-08-12 20:18:07 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2023-08-12 20:19:38 +0000
commitba250e03fd652940d2da0e4d947dca35e26b5a4c (patch)
treee44e645615e83f1572a3827978d84b38a51459bf
parent5dddaba184a7294486f50bbbc0fa87df51398cc4 (diff)
downloadports-ba250e03fd652940d2da0e4d947dca35e26b5a4c.tar.gz
ports-ba250e03fd652940d2da0e4d947dca35e26b5a4c.zip
x11/xdm: allow X server arguments to be set in Xservers
This patch changes the rc.d script so that: 1- The xdm_tty variable is set to 'default'. This disable the override and allows xdm to be configured the normal way. xdm uses the ttyv8 terminal by default anyway. 2- The server arguments are only overridden if the user explicitly specify a value for xdm_tty. PR: 265578
-rw-r--r--x11/xdm/Makefile2
-rw-r--r--x11/xdm/files/xdm.in6
2 files changed, 5 insertions, 3 deletions
diff --git a/x11/xdm/Makefile b/x11/xdm/Makefile
index f828df33c99b..2f86e3a665b0 100644
--- a/x11/xdm/Makefile
+++ b/x11/xdm/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xdm
PORTVERSION= 1.1.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
diff --git a/x11/xdm/files/xdm.in b/x11/xdm/files/xdm.in
index 182911e97848..dae4a2a40039 100644
--- a/x11/xdm/files/xdm.in
+++ b/x11/xdm/files/xdm.in
@@ -26,11 +26,13 @@ desc="X.org X display manager"
load_rc_config $name
: ${xdm_enable:=NO}
-: ${xdm_tty:=ttyv8}
+: ${xdm_tty:=default}
command=%%PREFIX%%/bin/$name
pidfile=/var/run/$name.pid
-start_precmd=xdm_set_vty
+if [ "${xdm_tty%%[0-9]*}" = "ttyv" ]; then
+ start_precmd=xdm_set_vty
+fi
xdm_set_vty()
{