aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Davis <brd@FreeBSD.org>2021-08-08 16:55:44 +0000
committerBrad Davis <brd@FreeBSD.org>2021-08-08 16:55:44 +0000
commitbaa26eb67c4d0d6406a190dec9214520a53c02e1 (patch)
treededf213691825d4150ab73d1fb1ed67718f64835
parent2607150a39e6148c46fab06b8bd12e92a4466f28 (diff)
downloadports-baa26eb67c4d0d6406a190dec9214520a53c02e1.tar.gz
ports-baa26eb67c4d0d6406a190dec9214520a53c02e1.zip
net/mosquitto: Fix startup pidfile issue
PR: 254254 Reviewed by: swills Approved by: joe@thrallingpenguin.com (maintainer, earlier version)
-rw-r--r--net/mosquitto/Makefile1
-rw-r--r--net/mosquitto/files/mosquitto.in8
2 files changed, 8 insertions, 1 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 740405a39144..a98109f9c046 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mosquitto
PORTVERSION= 2.0.10
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://mosquitto.org/files/source/
diff --git a/net/mosquitto/files/mosquitto.in b/net/mosquitto/files/mosquitto.in
index f781b772af61..ae1bd703ecbc 100644
--- a/net/mosquitto/files/mosquitto.in
+++ b/net/mosquitto/files/mosquitto.in
@@ -21,10 +21,11 @@ rcvar=mosquitto_enable
mosquitto_enable=${mosquitto_enable:="NO"}
mosquitto_config=${mosquitto_config:="%%PREFIX%%/etc/mosquitto/mosquitto.conf"}
+mosquitto_user=${mosquitto_user:="nobody"}
command=%%PREFIX%%/sbin/mosquitto
command_args="-c ${mosquitto_config} -d"
-pidfile=$(grep pidfile ${mosquitto_config} | awk '{print($2)}')
+pidfile=${mosquitto_pidfile:-"/var/run/mosquitto.pid"}
required_files=${mosquitto_config}
extra_commands="reload"
@@ -33,6 +34,11 @@ stop_postcmd()
{
rm -f $pidfile
}
+start_precmd=start_precmd
+start_precmd()
+{
+ install -o ${mosquitto_user} -m 644 /dev/null ${pidfile}
+}
load_rc_config $name
run_rc_command "$1"