aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-08-17 23:28:05 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-08-17 23:28:05 +0000
commitbabf3112deb1e32bfbe3b79733786aea9cec3a87 (patch)
tree193d43f42f9e06ca1be28a7ba14b9e2af312cc77
parent3dd3a9beb518358b09f9b80bad33e34d5ae0460c (diff)
downloadports-babf3112deb1e32bfbe3b79733786aea9cec3a87.tar.gz
ports-babf3112deb1e32bfbe3b79733786aea9cec3a87.zip
www/lighttpd: change the default var.state_dir to fix runtime
PR: 256643 Reported by: sm@codenetworks.net
-rw-r--r--www/lighttpd/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 117eda3d09f8..45791837dab2 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -2,6 +2,7 @@
PORTNAME?= lighttpd
PORTVERSION= 1.4.59
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES?= https://download.lighttpd.net/lighttpd/releases-1.4.x/
@@ -128,6 +129,7 @@ GROUPS= ${WWWGRP}
CACHEDIR= /var/cache/${PORTNAME}
LOGDIR= /var/log/${PORTNAME}
HOMEDIR= /var/run/${PORTNAME}
+RUNDIR= /var/run
PLIST_SUB+= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
PLIST_SUB+= CACHEDIR="${CACHEDIR}" HOMEDIR="${HOMEDIR}" LOGDIR="${LOGDIR}"
@@ -152,6 +154,7 @@ post-patch:
-e "s|^(var.log_root.*=).*|\1 \"${LOGDIR}\"|" \
-e "s|^(var.server_root.*=).*|\1 \"${WWWDIR}\"|" \
-e "s|^(var.home_dir.*=).*|\1 \"${HOMEDIR}\"|" \
+ -e "s|^(var.state_dir.*=).*|\1 \"${RUNDIR}\"|" \
-e "s|^(var.cache_dir.*=).*|\1 \"${CACHEDIR}\"|" \
${WRKSRC}/doc/config/lighttpd.conf
@${REINPLACE_CMD} -e "s|/etc/lighttpd|${ETCDIR}|g" \