aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2024-03-22 11:21:35 +0000
committerThierry Thomas <thierry@FreeBSD.org>2024-03-22 11:21:35 +0000
commitbbb76dace979e046a3ac1cbcf1ed51595f6d2aea (patch)
treef0b089f3f91502711f0c1445efb4da278ba5da9f
parent90277af827a5c5a194fede830367c602406122c6 (diff)
downloadports-bbb76dace979e046a3ac1cbcf1ed51595f6d2aea.tar.gz
ports-bbb76dace979e046a3ac1cbcf1ed51595f6d2aea.zip
cad/opencascade: the initial tarball has been reworked
Upstream reworked the tarball to integrate several patches without bumping revision. PR: 277881 Reported by: Sergey Kiselev
-rw-r--r--cad/opencascade/Makefile2
-rw-r--r--cad/opencascade/distinfo10
-rw-r--r--cad/opencascade/files/patch-adm_UDLIST10
-rw-r--r--cad/opencascade/files/patch-src_Message_Message__AttributeMeter.cxx10
-rw-r--r--cad/opencascade/files/patch-src_NCollection_NCollection__Array1.hxx39
-rw-r--r--cad/opencascade/files/patch-src_NCollection_NCollection__DynamicArray.hxx29
-rw-r--r--cad/opencascade/files/patch-src_NCollection_NCollection__Iterator.hxx19
7 files changed, 7 insertions, 112 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index 6d6caf8f84de..6796cab56497 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -1,7 +1,9 @@
PORTNAME= opencascade
DISTVERSIONPREFIX= V
DISTVERSION= 7_8_0
+PORTREVISION= 1
CATEGORIES= cad science
+DIST_SUBDIR= ${PORTNAME}-${DISTVERSION}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Open CASCADE Technology, 3D modeling & numerical simulation
diff --git a/cad/opencascade/distinfo b/cad/opencascade/distinfo
index 1854ffc388f5..89e9a325924c 100644
--- a/cad/opencascade/distinfo
+++ b/cad/opencascade/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1711092244
-SHA256 (documentation.tar.xz) = 096cd0f268fa9f6a50818e1d628ac92ecf87e10fd72187e2e8d6be57dfe12530
-SIZE (documentation.tar.xz) = 48428565
-SHA256 (Open-Cascade-SAS-OCCT-V7_8_0_GH0.tar.gz) = 3c5cdd70de9c82d9f0be4b9400d618494cfecd28f502d110111060c9aaaf50c7
-SIZE (Open-Cascade-SAS-OCCT-V7_8_0_GH0.tar.gz) = 48428333
+TIMESTAMP = 1711099991
+SHA256 (opencascade-7_8_0/documentation.tar.xz) = 096cd0f268fa9f6a50818e1d628ac92ecf87e10fd72187e2e8d6be57dfe12530
+SIZE (opencascade-7_8_0/documentation.tar.xz) = 48428565
+SHA256 (opencascade-7_8_0/Open-Cascade-SAS-OCCT-V7_8_0_GH0.tar.gz) = 096cd0f268fa9f6a50818e1d628ac92ecf87e10fd72187e2e8d6be57dfe12530
+SIZE (opencascade-7_8_0/Open-Cascade-SAS-OCCT-V7_8_0_GH0.tar.gz) = 48428565
diff --git a/cad/opencascade/files/patch-adm_UDLIST b/cad/opencascade/files/patch-adm_UDLIST
deleted file mode 100644
index feee670d3393..000000000000
--- a/cad/opencascade/files/patch-adm_UDLIST
+++ /dev/null
@@ -1,10 +0,0 @@
---- adm/UDLIST.orig 2023-12-04 15:53:08 UTC
-+++ adm/UDLIST
-@@ -32,6 +32,7 @@ r OS
- n gp
- n math
- r OS
-+n FlexLexer
- t TKMath
- t TKernel
- n Adaptor2d
diff --git a/cad/opencascade/files/patch-src_Message_Message__AttributeMeter.cxx b/cad/opencascade/files/patch-src_Message_Message__AttributeMeter.cxx
deleted file mode 100644
index 38686e6cd8b4..000000000000
--- a/cad/opencascade/files/patch-src_Message_Message__AttributeMeter.cxx
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/Message/Message_AttributeMeter.cxx.orig 2023-12-04 15:53:08 UTC
-+++ src/Message/Message_AttributeMeter.cxx
-@@ -253,6 +253,6 @@ void Message_AttributeMeter::DumpJson (Standard_OStrea
- anIterator.More(); anIterator.Next())
- {
- OCCT_DUMP_VECTOR_CLASS (theOStream, Message::MetricToString (anIterator.Key()),
-- 2, anIterator.Value(), anIterator.Value())
-+ 2, anIterator.Value().first, anIterator.Value().second)
- }
- }
diff --git a/cad/opencascade/files/patch-src_NCollection_NCollection__Array1.hxx b/cad/opencascade/files/patch-src_NCollection_NCollection__Array1.hxx
deleted file mode 100644
index 7a3f36deeade..000000000000
--- a/cad/opencascade/files/patch-src_NCollection_NCollection__Array1.hxx
+++ /dev/null
@@ -1,39 +0,0 @@
---- src/NCollection/NCollection_Array1.hxx.orig 2023-12-04 15:53:08 UTC
-+++ src/NCollection/NCollection_Array1.hxx
-@@ -72,26 +72,10 @@ class NCollection_Array1 (public)
-
- using iterator = NCollection_IndexedIterator<std::random_access_iterator_tag, NCollection_Array1, value_type, false>;
- using const_iterator = NCollection_IndexedIterator<std::random_access_iterator_tag, NCollection_Array1, value_type, true>;
-+ using Iterator = NCollection_Iterator<NCollection_Array1<TheItemType>>;
-
- public:
-
-- // Iterator class
-- class Iterator : public NCollection_Iterator<NCollection_Array1>
-- {
-- public:
-- using NCollection_Iterator<NCollection_Array1>::NCollection_Iterator;
--
-- const_reference Value() const
-- {
-- return *NCollection_Iterator<NCollection_Array1>::ValueIter();
-- }
--
-- reference ChangeValue()
-- {
-- return *NCollection_Iterator<NCollection_Array1>::ChangeValueIter();
-- }
-- };
--
- const_iterator begin() const
- {
- return const_iterator(*this);
-@@ -150,7 +134,7 @@ class NCollection_Array1 (public)
- mySize(theUpper - theLower + 1),
- myPointer(nullptr),
- myIsOwner(false),
-- allocator_type(theAlloc)
-+ myAllocator(theAlloc)
- {
- if (mySize == 0)
- {
diff --git a/cad/opencascade/files/patch-src_NCollection_NCollection__DynamicArray.hxx b/cad/opencascade/files/patch-src_NCollection_NCollection__DynamicArray.hxx
deleted file mode 100644
index 28bc7579f5fa..000000000000
--- a/cad/opencascade/files/patch-src_NCollection_NCollection__DynamicArray.hxx
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/NCollection/NCollection_DynamicArray.hxx.orig 2023-12-04 15:53:08 UTC
-+++ src/NCollection/NCollection_DynamicArray.hxx
-@@ -77,25 +77,9 @@ class NCollection_DynamicArray (public)
-
- using iterator = NCollection_IndexedIterator<std::random_access_iterator_tag, NCollection_DynamicArray, value_type, false>;
- using const_iterator = NCollection_IndexedIterator<std::random_access_iterator_tag, NCollection_DynamicArray, value_type, true>;
-+ using Iterator = NCollection_Iterator<NCollection_DynamicArray<TheItemType>>;
-
- public:
--
-- // Iterator class
-- class Iterator : public NCollection_Iterator<NCollection_DynamicArray>
-- {
-- public:
-- using NCollection_Iterator<NCollection_DynamicArray>::NCollection_Iterator;
--
-- const_reference Value() const
-- {
-- return *NCollection_Iterator<NCollection_DynamicArray>::ValueIter();
-- }
--
-- reference ChangeValue()
-- {
-- return *NCollection_Iterator<NCollection_DynamicArray>::ChangeValueIter();
-- }
-- };
-
- const_iterator begin() const
- {
diff --git a/cad/opencascade/files/patch-src_NCollection_NCollection__Iterator.hxx b/cad/opencascade/files/patch-src_NCollection_NCollection__Iterator.hxx
deleted file mode 100644
index 81d01c6b6809..000000000000
--- a/cad/opencascade/files/patch-src_NCollection_NCollection__Iterator.hxx
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/NCollection/NCollection_Iterator.hxx.orig 2023-12-04 15:53:08 UTC
-+++ src/NCollection/NCollection_Iterator.hxx
-@@ -94,6 +94,16 @@ class NCollection_Iterator (public)
- ++(myCur);
- }
-
-+ const typename Container::const_reference Value() const
-+ {
-+ return *myCur;
-+ }
-+
-+ const typename Container::reference ChangeValue()
-+ {
-+ return *myCur;
-+ }
-+
- bool operator==(const NCollection_Iterator& theOther) { return myLast == theOther.myLast && myCur == theOther.myCur; }
-
- bool operator!=(const NCollection_Iterator& theOther) { return myLast != theOther.myLast || myCur != theOther.myCur; }