aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalf van der Enden <tremere@cainites.net>2023-07-04 06:19:42 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-07-04 15:13:10 +0000
commitbbf3f2110b24b17eb4531cf9a0e8522a68850a97 (patch)
treef7de09dffa18f4ab97ed1c8380b4be3425a2ccd4
parentdcb7d2bd5902e25501b0033360c3f12ed152490c (diff)
downloadports-bbf3f2110b24b17eb4531cf9a0e8522a68850a97.tar.gz
ports-bbf3f2110b24b17eb4531cf9a0e8522a68850a97.zip
dns/powerdns-recursor: update to 4.9.0
ChangeLog: https://blog.powerdns.com/2023/06/30/powerdns-recursor-4-9-0-released * The performance impact of metrics collection has been reduced by using lock-free non-atomic thread-local counters. * The packet cache is sharded and shared by all threads. * The TTL of negative answers in the packet cache can now be controlled separately from positive and failure answers. * The rec_control trace_regex command writes the generated trace information to a specified file instead of the general log. The trace information contains more precise timestamps and DNSSEC validation information. * If extended-resolution-errors is enabled EDNS errors are now generated in more cases, specifically when authoritative servers for a zone are unreachable or when synthesising answers by e.g. using the aggressive NSEC cache. * The aggressive NSEC cache has been changed not to store NSEC3 entries which cover only a small fraction of possible names. This also allows switching off the aggressive cache for NSEC3 only. * It is now possible to switch off root-refreshing completely. * Proper handling of security policies that restrict the use of specific DNSSEC algorithms on RHEL9 derived systems. PR: 272343 Reported by: tremere@cainites.net (maintainer)
-rw-r--r--dns/powerdns-recursor/Makefile3
-rw-r--r--dns/powerdns-recursor/distinfo6
-rw-r--r--dns/powerdns-recursor/files/patch-rec-main.cc28
3 files changed, 18 insertions, 19 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 3cc81814b871..37a468371b74 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -1,6 +1,5 @@
PORTNAME= recursor
-DISTVERSION= 4.8.4
-PORTREVISION= 1
+DISTVERSION= 4.9.0
CATEGORIES= dns
MASTER_SITES= http://downloads.powerdns.com/releases/
PKGNAMEPREFIX= powerdns-
diff --git a/dns/powerdns-recursor/distinfo b/dns/powerdns-recursor/distinfo
index 33830e4d7c02..861c97590877 100644
--- a/dns/powerdns-recursor/distinfo
+++ b/dns/powerdns-recursor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1680094921
-SHA256 (pdns-recursor-4.8.4.tar.bz2) = f0a63fd08e03da82fa20d333ea5179d1b9259f4264546cf4995286677d9458c7
-SIZE (pdns-recursor-4.8.4.tar.bz2) = 1528092
+TIMESTAMP = 1688122340
+SHA256 (pdns-recursor-4.9.0.tar.bz2) = d36f162843e367646a661a785ca0becde9b68552855bf40532aebafa103966f3
+SIZE (pdns-recursor-4.9.0.tar.bz2) = 1551436
diff --git a/dns/powerdns-recursor/files/patch-rec-main.cc b/dns/powerdns-recursor/files/patch-rec-main.cc
index d233469daf42..abec8d2677d4 100644
--- a/dns/powerdns-recursor/files/patch-rec-main.cc
+++ b/dns/powerdns-recursor/files/patch-rec-main.cc
@@ -1,18 +1,18 @@
---- rec-main.cc.orig 2022-12-09 10:46:42 UTC
+--- rec-main.cc.orig 2023-06-30 06:58:36 UTC
+++ rec-main.cc
-@@ -2609,13 +2609,13 @@ int main(int argc, char** argv)
- SYSTEMD_SETID_MSG
+@@ -2829,13 +2829,13 @@ static void initArgs()
+ SYSTEMD_SETID_MSG
#endif
- )
-- = "";
-+ = "pdns";
- ::arg().set("setuid", "If set, change user id to this uid for more security"
+ )
+- = "";
++ = "pdns";
+ ::arg().set("setuid", "If set, change user id to this uid for more security"
#ifdef HAVE_SYSTEMD
- SYSTEMD_SETID_MSG
+ SYSTEMD_SETID_MSG
#endif
- )
-- = "";
-+ = "pdns_recursor";
- ::arg().set("network-timeout", "Wait this number of milliseconds for network i/o") = "1500";
- ::arg().set("threads", "Launch this number of threads") = "2";
- ::arg().set("distributor-threads", "Launch this number of distributor threads, distributing queries to other threads") = "0";
+ )
+- = "";
++ = "pdns_recursor";
+ ::arg().set("network-timeout", "Wait this number of milliseconds for network i/o") = "1500";
+ ::arg().set("threads", "Launch this number of threads") = "2";
+ ::arg().set("distributor-threads", "Launch this number of distributor threads, distributing queries to other threads") = "0";