aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2022-07-26 22:47:45 +0000
committerDima Panov <fluffy@FreeBSD.org>2022-07-26 22:50:46 +0000
commitbc11d4fd2d60809625cc475dbbefc06adeee7352 (patch)
tree72d433fbdc18301bd8e79ca40af1302c827f6ed8
parent58b51f941282911e9e677499a0e0925c89c33905 (diff)
downloadports-bc11d4fd2d60809625cc475dbbefc06adeee7352.tar.gz
ports-bc11d4fd2d60809625cc475dbbefc06adeee7352.zip
games/freeciv: update to 3.0.2 release (+)
WHAT'S CHANGED SINCE 2.6: The major changes in Freeciv 3.0 are civ2civ3 being the default ruleset, addition of the alien ruleset, hex maps as the default topology on new installations, and a whole lot of extra flexibility to create custom rulesets. As is usual for major releases, 3.0 clients cannot interoperate with pre-3.0 servers, and vice versa. Most pre-3.0 savegames can however be loaded into 3.0, and in most cases, the supplied rulesets have not changed so much as to make it difficult to complete a game started with 2.6.x's rules. Release Notes: https://freeciv.fandom.com/wiki/NEWS-3.0.2 https://freeciv.fandom.com/wiki/NEWS-3.0.1 https://freeciv.fandom.com/wiki/NEWS-3.0.0
-rw-r--r--games/freeciv/Makefile17
-rw-r--r--games/freeciv/distinfo6
-rw-r--r--games/freeciv/pkg-plist106
3 files changed, 76 insertions, 53 deletions
diff --git a/games/freeciv/Makefile b/games/freeciv/Makefile
index e4a2673a8594..c9308218688a 100644
--- a/games/freeciv/Makefile
+++ b/games/freeciv/Makefile
@@ -1,7 +1,8 @@
PORTNAME= freeciv
-PORTVERSION= 2.6.6
+PORTVERSION= 3.0.2
CATEGORIES= games
-MASTER_SITES= SF/freeciv/Freeciv%20${PORTVERSION:R}/${PORTVERSION}
+MASTER_SITES= SF/freeciv/Freeciv%20${PORTVERSION:R}/${PORTVERSION} \
+ http://files.freeciv.org/stable/
MAINTAINER= fluffy@FreeBSD.org
COMMENT= Free turn-based multiplayer strategy
@@ -13,7 +14,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libltdl.so:devel/libltdl
USES= autoreconf compiler:c++11-lang cpe gmake iconv libtool lua:53 \
- pkgconfig readline ssl tar:bzip2
+ pkgconfig readline ssl tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG} \
@@ -33,11 +34,12 @@ OPTIONS_DEFINE= DOCS IPV6 NLS
OPTIONS_DEFAULT= QT5 SQLITE3
OPTIONS_MULTI= DB UI
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE3
-OPTIONS_MULTI_UI= GTK2 GTK3 QT5 SDL
+OPTIONS_MULTI_UI= GTK2 GTK3 GTK4 QT5 SDL
OPTIONS_SUB= yes
DB_DESC= Database support
UI_DESC= GUI clients
+GTK4_DESC= GTK+ 4 GUI toolkit support (modpack only)
GTK2_USES= gnome sdl
GTK2_USE= GNOME=gdkpixbuf2,glib20,gtk20,pango \
@@ -49,8 +51,15 @@ GTK3_USES= gnome sdl
GTK3_USE= GNOME=cairo,gdkpixbuf2,glib20,gtk30,pango \
SDL=mixer2
GTK3_VARS= _FREECIV_CLIENT+=gtk3 \
+ _FREECIV_CLIENT+=gtk3.22 \
_FREECIV_MP+=gtk3
+GTK4_IMPLIES= GTK3
+GTK4_USES= gnome sdl
+GTK4_USE= GNOME=cairo,gdkpixbuf2,glib20,gtk40,pango \
+ SDL=mixer2
+GTK4_VARS= _FREECIV_MP+=gtk4
+
IPV6_CONFIGURE_ENABLE= ipv6
MYSQL_USES= mysql
diff --git a/games/freeciv/distinfo b/games/freeciv/distinfo
index 2d60cab6b8fa..b07ad00e5b60 100644
--- a/games/freeciv/distinfo
+++ b/games/freeciv/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1639336029
-SHA256 (freeciv-2.6.6.tar.bz2) = 7bcfe5dd3c081122e7cde7cdb24f57c3681d6a9667496faed207a91ac3165811
-SIZE (freeciv-2.6.6.tar.bz2) = 52244748
+TIMESTAMP = 1658874457
+SHA256 (freeciv-3.0.2.tar.xz) = 7407ea1a08267b1c5ee3439dc2db5c2d7b90ece7fcc3664ca2ad594435a57175
+SIZE (freeciv-3.0.2.tar.xz) = 33530112
diff --git a/games/freeciv/pkg-plist b/games/freeciv/pkg-plist
index 3f9897d49733..57d56cefe91f 100644
--- a/games/freeciv/pkg-plist
+++ b/games/freeciv/pkg-plist
@@ -1,12 +1,15 @@
%%CLIENT%%bin/freeciv-manual
%%GTK2%%bin/freeciv-gtk2
%%GTK3%%bin/freeciv-gtk3
+%%GTK3%%bin/freeciv-gtk3.22
bin/freeciv-mp-cli
%%GTK2%%bin/freeciv-mp-gtk2
%%GTK3%%bin/freeciv-mp-gtk3
+%%GTK4%%bin/freeciv-mp-gtk4
%%QT5%%bin/freeciv-mp-qt
%%QT5%%bin/freeciv-qt
%%QT5%%bin/freeciv-ruledit
+%%QT5%%bin/freeciv-ruleup
%%SDL%%bin/freeciv-sdl2
bin/freeciv-server
%%ETCDIR%%/database.lua
@@ -29,22 +32,16 @@ man/man6/freeciv-mp-cli.6.gz
%%QT5%%man/man6/freeciv-mp-qt.6.gz
%%QT5%%man/man6/freeciv-qt.6.gz
%%QT5%%man/man6/freeciv-ruledit.6.gz
+%%QT5%%man/man6/freeciv-ruleup.6.gz
@comment man/man6/freeciv-sdl.6.gz
%%SDL%%man/man6/freeciv-sdl2.6.gz
man/man6/freeciv-server.6.gz
@comment man/man6/freeciv-xaw.6.gz
-%%GTK2%%share/appdata/freeciv-gtk2.appdata.xml
-%%GTK3%%share/appdata/freeciv-gtk3.appdata.xml
-%%GTK2%%share/appdata/freeciv-mp-gtk2.appdata.xml
-%%GTK3%%share/appdata/freeciv-mp-gtk3.appdata.xml
-%%QT5%%share/appdata/freeciv-mp-qt.appdata.xml
-%%QT5%%share/appdata/freeciv-qt.appdata.xml
-%%QT5%%share/appdata/freeciv-ruledit.appdata.xml
-%%SDL%%share/appdata/freeciv-sdl2.appdata.xml
-share/appdata/freeciv-server.appdata.xml
%%GTK2%%share/applications/org.freeciv.gtk2.desktop
%%GTK2%%share/applications/org.freeciv.mp.gtk2.desktop
%%GTK3%%share/applications/org.freeciv.mp.gtk3.desktop
+%%GTK3%%share/applications/org.freeciv.gtk322.desktop
+%%GTK4%%share/applications/org.freeciv.mp.gtk4.desktop
%%QT5%%share/applications/org.freeciv.mp.qt.desktop
%%QT5%%share/applications/org.freeciv.qt.desktop
%%QT5%%share/applications/org.freeciv.ruledit.desktop
@@ -63,7 +60,7 @@ share/applications/org.freeciv.server.desktop
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/INSTALL.Cygwin
%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/NEWS-2.6
+%%PORTDOCS%%%%DOCSDIR%%/NEWS-3.0
%%PORTDOCS%%%%DOCSDIR%%/README.AI
%%PORTDOCS%%%%DOCSDIR%%/README.AI_modules
%%PORTDOCS%%%%DOCSDIR%%/README.achievements
@@ -80,131 +77,148 @@ share/applications/org.freeciv.server.desktop
%%PORTDOCS%%%%DOCSDIR%%/README.nations
%%PORTDOCS%%%%DOCSDIR%%/README.packaging
%%PORTDOCS%%%%DOCSDIR%%/README.rulesets
+%%PORTDOCS%%%%DOCSDIR%%/README.scenarios
%%PORTDOCS%%%%DOCSDIR%%/README.scorelog
%%PORTDOCS%%%%DOCSDIR%%/README.sound
%%PORTDOCS%%%%DOCSDIR%%/README.tilesets
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%CLIENT%%share/icons/hicolor/128x128/apps/freeciv-client.png
%%CLIENT%%share/icons/hicolor/128x128/apps/freeciv-modpack.png
+%%QT5%%share/icons/hicolor/128x128/apps/freeciv-ruledit.png
share/icons/hicolor/128x128/apps/freeciv-server.png
%%CLIENT%%share/icons/hicolor/16x16/apps/freeciv-client.png
%%CLIENT%%share/icons/hicolor/16x16/apps/freeciv-modpack.png
+%%QT5%%share/icons/hicolor/16x16/apps/freeciv-ruledit.png
share/icons/hicolor/16x16/apps/freeciv-server.png
%%CLIENT%%share/icons/hicolor/32x32/apps/freeciv-client.png
%%CLIENT%%share/icons/hicolor/32x32/apps/freeciv-modpack.png
+%%QT5%%share/icons/hicolor/32x32/apps/freeciv-ruledit.png
share/icons/hicolor/32x32/apps/freeciv-server.png
%%CLIENT%%share/icons/hicolor/48x48/apps/freeciv-client.png
%%CLIENT%%share/icons/hicolor/48x48/apps/freeciv-modpack.png
+%%QT5%%share/icons/hicolor/48x48/apps/freeciv-ruledit.png
share/icons/hicolor/48x48/apps/freeciv-server.png
%%CLIENT%%share/icons/hicolor/64x64/apps/freeciv-client.png
%%CLIENT%%share/icons/hicolor/64x64/apps/freeciv-modpack.png
+%%QT5%%share/icons/hicolor/64x64/apps/freeciv-ruledit.png
share/icons/hicolor/64x64/apps/freeciv-server.png
%%NLS%%share/locale/ar/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/ar/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/ar/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/bg/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/bg/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/bg/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/ca/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/ca/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/ca/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/cs/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/cs/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/da/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/da/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/da/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/da/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/de/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/de/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/de/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/de/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/el/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/el/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/el/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/el/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/en_GB/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/en_GB/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/eo/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/eo/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/eo/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/es/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/es/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/es/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/es/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/et/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/et/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/et/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/et/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/fa/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/fa/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/fa/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/fi/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/fi/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/fr/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/fr/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/ga/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/ga/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/ga/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/gd/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/gd/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/gd/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/gd/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/he/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/he/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/he/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/he/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/hu/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/hu/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/id/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/id/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/id/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/id/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/it/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/it/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/it/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/it/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/ja/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/ja/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/ko/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/ko/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/lt/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/lt/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/nb/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/nb/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/nb/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/nl/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/nl/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/pl/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/pl/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/pt/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/pt/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/pt/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/pt_BR/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/ro/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/ro/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/ru/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/ru/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/sr/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/sr/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/sr/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/sv/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/sv/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/tr/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/tr/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/uk/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/uk/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/zh_CN/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/freeciv-core.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/freeciv-nations.mo
%%QT5%%%%NLS%%share/locale/zh_TW/LC_MESSAGES/freeciv-ruledit.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/freeciv.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/freeciv-core.mo
+%%GTK3%%share/metainfo/org.freeciv.gtk3.appdata.xml
+%%GTK3%%share/metainfo/org.freeciv.gtk322.appdata.xml
+%%GTK3%%share/metainfo/org.freeciv.mp.gtk3.appdata.xml
+%%GTK4%%share/metainfo/org.freeciv.mp.gtk4.appdata.xml
+%%QT5%%share/metainfo/org.freeciv.mp.qt.appdata.xml
+%%QT5%%share/metainfo/org.freeciv.qt.appdata.xml
+%%QT5%%share/metainfo/org.freeciv.ruledit.appdata.xml
+%%SDL%%share/metainfo/org.freeciv.sdl2.appdata.xml
+share/metainfo/org.freeciv.server.appdata.xml
%%CLIENT%%share/pixmaps/freeciv-client.png
+%%CLIENT%%share/pixmaps/freeciv-modpack.png
+%%QT5%%share/pixmaps/freeciv-ruledit.png