aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-27 23:05:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-27 23:05:22 +0000
commitbc66887a61a3948243e0bed6a6d9b389f4922e86 (patch)
tree292cc13346a5fab3997de0be7feb3a56b606b8b1
parentb59f44268367e053377d59c603d95e184d24015f (diff)
downloadports-bc66887a61a3948243e0bed6a6d9b389f4922e86.tar.gz
ports-bc66887a61a3948243e0bed6a6d9b389f4922e86.zip
math/obake: Unbreak by backporting the PR that fixes fmt9 compatibility
-rw-r--r--math/obake/Makefile15
-rw-r--r--math/obake/distinfo12
-rw-r--r--math/obake/pkg-plist1
3 files changed, 24 insertions, 4 deletions
diff --git a/math/obake/Makefile b/math/obake/Makefile
index 9000bc7487f0..af31bc9f55a9 100644
--- a/math/obake/Makefile
+++ b/math/obake/Makefile
@@ -2,9 +2,16 @@ PORTNAME= obake
DISTVERSIONPREFIX= v
DISTVERSION= 0.7.0-24
DISTVERSIONSUFFIX= -gb8cc71c
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 1a53966f5ce8ca5542d3612c780ea4b69be34de2.patch:-p1 \
+ dadf4ce2aba713522d1949a16ffbf0fa5d6e6298.patch:-p1 \
+ 9310de2cb5cc4c85b54e7e90aa6cd88664380346.patch:-p1 \
+ 57da8d5f2d0c50e857979ba74434893b0b392382.patch:-p1 \
+ 494df04bd7608bb666efde776241370cb84c96bb.patch:-p1 # adding fmt9 compatibility, see https://github.com/bluescarni/obake/pull/145/commits
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= C++ library for the symbolic manipulation of sparse polynomials & co
WWW= https://bluescarni.github.io/obake/
@@ -12,8 +19,6 @@ WWW= https://bluescarni.github.io/obake/
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= https://github.com/bluescarni/obake/issues/148
-
LIB_DEPENDS= libabsl_base.so:devel/abseil \
libboost_serialization.so:devel/boost-libs \
libfmt.so:devel/libfmt \
@@ -33,4 +38,8 @@ CXXFLAGS+= -DBOOST_STACKTRACE_GNU_SOURCE_NOT_REQUIRED
CMAKE_TESTING_ON= OBAKE_BUILD_TESTS
+post-install:
+ # remove patch artefacts
+ @${FIND} ${STAGEDIR}${PREFIX}/include/obake -name "*.orig" -delete
+
.include <bsd.port.mk>
diff --git a/math/obake/distinfo b/math/obake/distinfo
index 47262c68960e..8cd5cc378310 100644
--- a/math/obake/distinfo
+++ b/math/obake/distinfo
@@ -1,3 +1,13 @@
-TIMESTAMP = 1671405815
+TIMESTAMP = 1672178723
SHA256 (bluescarni-obake-v0.7.0-24-gb8cc71c_GH0.tar.gz) = b47f24c2d9fda4ceea4ee52329421b90aab6879513a21e8c84944209955df5f9
SIZE (bluescarni-obake-v0.7.0-24-gb8cc71c_GH0.tar.gz) = 407151
+SHA256 (1a53966f5ce8ca5542d3612c780ea4b69be34de2.patch) = f5179471baa9679aabd9f82c270587c49f746d1c0d6a2f3e94f27a29b2161cc9
+SIZE (1a53966f5ce8ca5542d3612c780ea4b69be34de2.patch) = 86326
+SHA256 (dadf4ce2aba713522d1949a16ffbf0fa5d6e6298.patch) = 61e33a538725204352bb4676d9d066c7ef6daa486c51a9d9e164b585b62876e5
+SIZE (dadf4ce2aba713522d1949a16ffbf0fa5d6e6298.patch) = 4971
+SHA256 (9310de2cb5cc4c85b54e7e90aa6cd88664380346.patch) = 1680b5940776073f762b4f8a05128aac144da8acac966625ccbb0021fcf99e99
+SIZE (9310de2cb5cc4c85b54e7e90aa6cd88664380346.patch) = 2341
+SHA256 (57da8d5f2d0c50e857979ba74434893b0b392382.patch) = 814754a9447f2efed9372a73080c29884ccbe71d74d6dde79ea72afeb9f3f892
+SIZE (57da8d5f2d0c50e857979ba74434893b0b392382.patch) = 721
+SHA256 (494df04bd7608bb666efde776241370cb84c96bb.patch) = 381c334d50c375d0251353d1a586fc488946fa880fe0f32bf2b7791a1b851625
+SIZE (494df04bd7608bb666efde776241370cb84c96bb.patch) = 679
diff --git a/math/obake/pkg-plist b/math/obake/pkg-plist
index cf449749bd53..4e967b76247d 100644
--- a/math/obake/pkg-plist
+++ b/math/obake/pkg-plist
@@ -6,6 +6,7 @@ include/obake/detail/abseil.hpp
include/obake/detail/atomic_flag_array.hpp
include/obake/detail/atomic_lock_guard.hpp
include/obake/detail/fcast.hpp
+include/obake/detail/fmt_compat.hpp
include/obake/detail/fw_utils.hpp
include/obake/detail/hc.hpp
include/obake/detail/ignore.hpp