aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-11-08 15:21:19 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-11-09 21:52:29 +0000
commitbc87463a962176640419e9f72199e13dc0ee7c67 (patch)
treed851577d84247554dbb119a1c9f5f8e9e301be86
parentb8ae34430bf9fdc584e22d7ec89ecb80da323255 (diff)
downloadports-bc87463a962176640419e9f72199e13dc0ee7c67.tar.gz
ports-bc87463a962176640419e9f72199e13dc0ee7c67.zip
graphics/sciplot: New port: Modern C++ scientific plotting library powered by gnuplot
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/sciplot/Makefile28
-rw-r--r--graphics/sciplot/distinfo3
-rw-r--r--graphics/sciplot/pkg-descr5
-rw-r--r--graphics/sciplot/pkg-plist43
5 files changed, 80 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d1c238ad41da..34540fef8328 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1050,6 +1050,7 @@
SUBDIR += sane-epkowa
SUBDIR += scale2x
SUBDIR += scantailor
+ SUBDIR += sciplot
SUBDIR += scr2png
SUBDIR += scrot
SUBDIR += scwm-icons
diff --git a/graphics/sciplot/Makefile b/graphics/sciplot/Makefile
new file mode 100644
index 000000000000..602e9e955c2d
--- /dev/null
+++ b/graphics/sciplot/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= sciplot
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.1
+CATEGORIES= graphics
+PKGNAMESUFFIX= -plotting-library
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Modern C++ scientific plotting library powered by gnuplot
+WWW= https://sciplot.github.io/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= gnuplot:math/gnuplot
+
+USES= cmake:testing compiler:c++17-lang
+USE_GITHUB= yes
+
+CMAKE_OFF= SCIPLOT_BUILD_TESTS SCIPLOT_BUILD_EXAMPLES SCIPLOT_BUILD_DOCS
+CMAKE_TESTING_ON= SCIPLOT_BUILD_TESTS
+CMAKE_TESTING_TARGET= ${ALL_TARGET} # no test target, see https://github.com/sciplot/sciplot/issues/105
+
+NO_ARCH= yes
+
+post-test:
+ @cd ${TEST_WRKSRC} && tests/sciplot-cpptests
+
+.include <bsd.port.mk>
diff --git a/graphics/sciplot/distinfo b/graphics/sciplot/distinfo
new file mode 100644
index 000000000000..e81e91e94146
--- /dev/null
+++ b/graphics/sciplot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1668023049
+SHA256 (sciplot-sciplot-v0.3.1_GH0.tar.gz) = d5f8fa7783920c0db4f54d8d9cea8a5e50be99153e81dcaccf91532994ebbad0
+SIZE (sciplot-sciplot-v0.3.1_GH0.tar.gz) = 1801509
diff --git a/graphics/sciplot/pkg-descr b/graphics/sciplot/pkg-descr
new file mode 100644
index 000000000000..4435df6ea79b
--- /dev/null
+++ b/graphics/sciplot/pkg-descr
@@ -0,0 +1,5 @@
+The goal of the sciplot project is to enable C++ programs to conveniently plot
+beautiful graphs as easy as in other high-level programming languages. sciplot
+is a header-only library that needs a C++17-capable compiler, but has no
+external dependencies for compiling. The only external runtime dependencies are
+gnuplot-palettes for providing color palettes and a gnuplot executable.
diff --git a/graphics/sciplot/pkg-plist b/graphics/sciplot/pkg-plist
new file mode 100644
index 000000000000..650ae235c403
--- /dev/null
+++ b/graphics/sciplot/pkg-plist
@@ -0,0 +1,43 @@
+include/sciplot/Canvas.hpp
+include/sciplot/ColumnIndex.hpp
+include/sciplot/Constants.hpp
+include/sciplot/Default.hpp
+include/sciplot/Enums.hpp
+include/sciplot/Figure.hpp
+include/sciplot/Palettes.hpp
+include/sciplot/Plot.hpp
+include/sciplot/Plot2D.hpp
+include/sciplot/Plot3D.hpp
+include/sciplot/StringOrDouble.hpp
+include/sciplot/Utils.hpp
+include/sciplot/Vec.hpp
+include/sciplot/sciplot.hpp
+include/sciplot/specs/AxisLabelSpecs.hpp
+include/sciplot/specs/BorderSpecs.hpp
+include/sciplot/specs/DepthSpecsOf.hpp
+include/sciplot/specs/DrawSpecs.hpp
+include/sciplot/specs/FillSpecsOf.hpp
+include/sciplot/specs/FillStyleSpecs.hpp
+include/sciplot/specs/FilledCurvesSpecsOf.hpp
+include/sciplot/specs/FontSpecsOf.hpp
+include/sciplot/specs/FrameSpecsOf.hpp
+include/sciplot/specs/GridSpecs.hpp
+include/sciplot/specs/GridSpecsBase.hpp
+include/sciplot/specs/HistogramStyleSpecs.hpp
+include/sciplot/specs/LabelSpecs.hpp
+include/sciplot/specs/LayoutSpecs.hpp
+include/sciplot/specs/LegendSpecs.hpp
+include/sciplot/specs/LineSpecsOf.hpp
+include/sciplot/specs/OffsetSpecsOf.hpp
+include/sciplot/specs/PointSpecsOf.hpp
+include/sciplot/specs/ShowSpecsOf.hpp
+include/sciplot/specs/Specs.hpp
+include/sciplot/specs/TextSpecsOf.hpp
+include/sciplot/specs/TicsSpecs.hpp
+include/sciplot/specs/TicsSpecsBaseOf.hpp
+include/sciplot/specs/TicsSpecsMajor.hpp
+include/sciplot/specs/TicsSpecsMinor.hpp
+include/sciplot/specs/TitleSpecsOf.hpp
+%%DATADIR%%/sciplotConfig.cmake
+%%DATADIR%%/sciplotConfigVersion.cmake
+%%DATADIR%%/sciplotTargets.cmake