aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-05-30 11:46:42 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-05-30 11:46:42 +0000
commitbcd33cb437416f93f50d7f19d310ca8c8173f945 (patch)
tree4b9a72e4a39c62a19c19ef60e9cf25c5443148a9
parent3ec5ed27aa0364b3966981cd80ceeade1dc08453 (diff)
downloadports-bcd33cb437416f93f50d7f19d310ca8c8173f945.tar.gz
ports-bcd33cb437416f93f50d7f19d310ca8c8173f945.zip
audio/mpz: the port had been updated to version 1.0.20
Now has better support building itself against system dependencies (less patching required). Reported by: portscout
-rw-r--r--audio/mpz/Makefile4
-rw-r--r--audio/mpz/distinfo6
-rw-r--r--audio/mpz/files/patch-app_app.pro25
-rw-r--r--audio/mpz/files/patch-app_coverart_embedded.cpp25
-rw-r--r--audio/mpz/files/patch-mpz.pro13
5 files changed, 13 insertions, 60 deletions
diff --git a/audio/mpz/Makefile b/audio/mpz/Makefile
index b0df07bb32dc..3a48092b8a9f 100644
--- a/audio/mpz/Makefile
+++ b/audio/mpz/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= mpz
-PORTVERSION= 1.0.19
+PORTVERSION= 1.0.20
CATEGORIES= audio
MAINTAINER= danfe@FreeBSD.org
@@ -20,6 +20,8 @@ USE_GSTREAMER= flac libav mpg123 ogg opus vorbis
USE_QT= buildtools_build concurrent core dbus gui multimedia \
network widgets x11extras
+QMAKE_ARGS= DEFINES+=USE_SYSTEM_TAGLIB DEFINES+=USE_SYSTEM_YAMLCPP
+
post-extract:
@${RM} -r ${WRKSRC}/libs/taglib ${WRKSRC}/libs/yaml-cpp
diff --git a/audio/mpz/distinfo b/audio/mpz/distinfo
index 9e6b794ac9af..b12c8e1a2448 100644
--- a/audio/mpz/distinfo
+++ b/audio/mpz/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1638963522
-SHA256 (olegantonyan-mpz-1.0.19_GH0.tar.gz) = 2496d849d953eaae911a7bfb10006d7e31118df33666fe01a9fbb6fae1a5f697
-SIZE (olegantonyan-mpz-1.0.19_GH0.tar.gz) = 2700174
+TIMESTAMP = 1653719700
+SHA256 (olegantonyan-mpz-1.0.20_GH0.tar.gz) = bd4d14e1cb2207745dd022f9633671a904ae3ef60a9f8ef3005939413213a86c
+SIZE (olegantonyan-mpz-1.0.20_GH0.tar.gz) = 2702505
diff --git a/audio/mpz/files/patch-app_app.pro b/audio/mpz/files/patch-app_app.pro
index 28b6191706ac..134401c52986 100644
--- a/audio/mpz/files/patch-app_app.pro
+++ b/audio/mpz/files/patch-app_app.pro
@@ -1,28 +1,11 @@
---- app/app.pro.orig 2021-12-08 11:38:42 UTC
+--- app/app.pro.orig 2022-05-28 06:35:00 UTC
+++ app/app.pro
-@@ -171,16 +171,12 @@ contains(DEFINES, MPRIS_ENABLE) {
-
- # Libraries
- INCLUDEPATH += \
-- ../libs/taglib/taglib-1.12/taglib \
-- ../libs/taglib/taglib-1.12/taglib/toolkit \
-- ../libs/taglib/taglib-1.12/taglib/mpeg/id3v2 \
-- ../libs/yaml-cpp/yaml-cpp-0.7.0/include \
-+ ${LOCALBASE}/include/taglib \
- ../libs/qtwaitingspinner \
- ../libs/qhotkey/QHotkey-1.5.0
-
- LIBS += \
-- -L../libs/taglib -ltaglib \
-- -L../libs/yaml-cpp -lyaml-cpp \
-+ -L${LOCALBASE}/lib -ltag -lyaml-cpp \
- -L../libs/qtwaitingspinner -lqtwaitingspinner \
- -L../libs/qhotkey -lqhotkey
-
-@@ -191,5 +187,5 @@ RESOURCES += \
+@@ -205,7 +205,7 @@ RESOURCES += \
../resources.qrc
# make install
-target.path = /usr/bin/
+target.path = $$PREFIX/bin/
INSTALLS += target
+
+ TRANSLATIONS += \
diff --git a/audio/mpz/files/patch-app_coverart_embedded.cpp b/audio/mpz/files/patch-app_coverart_embedded.cpp
deleted file mode 100644
index 3c0a2a5b7f8f..000000000000
--- a/audio/mpz/files/patch-app_coverart_embedded.cpp
+++ /dev/null
@@ -1,25 +0,0 @@
---- app/coverart/embedded.cpp.orig 2021-12-08 11:38:42 UTC
-+++ app/coverart/embedded.cpp
-@@ -1,14 +1,14 @@
- #include "coverart/embedded.h"
-
- #include "tag.h"
--#include "mp4/mp4file.h"
--#include "mpeg/id3v2/id3v2.h"
--#include "mpeg/id3v2/id3v2frame.h"
--#include "mpeg/id3v2/frames/attachedpictureframe.h"
--#include "mpeg/id3v2/id3v2tag.h"
--#include "mpeg/mpegfile.h"
--#include "flac/flacfile.h"
--#include"flac/flacpicture.h"
-+#include "mp4file.h"
-+#include "id3v2.h"
-+#include "id3v2frame.h"
-+#include "attachedpictureframe.h"
-+#include "id3v2tag.h"
-+#include "mpegfile.h"
-+#include "flacfile.h"
-+#include "flacpicture.h"
- #include "fileref.h"
- #include "tag.h"
- #include "tpropertymap.h"
diff --git a/audio/mpz/files/patch-mpz.pro b/audio/mpz/files/patch-mpz.pro
index c599bf0b3cf4..4bd016476340 100644
--- a/audio/mpz/files/patch-mpz.pro
+++ b/audio/mpz/files/patch-mpz.pro
@@ -1,14 +1,7 @@
---- mpz.pro.orig 2020-10-22 11:15:32 UTC
+--- mpz.pro.orig 2022-05-28 06:35:00 UTC
+++ mpz.pro
-@@ -2,39 +2,37 @@ TEMPLATE = subdirs
- CONFIG += ordered
-
- SUBDIRS = \
-- libs/taglib \
-- libs/yaml-cpp \
- libs/qtwaitingspinner \
- libs/qhotkey \
- app
+@@ -13,32 +13,32 @@ SUBDIRS += app
+ SUBDIRS += app
# make install
-desktop.path = /usr/share/applications/