aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-06-08 19:33:02 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-06-08 20:01:56 +0000
commitbce5435ffc8066166eaa63df31ae14cac6f3a03f (patch)
tree240aaa18dc25d46d9db86176d485f22a3699995e
parent0ee68aa1362545e33637726c6a8d692b6b2d1fca (diff)
downloadports-bce5435ffc8066166eaa63df31ae14cac6f3a03f.tar.gz
ports-bce5435ffc8066166eaa63df31ae14cac6f3a03f.zip
emulators/mame: fix build on powerpc* CURRENT
Use newer LLVM: Assertion failed: (ESI.Type != EST_Uninstantiated), function SubstExceptionSpec, file /usr/local/poudriere/jails/main-powerpc/usr/src/contrib/llvm-project/clang/lib/Sema/SemaTemplateInstantiate.cpp, line 2240.
-rw-r--r--emulators/mame/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index b30e6045915f..ffeae0127dc2 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -104,7 +104,11 @@ WITH_DEBUG= yes
.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1400000
+.if ${ARCH:Mpowerpc*}
+USES+= llvm:min=16,build
+.else
USES+= llvm:15,build
+.endif
MAKE_ENV+= OVERRIDE_AR="llvm-ar${LLVM_VERSION}" \
OVERRIDE_CC="clang${LLVM_VERSION}" \
OVERRIDE_CXX="clang++${LLVM_VERSION}" \