aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2023-05-29 13:19:04 +0000
committerNicola Vitale <nivit@FreeBSD.org>2023-05-29 13:19:04 +0000
commitbd2e1ac71ad667fd25b4f86f935a58deb63db875 (patch)
tree83c9a09a117fbf85a550d606591680a01c73017f
parent2764ed8654ad3013a97d2deec914e2f8de509bfc (diff)
downloadports-bd2e1ac71ad667fd25b4f86f935a58deb63db875.tar.gz
ports-bd2e1ac71ad667fd25b4f86f935a58deb63db875.zip
deskutils/freeplane: Update to 1.11.4
- Install a .desktop file for a better integration with desktop environments - Fix startup script so that you can pass arguments to the program
-rw-r--r--deskutils/freeplane/Makefile17
-rw-r--r--deskutils/freeplane/distinfo6
-rw-r--r--deskutils/freeplane/files/freeplane.desktop.in14
-rw-r--r--deskutils/freeplane/files/freeplane.in2
-rw-r--r--deskutils/freeplane/files/patch-freeplane.sh43
-rw-r--r--deskutils/freeplane/pkg-plist2
6 files changed, 47 insertions, 37 deletions
diff --git a/deskutils/freeplane/Makefile b/deskutils/freeplane/Makefile
index f740c84e8b33..1e272bbddd97 100644
--- a/deskutils/freeplane/Makefile
+++ b/deskutils/freeplane/Makefile
@@ -1,5 +1,5 @@
PORTNAME= freeplane
-DISTVERSION= 1.11.2
+DISTVERSION= 1.11.4
CATEGORIES= deskutils editors java
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable
DISTNAME= ${PORTNAME}_bin-${PORTVERSION}
@@ -13,23 +13,26 @@ LICENSE_FILE= ${WRKSRC}/license.txt
RUN_DEPENDS= bash:shells/bash
-USES= cpe shebangfix zip
+USES= cpe desktop-file-utils shebangfix zip
USE_JAVA= yes
SHEBANG_FILES= ${WRKSRC}/freeplane.sh
NO_ARCH= yes
NO_BUILD= yes
+SUB_FILES= freeplane freeplane.desktop
+SUB_LIST= DATADIR=${DATADIR} \
+ PREFIX=${PREFIX}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_SUB= PORTVERSION="${PORTVERSION}"
+
do-install:
cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} \
- "! ( -name license\.txt -or -name *\.bat -or -name *\.exe )"
-# Install freeplane.sh with the right permission
- ${SED} -e 's|%%DATADIR%%|${DATADIR}|' < ${FILESDIR}/freeplane.in > \
- ${WRKSRC}/freeplane
- ${INSTALL_SCRIPT} ${WRKSRC}/freeplane ${STAGEDIR}${PREFIX}/bin/
+ "! ( -name license\.txt -or -name *\.bat -or -name *\.exe -or -name *\.orig -or -name *\.bak -or -name freeplane.sh )"
+ ${INSTALL_DATA} ${WRKDIR}/freeplane.desktop ${STAGEDIR}${DESKTOPDIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/freeplane.sh ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/freeplane ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/deskutils/freeplane/distinfo b/deskutils/freeplane/distinfo
index 55f233217422..ab3dc79378bb 100644
--- a/deskutils/freeplane/distinfo
+++ b/deskutils/freeplane/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1683618234
-SHA256 (freeplane_bin-1.11.2.zip) = ff2f6482f66873fb66c4e82494fa67a3ec7a913ff8eeb0adb690b0ead5a173ef
-SIZE (freeplane_bin-1.11.2.zip) = 52987091
+TIMESTAMP = 1685353064
+SHA256 (freeplane_bin-1.11.4.zip) = 90f290ae88b92b554885677c61ff69b91ee1a51b07d7ddf7ff6e90047975d629
+SIZE (freeplane_bin-1.11.4.zip) = 53088167
diff --git a/deskutils/freeplane/files/freeplane.desktop.in b/deskutils/freeplane/files/freeplane.desktop.in
new file mode 100644
index 000000000000..2bb5e5b2cf8e
--- /dev/null
+++ b/deskutils/freeplane/files/freeplane.desktop.in
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=1.0
+Name=Freeplane
+Categories=Office;
+Comment=A free tool to structure and organise your information with mind mapping
+Exec=%%PREFIX%%/bin/freeplane %F
+GenericName=Freeplane
+Icon=%%DATADIR%%/freeplane.svg
+Keywords=Mindmaps; Knowledge management; Organize information; Brainstorming; ...;
+MimeType=application/x-freeplane;
+StartupNotify=true
+StartupWMClass=org-knopflerfish-framework-BundleThread
+Terminal=false
+Type=Application
diff --git a/deskutils/freeplane/files/freeplane.in b/deskutils/freeplane/files/freeplane.in
index 979424a424e4..c61217966e84 100644
--- a/deskutils/freeplane/files/freeplane.in
+++ b/deskutils/freeplane/files/freeplane.in
@@ -1,3 +1,3 @@
#!/bin/sh
-exec /bin/sh %%DATADIR%%/freeplane.sh
+exec %%DATADIR%%/freeplane.sh "$@"
diff --git a/deskutils/freeplane/files/patch-freeplane.sh b/deskutils/freeplane/files/patch-freeplane.sh
index 946d90da0874..49a21b5c745d 100644
--- a/deskutils/freeplane/files/patch-freeplane.sh
+++ b/deskutils/freeplane/files/patch-freeplane.sh
@@ -1,28 +1,21 @@
---- freeplane.sh.orig 2022-07-04 06:07:42 UTC
+--- freeplane.sh.orig 2023-05-28 13:36:42 UTC
+++ freeplane.sh
-@@ -57,7 +57,7 @@ findjava() {
- fi
- fi
+@@ -1,5 +1,9 @@
+ #!/bin/bash
-- JAVA_VERSION=$(${JAVACMD} -version |& grep -E "[[:alnum:]]+ version" | awk '{print $3}' | tr -d '"')
-+ JAVA_VERSION=$(${JAVACMD} -version | grep -E "[[:alnum:]]+ version" | awk '{print $3}' | tr -d '"')
- JAVA_MAJOR_VERSION=$(echo $JAVA_VERSION | sed -e 's/^1\.//' | awk -F. '{print $1}')
- if [ $JAVA_MAJOR_VERSION -lt 8 ] || [ $JAVA_MAJOR_VERSION -gt 17 ] || [ $JAVA_MAJOR_VERSION -eq 10 ]; then
- if [ -z "${FREEPLANE_USE_UNSUPPORTED_JAVA_VERSION}" ]; then
-@@ -142,15 +142,7 @@ fi
-
- output_debug_info
-
--if [ -x $(which readlink) ] && [ "`echo $OSTYPE | cut -b1-6`" != "darwin" ]; then
-- # if we have 'readlink' we can use it to get an absolute path
-- # -m should be faster and link does always resolve, else this script
-- # wouldn't be called, would it?
++if [ -z "$OSTYPE" ]; then
++ OSTYPE="$(uname -o)"
++fi
++
+ # we only want to test the script, not Freeplane itself
+ if ( echo "${DEBUG}" | grep -qe "script" ); then
+ set -x
+@@ -146,7 +150,7 @@ if [ -x $(which readlink) ] && [ "`echo $OSTYPE | cut
+ # if we have 'readlink' we can use it to get an absolute path
+ # -m should be faster and link does always resolve, else this script
+ # wouldn't be called, would it?
- freefile=$(readlink -mn "$0")
-- _debug "Link '$0' resolved to '${freefile}'."
--else
-- freefile="$0"
--fi
-+freefile="$0"
-
- if [ "`echo $OSTYPE | cut -b1-6`" == "darwin" ]; then
- xdockname='-Xdock:name=Freeplane'
++ freefile=$(readlink -fn "$0")
+ _debug "Link '$0' resolved to '${freefile}'."
+ else
+ freefile="$0"
diff --git a/deskutils/freeplane/pkg-plist b/deskutils/freeplane/pkg-plist
index 6369a7a6ce72..22226f38da76 100644
--- a/deskutils/freeplane/pkg-plist
+++ b/deskutils/freeplane/pkg-plist
@@ -1,4 +1,5 @@
bin/freeplane
+share/applications/freeplane.desktop
%%DATADIR%%/core/org.freeplane.core/META-INF/MANIFEST.MF
%%DATADIR%%/core/org.freeplane.core/lib/common-image-3.9.4.jar
%%DATADIR%%/core/org.freeplane.core/lib/common-io-3.9.4.jar
@@ -253,7 +254,6 @@ bin/freeplane
%%DATADIR%%/freeplane.png
%%DATADIR%%/freeplane.policy
%%DATADIR%%/freeplane.sh
-%%DATADIR%%/freeplane.sh.orig
%%DATADIR%%/freeplane.svg
%%DATADIR%%/freeplaneConsole.l4j.ini
%%DATADIR%%/freeplaneIcons.dll