aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-03-27 20:13:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-03-27 20:16:27 +0000
commitbd78a1b4103aedc78d22c173685d9938ad8b8986 (patch)
tree59ce067b31df5c9bb3f2fe38ec8b3afa696d9254
parent81937131f3c85f2a5b8591cc8c94b5c3e88c5186 (diff)
downloadports-bd78a1b4103aedc78d22c173685d9938ad8b8986.tar.gz
ports-bd78a1b4103aedc78d22c173685d9938ad8b8986.zip
databases/arrow: Fix build on 13.2
The TESTING option (enabling the TESTING module) is disabled due to googletest incompatibility with C++17 -compiled code on 13.2 PR: 277953 Reported by: Palle Girgensohn <girgen@FreeBSD.org>
-rw-r--r--databases/arrow/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/databases/arrow/Makefile b/databases/arrow/Makefile
index 3df2af72231d..d4545fe4dd76 100644
--- a/databases/arrow/Makefile
+++ b/databases/arrow/Makefile
@@ -178,6 +178,14 @@ TESTING_DESC= Arrow testing libraries
TESTING_CMAKE_BOOL= ARROW_TESTING
TESTING_LIB_DEPENDS= libgtest.so:devel/googletest
+# workaround for https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=277953
+OPSYS!= uname -s # HACK: OPSYS is defined in bsd.port.options.mk which has to be later
+OSVERSION!= awk '/^\#define[[:blank:]]__FreeBSD_version/ {print $$3}' < ${CROSS_SYSROOT}/usr/include/sys/param.h # HACK: same as above
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1303000
+TESTING_BROKEN= configure fails because GTest built with C++ level <17 isn't compatible with C++17 used in arrow
+.endif
+
+# form OPTIONS_DEFAULT
.for opt in ${OPTIONS_GROUP_COMPONENTS}
. if "${${opt}_BROKEN}" == ""
OPTIONS_DEFAULT+= ${opt}