aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-05-08 08:56:48 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-05-10 16:19:49 +0000
commitbdade1d07488ae8fa9270263d8e8d8aa8af3652c (patch)
tree9076446dd7b896d5b79b10e8e6fee4b75c40ce15
parentf1df391af8b759fedf8651291ce2d405d8b32dae (diff)
downloadports-bdade1d07488ae8fa9270263d8e8d8aa8af3652c.tar.gz
ports-bdade1d07488ae8fa9270263d8e8d8aa8af3652c.zip
misc/air: fix build on powerpc64
cargo:warning=/usr/local/llvm15/lib/clang/15.0.7/include/ppc_wrappers/xmmintrin.h:31:2: error: "Please read comment above. Use -DNO_WARN_X86_INTRINSICS to disable this error."
-rw-r--r--misc/air/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/misc/air/Makefile b/misc/air/Makefile
index 8893fbf32e9b..b0107658e1d3 100644
--- a/misc/air/Makefile
+++ b/misc/air/Makefile
@@ -211,12 +211,19 @@ CARGO_CRATES= addr2line-0.21.0 \
winreg-0.50.0
CFLAGS_powerpc64le= -DNO_WARN_X86_INTRINSICS
+CFLAGS_powerpc64= -DNO_WARN_X86_INTRINSICS
OPENSSLINC= /usr/include
OPENSSLLIB= /usr/lib
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64 && !defined(CPUTYPE)
+CFLAGS+= -mcpu=power7
+.endif
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}