aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2023-02-13 22:49:08 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2023-02-13 22:50:38 +0000
commitbdcf7e293085355b046b5a334251a080c32edca3 (patch)
tree69d41f5c649c00484ae0b851e630d10ea8c251af
parent97400f86dcca45ff2a6c1e60d5f47f613fb2782f (diff)
downloadports-bdcf7e293085355b046b5a334251a080c32edca3.tar.gz
ports-bdcf7e293085355b046b5a334251a080c32edca3.zip
deskutils/xpostit: fix integer/pointer compile error
Recent compiler versions complain about the implicit conversion of an int to a (generic) pointer, apply appropriate cast. (This is 30-year old code.)
-rw-r--r--deskutils/xpostit/Makefile2
-rw-r--r--deskutils/xpostit/files/patch-menu.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/deskutils/xpostit/Makefile b/deskutils/xpostit/Makefile
index 9fea37a29ff9..6ec547371066 100644
--- a/deskutils/xpostit/Makefile
+++ b/deskutils/xpostit/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xpostit
PORTVERSION= 3.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
# DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
diff --git a/deskutils/xpostit/files/patch-menu.c b/deskutils/xpostit/files/patch-menu.c
new file mode 100644
index 000000000000..5ee09fc8d7d8
--- /dev/null
+++ b/deskutils/xpostit/files/patch-menu.c
@@ -0,0 +1,11 @@
+--- menu.c~ 1992-12-11 14:04:14.000000000 +0100
++++ menu.c 2023-02-13 23:44:16.137102000 +0100
+@@ -120,7 +120,7 @@
+ smeBSBObjectClass, menuwidget,
+ NULL, 0);
+
+- XtAddCallback(entry, XtNcallback, HandleMenuSelection, i);
++ XtAddCallback(entry, XtNcallback, HandleMenuSelection, (XtPointer)i);
+ }
+
+ XawSimpleMenuAddGlobalActions(appcontext);