aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2021-08-04 11:42:31 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2021-08-04 11:42:43 +0000
commitbf413125edadefba0a2bddcc5f3f5dd521f22537 (patch)
treeaf03527f5f6552ced2d47027eee6b7ad47a221c9
parent86915041db17fcc4976134dd9a0fbe4df27b44d4 (diff)
downloadports-bf413125edadefba0a2bddcc5f3f5dd521f22537.tar.gz
ports-bf413125edadefba0a2bddcc5f3f5dd521f22537.zip
sysutils/tmux-mem-cpu-load: Update to 3.5.0
-rw-r--r--sysutils/tmux-mem-cpu-load/Makefile3
-rw-r--r--sysutils/tmux-mem-cpu-load/distinfo6
-rw-r--r--sysutils/tmux-mem-cpu-load/files/patch-common_cpu.h11
-rw-r--r--sysutils/tmux-mem-cpu-load/files/patch-freebsd_memory.cc24
4 files changed, 15 insertions, 29 deletions
diff --git a/sysutils/tmux-mem-cpu-load/Makefile b/sysutils/tmux-mem-cpu-load/Makefile
index 436b9c02c0dd..30343445a256 100644
--- a/sysutils/tmux-mem-cpu-load/Makefile
+++ b/sysutils/tmux-mem-cpu-load/Makefile
@@ -1,8 +1,7 @@
# Created by: Adam Weinberger <adamw@FreeBSD.org>
PORTNAME= tmux-mem-cpu-load
-PORTVERSION= 3.4.0
-PORTREVISION= 4
+PORTVERSION= 3.5.0
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
diff --git a/sysutils/tmux-mem-cpu-load/distinfo b/sysutils/tmux-mem-cpu-load/distinfo
index fcd821f15979..03fb3a3292ac 100644
--- a/sysutils/tmux-mem-cpu-load/distinfo
+++ b/sysutils/tmux-mem-cpu-load/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1484523357
-SHA256 (thewtex-tmux-mem-cpu-load-v3.4.0_GH0.tar.gz) = a773994e160812a964abc7fc4e8ec16b7d9833edb0a66e5c67f287c7c5949ecb
-SIZE (thewtex-tmux-mem-cpu-load-v3.4.0_GH0.tar.gz) = 19483
+TIMESTAMP = 1628076750
+SHA256 (thewtex-tmux-mem-cpu-load-v3.5.0_GH0.tar.gz) = 555b8fe2dfbedd496e697c86aa0824a4ed3a4ade7e8c007b5cb11c962084b511
+SIZE (thewtex-tmux-mem-cpu-load-v3.5.0_GH0.tar.gz) = 23022
diff --git a/sysutils/tmux-mem-cpu-load/files/patch-common_cpu.h b/sysutils/tmux-mem-cpu-load/files/patch-common_cpu.h
new file mode 100644
index 000000000000..42237a044b95
--- /dev/null
+++ b/sysutils/tmux-mem-cpu-load/files/patch-common_cpu.h
@@ -0,0 +1,11 @@
+--- common/cpu.h.orig 2021-08-04 11:37:18 UTC
++++ common/cpu.h
+@@ -45,7 +45,7 @@
+ #endif
+
+ float cpu_percentage( unsigned );
+-uint32_t get_cpu_count();
++uint8_t get_cpu_count();
+
+ /** CPU percentage output mode.
+ *
diff --git a/sysutils/tmux-mem-cpu-load/files/patch-freebsd_memory.cc b/sysutils/tmux-mem-cpu-load/files/patch-freebsd_memory.cc
deleted file mode 100644
index d6c2344c9274..000000000000
--- a/sysutils/tmux-mem-cpu-load/files/patch-freebsd_memory.cc
+++ /dev/null
@@ -1,24 +0,0 @@
-From e24890652e3674fe4677722aab8644e62da37348 Mon Sep 17 00:00:00 2001
-From: Dima Panov <fluffy@FreeBSD.org>
-Date: Fri, 20 Dec 2019 02:47:32 +1000
-Subject: [PATCH] Fix calculate memory usage on FreeBSD
-
----
- freebsd/memory.cc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/freebsd/memory.cc b/freebsd/memory.cc
-index 5500032..687a0a8 100644
---- freebsd/memory.cc
-+++ freebsd/memory.cc
-@@ -63,8 +63,8 @@ void mem_status( MemoryStatus & status )
- //u_int unused = ( cache + inactive + free ) * page_size;
-
- // Used memory on FreeBSD is active + wired.
-- u_int used = ( active + wired ) * page_size;
-+ u_int used = ( active + wired );
-
-- status.used_mem = convert_unit( static_cast< float >( used ), MEGABYTES );
-+ status.used_mem = convert_unit( static_cast< float >( used * (page_size >> 10) ), MEGABYTES, KILOBYTES );
- status.total_mem = convert_unit( static_cast< float >( page_count * (page_size >> 10) ), MEGABYTES, KILOBYTES);
- }