aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2023-02-14 20:47:16 +0000
committerDan Langille <dvl@FreeBSD.org>2023-02-14 20:48:38 +0000
commitbf8338b77fa98dbb1cfe87da864e2af994ef1ace (patch)
tree1e5537940a21eaa0ac742f1abf8c5376ba31590f
parente2630f644fcb41ca2f9cba64a2e4416043b59fda (diff)
downloadports-bf8338b77fa98dbb1cfe87da864e2af994ef1ace.tar.gz
ports-bf8338b77fa98dbb1cfe87da864e2af994ef1ace.zip
net-mgmt/icingaweb2: add SHEBANG fix for bin/icingacli
PR: 269558 Approved by: maintainer (via private email)
-rw-r--r--net-mgmt/icingaweb2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-mgmt/icingaweb2/Makefile b/net-mgmt/icingaweb2/Makefile
index b3535744898a..26e5bdd7ebb0 100644
--- a/net-mgmt/icingaweb2/Makefile
+++ b/net-mgmt/icingaweb2/Makefile
@@ -1,6 +1,7 @@
PORTNAME= icingaweb2
DISTVERSIONPREFIX= v
DISTVERSION= 2.11.4
+PORTREVISION= 1
CATEGORIES= net-mgmt www
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
@@ -15,7 +16,7 @@ RUN_DEPENDS= icinga-php-library${PHP_PKGNAMESUFFIX}>=0.10.0:net-mgmt/icinga-php-
icinga-php-thirdparty${PHP_PKGNAMESUFFIX}>=0.11.0:net-mgmt/icinga-php-thirdparty@${PHP_FLAVOR} \
icingaweb2-module-incubator${PHP_PKGNAMESUFFIX}>=0.18.0:net-mgmt/icingaweb2-module-incubator@${PHP_FLAVOR}
-USES= php:build,web,flavors
+USES= php:build,web,flavors shebangfix
USE_PHP= bcmath bitset ctype curl dom gd gettext hash iconv json ldap \
mbstring mcrypt memcache memcached opcache openssl pcre pdo \
pdo_sqlite posix session simplexml soap sockets sqlite3 xml \
@@ -29,6 +30,8 @@ NO_ARCH= yes
CONFLICTS_INSTALL= icingaweb2-php* # bin/icingacli
+SHEBANG_FILES= bin/icingacli
+
SUB_FILES= pkg-message
SUB_LIST= ETCDIR=${ETCDIR} \
EXAMPLESDIR=${EXAMPLESDIR} \