aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-08-31 18:23:32 +0000
committerCy Schubert <cy@FreeBSD.org>2021-08-31 19:25:53 +0000
commitbf9e35445d7da021a83f3c7dba9874def987d19f (patch)
tree67f738643b697f6883f44d56ab318c011c0397a3
parent4cf22b504ccf9e40971e8a7bcc00c91b6e61ccaf (diff)
downloadports-bf9e35445d7da021a83f3c7dba9874def987d19f.tar.gz
ports-bf9e35445d7da021a83f3c7dba9874def987d19f.zip
mail/exmh2: Resolve state(tag) error
can't read "state(tag)": no such variable, has returned with tcl 8.7a5. Resolve this error for good.
-rw-r--r--mail/exmh2/Makefile2
-rw-r--r--mail/exmh2/files/patch-lib_html__text.tcl20
2 files changed, 21 insertions, 1 deletions
diff --git a/mail/exmh2/Makefile b/mail/exmh2/Makefile
index adf14881c048..24566242400d 100644
--- a/mail/exmh2/Makefile
+++ b/mail/exmh2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= exmh
PORTVERSION= 2.9.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES+= mail tk
# XXX: Standard SF fails with a hung download
MASTER_SITES= https://sourceforge.net/projects/${PORTNAME}/files/${PORTNAME}/${PORTVERSION}/
diff --git a/mail/exmh2/files/patch-lib_html__text.tcl b/mail/exmh2/files/patch-lib_html__text.tcl
new file mode 100644
index 000000000000..88391545e54d
--- /dev/null
+++ b/mail/exmh2/files/patch-lib_html__text.tcl
@@ -0,0 +1,20 @@
+--- lib/html_text.tcl.orig 2017-11-09 20:42:24.000000000 -0800
++++ lib/html_text.tcl 2021-08-31 11:19:25.451174000 -0700
+@@ -60,7 +60,7 @@
+ }
+ set state(tag) $tag
+ $win dump -tag -text -window -command \
+- [list TextUndoTagAddProc state $win] $m1 $m2
++ [list TextUndoTagAddProc state $win] $m1 $m2 tag
+ TextUndoTagAdd state $win [$win index $m2]
+ $win tag add $tag $m1 $m2
+ }
+@@ -179,7 +179,7 @@
+ unset state(ix)
+ }
+ }
+-proc TextUndoTagAddProc {stateVar win key value ix} {
++proc TextUndoTagAddProc {stateVar win key value ix tag} {
+ upvar $stateVar state
+ switch -- $key {
+ tagon {