aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-11-19 08:13:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-11-19 08:13:33 +0000
commitc0787c840c5b43e607e534bdfc32546f70c902b1 (patch)
tree477820c7db5912bdb513e6937f812d6ad3773149
parent9bf459c57027c045d803683176268f30bf1df272 (diff)
downloadports-c0787c840c5b43e607e534bdfc32546f70c902b1.tar.gz
ports-c0787c840c5b43e607e534bdfc32546f70c902b1.zip
devel/py-jupyter-client: Fix fe1cb27d684be2279f9bf64e6f1464a9ff46151e
- Remove unneeded BUILD_DEPENDS - Add missing RUN_DEPENDS - Remove outdated PORTSCOUT - Bump PORTREVISION for dependency change
-rw-r--r--devel/py-jupyter-client/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/devel/py-jupyter-client/Makefile b/devel/py-jupyter-client/Makefile
index 61a748eb29d2..3c9678894bd3 100644
--- a/devel/py-jupyter-client/Makefile
+++ b/devel/py-jupyter-client/Makefile
@@ -1,5 +1,6 @@
PORTNAME= jupyter-client
DISTVERSION= 7.4.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,29 +13,27 @@ WWW= https://jupyter.org/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING.md
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>0:devel/py-hatchling@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}entrypoints>0:devel/py-entrypoints@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}entrypoints>=0:devel/py-entrypoints@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jupyter-core>=4.9.2:devel/py-jupyter-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nest-asyncio>=1.5.4:devel/py-nest-asyncio@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=2.8.2:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyzmq>=23.0:net/py-pyzmq@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tornado>=6.2:www/py-tornado@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}traitlets>0:devel/py-traitlets@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}codecov>0:devel/py-codecov@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}coverage>0:devel/py-coverage@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}traitlets>=0:devel/py-traitlets@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}codecov>=0:devel/py-codecov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ipykernel>=6.5:devel/py-ipykernel@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}ipython>0:devel/ipython@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mypy>0:devel/py-mypy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ipython>=0:devel/ipython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mypy>=0:devel/py-mypy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0.18:devel/py-pytest-asyncio@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-timeout>0:devel/py-pytest-timeout@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-timeout>=0:devel/py-pytest-timeout@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils pytest # 1 test fails, see https://github.com/jupyter/jupyter_client/issues/855
NO_ARCH= yes
-PORTSCOUT= skipv:6.1.13,6.2.0
-
# upstream stopped providing setup.py
post-patch:
@${ECHO_CMD} 'import setuptools; setuptools.setup()' > ${WRKSRC}/setup.py