aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-10-18 19:17:09 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-10-19 07:07:31 +0000
commitc07e560b22f7edc7d26098be318af3c415311c9a (patch)
tree3a94354d5668dcbc6efdd811706e207703fdbedd
parentdd4aa61a9e9d623aa62f2ff529e933f240aa0223 (diff)
downloadports-c07e560b22f7edc7d26098be318af3c415311c9a.tar.gz
ports-c07e560b22f7edc7d26098be318af3c415311c9a.zip
science/py-pymol: fix build on targets without OpenMP
armv7 still doesn't have it, so disable OpenMP there to make the port build. The previous problem from PR 262208 seems to no longer occur. Approved by: portmgr (build fix blanket) MFH: 2023Q4
-rw-r--r--science/py-pymol/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/science/py-pymol/Makefile b/science/py-pymol/Makefile
index ae9365af177c..b31b04de6cb9 100644
--- a/science/py-pymol/Makefile
+++ b/science/py-pymol/Makefile
@@ -39,6 +39,11 @@ CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}chempy # chempy port is unrelated, see
CXXFLAGS+= -DMSGPACK_NO_BOOST # in line with MSGPACK_USE_BOOST=OFF in devel/msgpack-cxx
+.if !exists(/usr/include/omp.h)
+PYDISTUTILS_CONFIGUREARGS+= --use-openmp=no
+PYDISTUTILS_BUILDARGS+= --use-openmp=no
+.endif
+
OPTIONS_SINGLE= GUI
OPTIONS_SINGLE_GUI= QT5 TK
OPTIONS_DEFAULT= QT5