aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-08-09 15:59:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-08-09 16:03:07 +0000
commitc0ad875984407cf58be8f547e0b66f179e39c1a8 (patch)
tree445ff717fb8483f13aafa83b40e1f02478407c46
parent913b526c6eceabf9f68e3448a0bc01bb3ab59799 (diff)
downloadports-c0ad875984407cf58be8f547e0b66f179e39c1a8.tar.gz
ports-c0ad875984407cf58be8f547e0b66f179e39c1a8.zip
audio/stk: Update 4.6.2 → 5.0.0
Also add audio backend options. Reported by: portscout
-rw-r--r--audio/csound/Makefile2
-rw-r--r--audio/polyphone/Makefile2
-rw-r--r--audio/sc3-plugins/Makefile2
-rw-r--r--audio/stk/Makefile19
-rw-r--r--audio/stk/distinfo6
-rw-r--r--audio/stk/files/patch-configure101
-rw-r--r--audio/stk/files/patch-configure.ac60
-rw-r--r--audio/stk/pkg-plist2
8 files changed, 121 insertions, 73 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 9988b2d54673..eb4caaf7c139 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -1,6 +1,6 @@
PORTNAME= csound
DISTVERSION= 6.15.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= audio lang
MAINTAINER= yuri@FreeBSD.org
diff --git a/audio/polyphone/Makefile b/audio/polyphone/Makefile
index b0b4f7fa9d87..e8f326204209 100644
--- a/audio/polyphone/Makefile
+++ b/audio/polyphone/Makefile
@@ -1,6 +1,6 @@
PORTNAME= polyphone
DISTVERSION= 2.3.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
diff --git a/audio/sc3-plugins/Makefile b/audio/sc3-plugins/Makefile
index 7cd177eff4bc..a8fb868905c4 100644
--- a/audio/sc3-plugins/Makefile
+++ b/audio/sc3-plugins/Makefile
@@ -1,7 +1,7 @@
PORTNAME= sc3-plugins
DISTVERSIONPREFIX= Version-
DISTVERSION= 3.9.0
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
diff --git a/audio/stk/Makefile b/audio/stk/Makefile
index 6a2467dd66bd..47d7f4160734 100644
--- a/audio/stk/Makefile
+++ b/audio/stk/Makefile
@@ -1,6 +1,5 @@
PORTNAME= stk
-PORTVERSION= 4.6.2
-PORTREVISION= 1
+DISTVERSION= 5.0.0
CATEGORIES= audio
MASTER_SITES= http://ccrma.stanford.edu/software/stk/release/
@@ -11,20 +10,28 @@ WWW= https://ccrma.stanford.edu/software/stk
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libjack.so:audio/jack
-
-USES= autoreconf compiler:c++11-lang dos2unix gmake localbase pkgconfig
+USES= compiler:c++11-lang dos2unix gmake localbase pkgconfig
USE_LDCONFIG= yes
DOS2UNIX_GLOB= *.cpp *.h
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-jack --with-oss
MAKE_ARGS= RAWWAVES=${DATADIR}/rawwaves/
LDFLAGS+= -pthread
+OPTIONS_RADIO= BACKEND
+OPTIONS_RADIO_BACKEND= JACK OSS
+OPTIONS_DEFAULT= OSS
+
+BACKEND_DESC= Audio Backend
+
+JACK_CONFIGURE_WITH= jack
+JACK_LIB_DEPENDS= libjack.so:audio/jack
+
+OSS_CONFIGURE_WITH= oss
+
post-install:
@cd ${WRKSRC} && ${COPYTREE_SHARE} rawwaves ${STAGEDIR}${DATADIR}
@${RM} ${STAGEDIR}${DATADIR}/rawwaves/._* ${STAGEDIR}${DATADIR}/rawwaves/*.c
diff --git a/audio/stk/distinfo b/audio/stk/distinfo
index b82f155b883f..030b90e7c85c 100644
--- a/audio/stk/distinfo
+++ b/audio/stk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637267004
-SHA256 (stk-4.6.2.tar.gz) = 573e26ccf72ce436a1dc4ee3bea05fd35e0a8e742c339c7f5b85225502238083
-SIZE (stk-4.6.2.tar.gz) = 2618125
+TIMESTAMP = 1691561974
+SHA256 (stk-5.0.0.tar.gz) = 0e97d8d2ef0d0d3dd4255fed6d71fcbd832f9977bd1031d2166cdbb865529f11
+SIZE (stk-5.0.0.tar.gz) = 2830586
diff --git a/audio/stk/files/patch-configure b/audio/stk/files/patch-configure
new file mode 100644
index 000000000000..dca9a1948cc7
--- /dev/null
+++ b/audio/stk/files/patch-configure
@@ -0,0 +1,101 @@
+--- configure.orig 2023-08-04 15:25:31 UTC
++++ configure
+@@ -6220,7 +6220,7 @@ then :
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: using OSS" >&5
+ printf "%s\n" "using OSS" >&6; }
+ api="$api -D__LINUX_OSS__"
+- LIBS="$LIBS -lossaudio"
++ #LIBS="$LIBS -lossaudio"
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for pthread_create in -lpthread" >&5
+ printf %s "checking for pthread_create in -lpthread... " >&6; }
+ if test ${ac_cv_lib_pthread_pthread_create+y}
+@@ -6228,7 +6228,7 @@ then :
+ printf %s "(cached) " >&6
+ else $as_nop
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -6260,7 +6260,7 @@ if test "x$ac_cv_lib_pthread_pthread_create" = xyes
+ then :
+ printf "%s\n" "#define HAVE_LIBPTHREAD 1" >>confdefs.h
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else $as_nop
+ as_fn_error $? "RtAudio requires the pthread library!" "$LINENO" 5
+@@ -6276,7 +6276,7 @@ then :
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: using OSS" >&5
+ printf "%s\n" "using OSS" >&6; }
+ api="$api -D__LINUX_OSS__"
+- LIBS="$LIBS -lossaudio"
++ #LIBS="$LIBS -lossaudio"
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for pthread_create in -lpthread" >&5
+ printf %s "checking for pthread_create in -lpthread... " >&6; }
+ if test ${ac_cv_lib_pthread_pthread_create+y}
+@@ -6284,7 +6284,7 @@ then :
+ printf %s "(cached) " >&6
+ else $as_nop
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -6316,7 +6316,7 @@ if test "x$ac_cv_lib_pthread_pthread_create" = xyes
+ then :
+ printf "%s\n" "#define HAVE_LIBPTHREAD 1" >>confdefs.h
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else $as_nop
+ as_fn_error $? "RtAudio requires the pthread library!" "$LINENO" 5
+@@ -6325,7 +6325,7 @@ fi
+ fi
+ ;;
+
+- *-*-linux*)
++ *-*-linux* | *-*-freebsd*)
+ # Look for ALSA flag
+
+ # Check whether --with-alsa was given.
+@@ -6617,7 +6617,7 @@ then :
+ printf %s "(cached) " >&6
+ else $as_nop
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -6649,7 +6649,7 @@ if test "x$ac_cv_lib_pthread_pthread_create" = xyes
+ then :
+ printf "%s\n" "#define HAVE_LIBPTHREAD 1" >>confdefs.h
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else $as_nop
+ as_fn_error $? "RtAudio requires the pthread library!" "$LINENO" 5
+@@ -6711,7 +6711,7 @@ then :
+ printf %s "(cached) " >&6
+ else $as_nop
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -6743,7 +6743,7 @@ if test "x$ac_cv_lib_pthread_pthread_create" = xyes
+ then :
+ printf "%s\n" "#define HAVE_LIBPTHREAD 1" >>confdefs.h
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else $as_nop
+ as_fn_error $? "RtAudio requires the pthread library!" "$LINENO" 5
diff --git a/audio/stk/files/patch-configure.ac b/audio/stk/files/patch-configure.ac
deleted file mode 100644
index 36239221a15c..000000000000
--- a/audio/stk/files/patch-configure.ac
+++ /dev/null
@@ -1,60 +0,0 @@
---- configure.ac.orig 2021-11-18 02:08:39 UTC
-+++ configure.ac
-@@ -89,7 +89,6 @@ if test "$debug" = "yes"; then
- else
- AC_SUBST( debug, [no] )
- AC_SUBST( cppflag, [] )
-- AC_SUBST( cxxflag, [-O3] )
- AC_SUBST( object_path, [Release] )
- fi
- AC_MSG_RESULT($debug)
-@@ -104,7 +103,7 @@ fi
- CPPFLAGS="$CPPFLAGS $cppflag"
-
- # For debugging and optimization ... overwrite default because it has both -g and -O2
--CXXFLAGS="$cxxflag"
-+CXXFLAGS="$CXXFLAGS $cxxflag"
-
- # Check compiler and use -Wall if gnu.
- if [test $GXX = "yes" ;] then
-@@ -154,27 +153,27 @@ api="$api -D__UNIX_JACK__"
- AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtAudio requires the pthread library!))])
- ;;
-
-- *-*-linux*)
-+ *-*-linux*|*-*-freebsd*)
- # Look for ALSA flag
-- AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)])
-- AS_IF([test "x$with_alsa" == "xyes"], [
-- api="$api -D__LINUX_ALSA__"
-- AC_MSG_RESULT(using ALSA)
-- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
-+ #AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)])
-+ #AS_IF([test "x$with_alsa" == "xyes"], [
-+ #api="$api -D__LINUX_ALSA__"
-+ #AC_MSG_RESULT(using ALSA)
-+ #AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
-
- # Look for OSS flag
- AC_ARG_WITH(oss, [ --with-oss = choose OSS API support (unixes only)])
- AS_IF([test "x$with_oss" == "xyes"], [
-- api="$api -D__LINUX_OSS__ -D__LINUX_ALSA__"
-+ api="$api -D__LINUX_OSS__"
- AC_MSG_RESULT(using OSS)
-- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(OSS support requires ALSA for RtMidi!))])
-+ #AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(OSS support requires ALSA for RtMidi!))])
-
- # If no audio api flags specified, use ALSA
-- AS_IF([test "$api" == ""], [
-- AC_MSG_RESULT(using ALSA)
-- AC_SUBST( api, [-D__LINUX_ALSA__] )
-- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
-- ])
-+ #AS_IF([test "$api" == ""], [
-+ # AC_MSG_RESULT(using ALSA)
-+ # AC_SUBST( api, [-D__LINUX_ALSA__] )
-+ # AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
-+ #])
-
- AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtAudio requires the pthread library!))
- ;;
diff --git a/audio/stk/pkg-plist b/audio/stk/pkg-plist
index 8bcbdf3de92e..82bd26ecb01f 100644
--- a/audio/stk/pkg-plist
+++ b/audio/stk/pkg-plist
@@ -102,7 +102,7 @@ include/stk/Whistle.h
include/stk/Wurley.h
include/stk/WvIn.h
include/stk/WvOut.h
-lib/libstk-4.6.2.so
+lib/libstk-5.0.0.so
lib/libstk.so
%%DATADIR%%/rawwaves/ahh.raw
%%DATADIR%%/rawwaves/bassdrum.raw