aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2021-12-16 19:48:22 +0000
committerAlex Dupre <ale@FreeBSD.org>2021-12-16 19:48:51 +0000
commitc0b2860b45d9d0512929b994ba7ef739337d79dc (patch)
treedfa90f0ba8fe1b7525bc095a0d3a2617e788b6ab
parent76649584d335b4c1b4bda9ad3653bff6416c256d (diff)
downloadports-c0b2860b45d9d0512929b994ba7ef739337d79dc.tar.gz
ports-c0b2860b45d9d0512929b994ba7ef739337d79dc.zip
lang/solidity: fix build with newer z3.
-rw-r--r--lang/solidity/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index b502fd8859fd..44fd5e4e1afe 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -34,7 +34,8 @@ CVC4_CMAKE_OFF= USE_CVC4
CMAKE_ARGS+= -DUSE_LD_GOLD=OFF -DTESTS=OFF \
-DRANGE_V3_INCLUDE_DIR="${LOCALBASE}/include" \
-DJSONCPP_INCLUDE_DIR:STRING="${LOCALBASE}/include/jsoncpp" \
- -DJSONCPP_LIB_DIR:STRING="${LOCALBASE}/lib"
+ -DJSONCPP_LIB_DIR:STRING="${LOCALBASE}/lib" \
+ -DSTRICT_Z3_VERSION=OFF
PLIST_FILES= bin/solc \
bin/solidity-upgrade \