aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-18 16:18:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-12-02 19:16:29 +0000
commitc121bf425f0236689bcd09d4215854e343d31231 (patch)
treeea57f300fc884606bc0a13e43448409d0ee98912
parent7a3d9eb2d0b5fcfb8078300060186a70609d5ac1 (diff)
downloadports-c121bf425f0236689bcd09d4215854e343d31231.tar.gz
ports-c121bf425f0236689bcd09d4215854e343d31231.zip
www/py-aiohttp: fix build with python 3.11
Forcibly run cython on all *.pyx files, as just touching them is not enough, and the package lacks facilities to cythonize automatically. Approved by: koobs (maintainer)
-rw-r--r--www/py-aiohttp/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/www/py-aiohttp/Makefile b/www/py-aiohttp/Makefile
index 2f757c4883b7..7d8f1286355b 100644
--- a/www/py-aiohttp/Makefile
+++ b/www/py-aiohttp/Makefile
@@ -41,7 +41,10 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}idna_ssl>=1.0:dns/py-idna_ssl@${PY_FLAVOR}
.endif
pre-configure:
- @${TOUCH} ${WRKSRC}/aiohttp/*.pyx
+.for file in _frozenlist _helpers _http_parser _http_writer _websocket
+ @${RM} ${WRKSRC}/aiohttp/${file}.c
+ @cd ${WRKSRC} && cython-${PYTHON_VER} -3 -o aiohttp/${file}.c aiohttp/${file}.pyx -I aiohttp
+.endfor
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/aiohttp/*.so