aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-06-25 20:55:07 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-06-25 21:05:52 +0000
commitc1e480fdcab9449576610ea83ff16f45b8f4f3bd (patch)
treeba56bade2acf991b9c7b3d573a46060958436573
parent7d30ecf443fb98ff417283fda4c3d820dc3ea0fb (diff)
downloadports-c1e480fdcab9449576610ea83ff16f45b8f4f3bd.tar.gz
ports-c1e480fdcab9449576610ea83ff16f45b8f4f3bd.zip
x11-toolkits/fox16: Genericize llvm16 fix from [1]
Checking against the operating system version doesn't make much sense to me since the problem will return if not using the base compiler. This change will also suppress warnings when building with older versions of Clang. [1] https://cgit.freebsd.org/ports/commit/?id=abad80143b961d4b2431114a4a5160d0efd04284
-rw-r--r--x11-toolkits/fox16/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/x11-toolkits/fox16/Makefile b/x11-toolkits/fox16/Makefile
index ab05351f6a92..6187abee5673 100644
--- a/x11-toolkits/fox16/Makefile
+++ b/x11-toolkits/fox16/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-opengl --with-x --with-xim
USE_LDCONFIG= yes
-CPPFLAGS+= -fPIC
+CPPFLAGS+= -fPIC -Dregister=
PLIST_SUB= MAJORVER="${MAJORVER}"
@@ -83,10 +83,6 @@ CXXFLAGS+= -fexpensive-optimizations -finline-functions
. endif
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CPPFLAGS+= -Dregister=
-.endif
-
post-patch:
# Rename man pages as in manpage.1 --> manpage-16.1 to avoid
# conflicts with fox14 and fox17