aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2023-07-01 14:33:17 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2023-07-01 17:33:36 +0000
commitc284c96d117c97120e8b4f01efa592a4fe10596b (patch)
tree59be8a6c26406f5022d6f4a831f3f5f658a26062
parentfe0a1b46a03eb90ae24667e112c6bf7c24f19a4a (diff)
downloadports-c284c96d117c97120e8b4f01efa592a4fe10596b.tar.gz
ports-c284c96d117c97120e8b4f01efa592a4fe10596b.zip
mail/spamassassin: Remove deprecated method usage in sa-update
PR: 272313 Approved by: cy (maintainer) Obtained from: https://svn.apache.org/viewvc?view=revision&revision=1910601
-rw-r--r--mail/spamassassin/Makefile2
-rw-r--r--mail/spamassassin/files/patch-sa-update.raw12
2 files changed, 13 insertions, 1 deletions
diff --git a/mail/spamassassin/Makefile b/mail/spamassassin/Makefile
index f98eb2fd343f..4cc5c6a30204 100644
--- a/mail/spamassassin/Makefile
+++ b/mail/spamassassin/Makefile
@@ -1,6 +1,6 @@
PORTNAME= spamassassin
PORTVERSION= 4.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= mail perl5
MASTER_SITES= https://archive.apache.org/dist/${PORTNAME}/source/ CPAN/Mail
DISTNAME= Mail-SpamAssassin-${PORTVERSION}
diff --git a/mail/spamassassin/files/patch-sa-update.raw b/mail/spamassassin/files/patch-sa-update.raw
new file mode 100644
index 000000000000..4a3df72b29f5
--- /dev/null
+++ b/mail/spamassassin/files/patch-sa-update.raw
@@ -0,0 +1,12 @@
+# https://svn.apache.org/viewvc?view=revision&revision=1910601
+--- sa-update.raw.orig 2022-12-14 06:03:27 UTC
++++ sa-update.raw
+@@ -1458,7 +1458,7 @@ sub do_dns_query {
+ next if !$rr; # no answer records, only rcode
+ next if $rr->type ne $rr_type;
+ # scalar context!
+- my $text = $rr->UNIVERSAL::can('txtdata') ? $rr->txtdata : $rr->rdatastr;
++ my $text = $rr->UNIVERSAL::can('txtdata') ? $rr->txtdata : $rr->rdstring;
+ push(@result,$text) if defined $text && $text ne '';
+ }
+ printf("DNS %s query: %s -> %s\n", $rr_type, $query, join(", ",@result))