aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-01-16 07:06:04 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-01-16 07:17:52 +0000
commitc2c83f08f79365059b73bbbefcc6375c2ab400bc (patch)
tree163a45f7420092a2a9145e4f0d6416c50f2a6cdf
parent72cbe1a32d80ad327e6e7390f46f3a326034c617 (diff)
downloadports-c2c83f08f79365059b73bbbefcc6375c2ab400bc.tar.gz
ports-c2c83f08f79365059b73bbbefcc6375c2ab400bc.zip
math/apache-commons-math: build empty jar file (without classes) and doesn't build with jdk 11+
1. Without target "compile" commons-math.jar was ~8KB only and without classes - whit patch it's ~2MB. 2. Doesn't build with OpenJDK 11+: "compile.source" and "compile.target" 1.5 deprecated and was removed in newer OpenJDKs. Approved by: bofh (maintainer), arrowd (mentor) Differential Revision: https://reviews.freebsd.org/D43462 MFH: 2024Q1 (cherry picked from commit 11fc1e476c9d02bff164f4f37f7ba24ca6d7d87c)
-rw-r--r--math/apache-commons-math/Makefile4
-rw-r--r--math/apache-commons-math/files/patch-build.xml11
2 files changed, 13 insertions, 2 deletions
diff --git a/math/apache-commons-math/Makefile b/math/apache-commons-math/Makefile
index 59e38cc39ec5..2939cf7ac7dc 100644
--- a/math/apache-commons-math/Makefile
+++ b/math/apache-commons-math/Makefile
@@ -1,6 +1,6 @@
PORTNAME= commons-math
PORTVERSION= 3.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math java
MASTER_SITES= APACHE_COMMONS_SOURCE \
https://repo1.maven.org/maven2/junit/junit/4.8.2/:source2
@@ -23,7 +23,7 @@ USE_ANT= yes
USE_JAVA= yes
USE_LOCALE= en_US.ISO8859-1
-ALL_TARGET= jar
+ALL_TARGET= compile jar
MAKE_ARGS= -Dlibdir=${WRKDIR} -Dnoget=true
JARFILE= ${PORTNAME:S,3,,}-3.6.jar
diff --git a/math/apache-commons-math/files/patch-build.xml b/math/apache-commons-math/files/patch-build.xml
index 256c8c63f281..57ce05cc8e36 100644
--- a/math/apache-commons-math/files/patch-build.xml
+++ b/math/apache-commons-math/files/patch-build.xml
@@ -1,5 +1,16 @@
--- build.xml.orig 2016-03-17 12:14:52 UTC
+++ build.xml
+@@ -100,8 +100,8 @@
+ <property name="source.encoding" value="UTF-8"/>
+
+ <!-- JDK level -->
+- <property name="compile.source" value="1.5"/>
+- <property name="compile.target" value="1.5"/>
++ <property name="compile.source" value="8"/>
++ <property name="compile.target" value="8"/>
+
+ <!-- Base compile classpath -->
+ <path id="compile.classpath">
@@ -174,7 +174,7 @@
<!-- ========== Unit Test Targets ========================================= -->