aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-07-18 20:38:40 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-07-18 20:38:40 +0000
commitc30305d589ace6807514a3d95df72f25c765f9a5 (patch)
treec3fa8d209d832ea1cc5802c8f95919cb28319a18
parent8e804768bbb0bea5e44dba92f7483dd1015fd9a6 (diff)
downloadports-c30305d589ace6807514a3d95df72f25c765f9a5.tar.gz
ports-c30305d589ace6807514a3d95df72f25c765f9a5.zip
devel/py-ckanapi: Add py-ckanapi 4.7
ckanapi is a command line interface and Python module for accessing the CKAN Action API. The ckanapi command line interface lets you access local and remote CKAN instances for bulk operations and simple API actions. The ckanapi Python module may be used from within a CKAN extension or in a Python 2 or Python 3 application separate from CKAN. WWW: https://github.com/ckan/ckanapi
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ckanapi/Makefile24
-rw-r--r--devel/py-ckanapi/distinfo3
-rw-r--r--devel/py-ckanapi/pkg-descr10
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5d6f22da5307..4ae2fb5bd9e4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4311,6 +4311,7 @@
SUBDIR += py-circuitbreaker
SUBDIR += py-circuits
SUBDIR += py-ciso8601
+ SUBDIR += py-ckanapi
SUBDIR += py-clang
SUBDIR += py-cld
SUBDIR += py-cle
diff --git a/devel/py-ckanapi/Makefile b/devel/py-ckanapi/Makefile
new file mode 100644
index 000000000000..bb69e5a32f23
--- /dev/null
+++ b/devel/py-ckanapi/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= ckanapi
+PORTVERSION= 4.7
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= CLI and Python module for accessing the CKAN Action API
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docopt>=0:devel/py-docopt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-slugify>=1.0:textproc/py-python-slugify@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9<2.0:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-ckanapi/distinfo b/devel/py-ckanapi/distinfo
new file mode 100644
index 000000000000..f7850a956873
--- /dev/null
+++ b/devel/py-ckanapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1658176300
+SHA256 (ckanapi-4.7.tar.gz) = 6cb1414faef384de58a0e1f648b977177db444e95073b65ed950f2a8b0f55d0d
+SIZE (ckanapi-4.7.tar.gz) = 33192
diff --git a/devel/py-ckanapi/pkg-descr b/devel/py-ckanapi/pkg-descr
new file mode 100644
index 000000000000..21865a88d223
--- /dev/null
+++ b/devel/py-ckanapi/pkg-descr
@@ -0,0 +1,10 @@
+ckanapi is a command line interface and Python module for accessing the CKAN
+Action API.
+
+The ckanapi command line interface lets you access local and remote CKAN
+instances for bulk operations and simple API actions.
+
+The ckanapi Python module may be used from within a CKAN extension or in a
+Python 2 or Python 3 application separate from CKAN.
+
+WWW: https://github.com/ckan/ckanapi