aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2021-06-05 22:58:36 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2021-06-05 23:00:24 +0000
commitc33cf04fe57592ec5c03074f022d3bfa917fd2c7 (patch)
tree515d9f4abeb7059b6c9a61eadb209b7d8af9ecaf
parentb21237d40d11d667648a771bccf61bd47d8b3803 (diff)
downloadports-c33cf04fe57592ec5c03074f022d3bfa917fd2c7.tar.gz
ports-c33cf04fe57592ec5c03074f022d3bfa917fd2c7.zip
biology/hyphy: Update to 2.5.31
-rw-r--r--biology/hyphy/Makefile2
-rw-r--r--biology/hyphy/distinfo6
-rw-r--r--biology/hyphy/files/patch-CMakeLists.txt27
3 files changed, 31 insertions, 4 deletions
diff --git a/biology/hyphy/Makefile b/biology/hyphy/Makefile
index 840581d4926e..34850adee62a 100644
--- a/biology/hyphy/Makefile
+++ b/biology/hyphy/Makefile
@@ -1,5 +1,5 @@
PORTNAME= hyphy
-DISTVERSION= 2.5.30
+DISTVERSION= 2.5.31
CATEGORIES= biology
MAINTAINER= jrm@FreeBSD.org
diff --git a/biology/hyphy/distinfo b/biology/hyphy/distinfo
index f4ad79792145..9300d52387fe 100644
--- a/biology/hyphy/distinfo
+++ b/biology/hyphy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1617844705
-SHA256 (veg-hyphy-2.5.30_GH0.tar.gz) = 8850964cfe75b0053af49994be7d847e7827a6117f926f45db5798d12e54bad1
-SIZE (veg-hyphy-2.5.30_GH0.tar.gz) = 5341483
+TIMESTAMP = 1622916930
+SHA256 (veg-hyphy-2.5.31_GH0.tar.gz) = 2fa27ba3c4464ee2239570ebf6a038c6a3e216350ba8c3c22e43de0cb9c5dbd7
+SIZE (veg-hyphy-2.5.31_GH0.tar.gz) = 5342292
diff --git a/biology/hyphy/files/patch-CMakeLists.txt b/biology/hyphy/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..704bbe9368b6
--- /dev/null
+++ b/biology/hyphy/files/patch-CMakeLists.txt
@@ -0,0 +1,27 @@
+--- CMakeLists.txt.orig 2021-06-05 18:31:25 UTC
++++ CMakeLists.txt
+@@ -307,21 +307,16 @@ endif(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+ #-------------------------------------------------------------------------------
+ find_package(CURL)
+ if(${CURL_FOUND})
+- #if(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+- # set(DEFAULT_LIBRARIES " crypto curl ssl")
+- #else(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+- # set(DEFAULT_LIBRARIES "dl crypto curl ssl")
+- #endif(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+ message(${CURL_LIBRARIES})
+- string(APPEND DEFAULT_LIBRARIES " " ${CURL_LIBRARIES})
++ list(APPEND DEFAULT_LIBRARIES ${CURL_LIBRARIES})
+ add_definitions (-D__HYPHYCURL__)
+ endif(${CURL_FOUND})
+
+ if(NOT NOZLIB)
+ find_package(ZLIB 1.2.9)
+ if(${ZLIB_FOUND})
+- string(APPEND DEFAULT_LIBRARIES " " ${ZLIB_LIBRARIES})
+- include_directories(${ZLIB_INCLUDE_DIRS})
++ list(APPEND DEFAULT_LIBRARIES ${ZLIB_LIBRARIES})
++ include_directories(${ZLIB_INCLUDE_DIRS})
+ add_definitions (-D__ZLIB__)
+ endif(${ZLIB_FOUND})
+ endif(NOT NOZLIB)