aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-08-21 15:56:04 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-08-21 16:02:13 +0000
commitc3834b63e4b3b8c921929442b4fce3c01a98ba9b (patch)
treef9f0ae750e746a327afa4780aa88716cbb03faf9
parentf329614a04012911c0a00b81ee113132a0709960 (diff)
downloadports-c3834b63e4b3b8c921929442b4fce3c01a98ba9b.tar.gz
ports-c3834b63e4b3b8c921929442b4fce3c01a98ba9b.zip
sysutils/e2fsprogs: regression fix update 1.46.4
Release Notes: http://e2fsprogs.sourceforge.net/e2fsprogs-release.html#1.46.4 and local port changes: * do not hardlink to symlinks, neither dump/restore nor our libarchive-based tar can copy them * pkg-install texts add a blank before the full stop character, to ease copy & paste * tst/bitops.c patch was integrated upstream Since this contains regression fixes vs. 1.46.3: MFH: 2021Q3 (cherry picked from commit 99d4ddef914d90456d0120cfcf2b88af1b7dcdd5)
-rw-r--r--sysutils/e2fsprogs/Makefile9
-rw-r--r--sysutils/e2fsprogs/distinfo6
-rw-r--r--sysutils/e2fsprogs/files/patch-lib__ext2fs__tst_bitops.c11
-rw-r--r--sysutils/e2fsprogs/pkg-install14
4 files changed, 17 insertions, 23 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 2d8c3dbf78be..42347389b44d 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -1,7 +1,7 @@
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
PORTNAME= e2fsprogs
-PORTVERSION= 1.46.3
+PORTVERSION= 1.46.4
PORTREVISION?= 0
CATEGORIES?= sysutils
MASTER_SITES= KERNEL_ORG/linux/kernel/people/tytso/${PORTNAME}/v${PORTVERSION}
@@ -302,10 +302,9 @@ post-install:
# yet stage-qa warns about these on 2020-09-16:
${LN} -fs /sbin/fsck_ext2fs ${STAGEDIR}${PREFIX}/sbin/
${LN} -fs /sbin/e2fsck ${STAGEDIR}${PREFIX}/sbin/
- # these are made hardlinks to symlinks - -P avoids following them to /sbin:
- ${LN} -fP ${STAGEDIR}${PREFIX}/sbin/e2fsck ${STAGEDIR}${PREFIX}/sbin/fsck.ext2
- ${LN} -fP ${STAGEDIR}${PREFIX}/sbin/e2fsck ${STAGEDIR}${PREFIX}/sbin/fsck.ext3
- ${LN} -fP ${STAGEDIR}${PREFIX}/sbin/e2fsck ${STAGEDIR}${PREFIX}/sbin/fsck.ext4
+ ${LN} -fs e2fsck ${STAGEDIR}${PREFIX}/sbin/fsck.ext2
+ ${LN} -fs e2fsck ${STAGEDIR}${PREFIX}/sbin/fsck.ext3
+ ${LN} -fs e2fsck ${STAGEDIR}${PREFIX}/sbin/fsck.ext4
# now the remainder of the usual post-install jobs:
${INSTALL_MAN} ${FILESDIR}/fsck_ext2fs.8 ${STAGEDIR}${PREFIX}/man/man8/
.if ${PORT_OPTIONS:MDOCS}
diff --git a/sysutils/e2fsprogs/distinfo b/sysutils/e2fsprogs/distinfo
index ecf7673b166a..0722d23204bc 100644
--- a/sysutils/e2fsprogs/distinfo
+++ b/sysutils/e2fsprogs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1628091626
-SHA256 (e2fsprogs-1.46.3.tar.xz) = 86d1580facdd49f2e0e6b027e26b1e6c48af538762dc40aeed2a87153c1f11b7
-SIZE (e2fsprogs-1.46.3.tar.xz) = 7024896
+TIMESTAMP = 1629558567
+SHA256 (e2fsprogs-1.46.4.tar.xz) = b11042533c1b1dcf17512f0da48e05b0c573dada1dd8b762864d10f4dc399713
+SIZE (e2fsprogs-1.46.4.tar.xz) = 7035200
diff --git a/sysutils/e2fsprogs/files/patch-lib__ext2fs__tst_bitops.c b/sysutils/e2fsprogs/files/patch-lib__ext2fs__tst_bitops.c
deleted file mode 100644
index d6285d651187..000000000000
--- a/sysutils/e2fsprogs/files/patch-lib__ext2fs__tst_bitops.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/ext2fs/tst_bitops.c.orig 2014-10-16 00:29:23 UTC
-+++ lib/ext2fs/tst_bitops.c
-@@ -104,7 +104,7 @@ int main(int argc, char **argv)
- bigarray = malloc(1 << 29);
- if (!bigarray) {
- fprintf(stderr, "Failed to allocate scratch memory!\n");
-- exit(1);
-+ exit(0);
- }
-
- bigarray[BIG_TEST_BIT >> 3] = 0;
diff --git a/sysutils/e2fsprogs/pkg-install b/sysutils/e2fsprogs/pkg-install
index 25259ebfc8a3..0c954eaf8179 100644
--- a/sysutils/e2fsprogs/pkg-install
+++ b/sysutils/e2fsprogs/pkg-install
@@ -34,13 +34,16 @@ POST-INSTALL)
else
rc=0
grep -q ext4dev ${PKG_PREFIX}/etc/mke2fs.conf || rc=$?
+ # !!! the echo messages below deliberately contain spacing errors
+ # so that the file names can be double-clicked in a typical console
+ # window for copying and pasting without keen targeting with the mouse.
case $rc in
1) # ext4dev not found (old name)
cp -f -p ${PKG_PREFIX}/etc/mke2fs.conf.dist \
${PKG_PREFIX}/etc/mke2fs.conf.e2fsprogs-new
echo "==========================================================================="
echo "Warning: installing mke2fs.conf in ${PKG_PREFIX}/etc/mke2fs.conf.e2fsprogs-new"
- echo "Check to see if you need to update your ${PKG_PREFIX}/etc/mke2fs.conf"
+ echo "Check to see if you need to update your ${PKG_PREFIX}/etc/mke2fs.conf ."
echo "==========================================================================="
;;
0) # ext4dev found (old name)
@@ -50,7 +53,7 @@ POST-INSTALL)
${PKG_PREFIX}/etc/mke2fs.conf
echo "==========================================================================="
echo "Your mke2fs.conf is too old. Backing up old version in"
- echo "${PKG_PREFIX}/etc/mke2fs.conf.e2fsprogs-old. Please check to see"
+ echo "${PKG_PREFIX}/etc/mke2fs.conf.e2fsprogs-old . Please check to see"
echo "if you have any local customizations that you wish to preserve."
echo "==========================================================================="
;;
@@ -67,13 +70,16 @@ POST-INSTALL)
;;
DEINSTALL)
+ # !!! the echo messages below deliberately contain spacing errors
+ # so that the file names can be double-clicked in a typical console
+ # window for copying and pasting without keen targeting with the mouse.
if cmp -s ${PKG_PREFIX}/etc/mke2fs.conf \
${PKG_PREFIX}/etc/mke2fs.conf.dist
then
rm -f ${PKG_PREFIX}/etc/mke2fs.conf
else
echo "If and only if you are deleting e2fsprogs forever,"
- echo "remember to delete ${PKG_PREFIX}/etc/mke2fs.conf."
+ echo "remember to delete ${PKG_PREFIX}/etc/mke2fs.conf ."
fi
# e2fsck.conf is no longer part of the distribution, but still supported,
# => no pkg-list @sample line possible
@@ -81,7 +87,7 @@ DEINSTALL)
if test -f ${PKG_PREFIX}/etc/e2fsck.conf
then
echo "If and only if you are deleting e2fsprogs forever,"
- echo "remember to delete ${PKG_PREFIX}/etc/e2fsck.conf."
+ echo "remember to delete ${PKG_PREFIX}/etc/e2fsck.conf ."
fi
;;
esac