aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-25 16:54:44 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-25 16:56:04 +0000
commitc3b8d9a080d88eea9850551dfefbdc3604bbf085 (patch)
tree927d9a53a83f8373543b87ed434ea91c9fd46b06
parent9167af9a47587bec5ac64e59b191257722630162 (diff)
downloadports-c3b8d9a080d88eea9850551dfefbdc3604bbf085.tar.gz
ports-c3b8d9a080d88eea9850551dfefbdc3604bbf085.zip
lang/python-tools: fix for python 3.9 and later
While here, add NO_ARCH Approved by: portmgr blanket
-rw-r--r--lang/python-tools/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/lang/python-tools/Makefile b/lang/python-tools/Makefile
index 6670a6dc75e8..f4296366268d 100644
--- a/lang/python-tools/Makefile
+++ b/lang/python-tools/Makefile
@@ -16,12 +16,13 @@ PORTSCOUT= ignore:1
USES= python:3.6+ shebangfix tar:xz
USE_PYTHON= flavors concurrent
NO_BUILD= yes
+NO_ARCH= yes
DIST_SUBDIR= python
DISTINFO_FILE= ${.CURDIR}/../python${PYTHON_SUFFIX}/distinfo
WRKSRC_SUBDIR= Tools/scripts
-SCRIPT_FILES= byteyears checkpyc copytime crlf dutree \
+SCRIPT_FILES= byteyears copytime crlf dutree \
lfcr ptags untabify
PYLIB_FILES= tabnanny timeit
PLIST_FILES= ${SCRIPT_FILES:C|^|bin/|} ${PYLIB_FILES:C|^|bin/|}
@@ -29,6 +30,12 @@ PLIST_FILES= ${SCRIPT_FILES:C|^|bin/|} ${PYLIB_FILES:C|^|bin/|}
SHEBANG_FILES= ${SCRIPT_FILES:C|$|.py|} \
${PYLIB_FILES:C|.*|../../Lib/&.py|}
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30900
+SCRIPT_FILES+= checkpyc
+.endif
+
do-install:
.for fname in ${SCRIPT_FILES}
${INSTALL_SCRIPT} ${INSTALL_WRKSRC}/${fname}.py \
@@ -39,4 +46,4 @@ do-install:
${STAGEDIR}${PREFIX}/bin/${fname}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>