aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-08-07 15:29:41 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-08-07 15:34:53 +0000
commitc45834e17fc487ddb045a2507c3647b60789c8ca (patch)
tree7f3beffadd9ac2cec06208ce89b247b09ec9fd11
parent39f013473827829f5d843f90db10a8b9d0e5f805 (diff)
downloadports-c45834e17fc487ddb045a2507c3647b60789c8ca.tar.gz
ports-c45834e17fc487ddb045a2507c3647b60789c8ca.zip
textproc/py-jq: update to v1.2.1
Adds Python 3.10 support (see [1]), else see the Changelog: https://github.com/mwilliamson/jq.py/blob/1.2.1/CHANGELOG.rst#changelog Note that Python 3.10 cannot currently execute self-tests, assistance solicited: ______ ERROR collecting tests/jq_old_tests.py _____ <frozen importlib._bootstrap>:939: in _find_spec ??? E AttributeError: 'AssertionRewritingHook' object has no attribute 'find_spec' During handling of the above exception, another exception occurred: /usr/local/lib/python3.10/site-packages/py/_path/local.py:704: in pyimport __import__(modname) <frozen importlib._bootstrap>:1027: in _find_and_load ??? <frozen importlib._bootstrap>:1002: in _find_and_load_unlocked ??? <frozen importlib._bootstrap>:941: in _find_spec ??? <frozen importlib._bootstrap>:915: in _find_spec_legacy ??? /usr/local/lib/python3.10/site-packages/_pytest/assertion/rewrite.py:169: in find_module source_stat, co = _rewrite_test(self.config, fn_pypath) /usr/local/lib/python3.10/site-packages/_pytest/assertion/rewrite.py:406: in _rewrite_test co = compile(tree, fn.strpath, "exec", dont_inherit=True) E TypeError: required field "lineno" missing from alias ___________________________________________________ [1] https://github.com/mwilliamson/jq.py/commit/337c0f8baf77a59f9054eefc07460fffe91702ce
-rw-r--r--textproc/py-jq/Makefile20
-rw-r--r--textproc/py-jq/distinfo8
2 files changed, 20 insertions, 8 deletions
diff --git a/textproc/py-jq/Makefile b/textproc/py-jq/Makefile
index 8fb4f53df061..587277822451 100644
--- a/textproc/py-jq/Makefile
+++ b/textproc/py-jq/Makefile
@@ -1,8 +1,9 @@
PORTNAME= jq
-PORTVERSION= 1.1.3
+PORTVERSION= 1.2.1
CATEGORIES= textproc python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= CHEESESHOP LOCAL/mandree:mandree
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} jq-1.2.1-tests${EXTRACT_SUFX}:mandree
MAINTAINER= mandree@FreeBSD.org
COMMENT= jq.py: a lightweight and flexible JSON processor
@@ -10,16 +11,25 @@ COMMENT= jq.py: a lightweight and flexible JSON processor
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${RUN_DEPENDS}
LIB_DEPENDS= libjq.so:textproc/jq \
libonig.so:devel/oniguruma
-
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
-BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
-USES= localbase python:3.4+
+USES= localbase python:3.5+
USE_PYTHON= autoplist distutils
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/jq*.so
+do-test:
+ cd ${WRKSRC} && ${SETENV} \
+ PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR} \
+ ${PYTHON_CMD} -m pytest -v tests/
+
.include <bsd.port.mk>
diff --git a/textproc/py-jq/distinfo b/textproc/py-jq/distinfo
index a6397f5fe49e..1ae9e5b0e920 100644
--- a/textproc/py-jq/distinfo
+++ b/textproc/py-jq/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1621674990
-SHA256 (jq-1.1.3.tar.gz) = f9ec1dfa7f9875b04495f3e08e85ee96f37a3b843e5bca738a3300732865dde7
-SIZE (jq-1.1.3.tar.gz) = 71393
+TIMESTAMP = 1628345619
+SHA256 (jq-1.2.1.tar.gz) = 73ce588025495e6ebcda20bb9e64b6d9f3f1657c22895143ae243899ac710cbc
+SIZE (jq-1.2.1.tar.gz) = 72435
+SHA256 (jq-1.2.1-tests.tar.gz) = 7648084f434896eda31bb5e09a4f6d32ebb561660c95655e08346c33be9b3ece
+SIZE (jq-1.2.1-tests.tar.gz) = 2856